aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2023-11-11 22:45:41 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2023-11-11 22:56:02 +0000
commit98838077216800459aa19d9954fd8fd6407cf35d (patch)
tree0bdb98f7ec13209cae704841db69081147108c10
parent9e3d4a452c9b7180005ff21e8d9e4ceaf40317af (diff)
downloadports-98838077216800459aa19d9954fd8fd6407cf35d.tar.gz
ports-98838077216800459aa19d9954fd8fd6407cf35d.zip
www/h2o-devel: update to 20231107 snapshot
- fix i386 builds
-rw-r--r--www/h2o-devel/Makefile8
-rw-r--r--www/h2o-devel/distinfo6
-rw-r--r--www/h2o-devel/files/patch-deps_quicly_lib_quicly.c10
3 files changed, 17 insertions, 7 deletions
diff --git a/www/h2o-devel/Makefile b/www/h2o-devel/Makefile
index 1322b991903a..49d731d58d6b 100644
--- a/www/h2o-devel/Makefile
+++ b/www/h2o-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= h2o
DISTVERSIONPREFIX= v
-DISTVERSION= 2.3.0-dev.20231010
+DISTVERSION= 2.3.0-dev.20231107
CATEGORIES= www
PKGNAMESUFFIX= -devel
@@ -21,14 +21,14 @@ LIB_DEPENDS= libuv.so:devel/libuv
USES= cmake:noninja compiler:c11 cpe perl5 pkgconfig shebangfix ssl
CPE_VENDOR= dena
USE_GITHUB= yes
-GH_TAGNAME= 8f8e35a
+GH_TAGNAME= b15937e
+
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
SHEBANG_FILES= share/h2o/start_server
-CMAKE_ARGS+= -DBUILD_SHARED_LIBS=OFF \
- -DWITH_BUNDLED_SSL=OFF
+CMAKE_ARGS+= -DBUILD_SHARED_LIBS=OFF
CONFLICTS= h2o
diff --git a/www/h2o-devel/distinfo b/www/h2o-devel/distinfo
index 739d40a07990..2ba3cd8e0770 100644
--- a/www/h2o-devel/distinfo
+++ b/www/h2o-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1696944296
-SHA256 (h2o-h2o-v2.3.0-dev.20231010-8f8e35a_GH0.tar.gz) = 639ef6a4adf5a33606a427a9c7d1e60cca05d8612ddc3a2831e31aee6f6b5a85
-SIZE (h2o-h2o-v2.3.0-dev.20231010-8f8e35a_GH0.tar.gz) = 30559011
+TIMESTAMP = 1699740447
+SHA256 (h2o-h2o-v2.3.0-dev.20231107-b15937e_GH0.tar.gz) = 3d70ad17d24f9e8ec575c235004f22ef3cf4d2c93f95f351928d05cbc5ed0c76
+SIZE (h2o-h2o-v2.3.0-dev.20231107-b15937e_GH0.tar.gz) = 30565861
diff --git a/www/h2o-devel/files/patch-deps_quicly_lib_quicly.c b/www/h2o-devel/files/patch-deps_quicly_lib_quicly.c
new file mode 100644
index 000000000000..b105a79ab8bb
--- /dev/null
+++ b/www/h2o-devel/files/patch-deps_quicly_lib_quicly.c
@@ -0,0 +1,10 @@
+--- deps/quicly/lib/quicly.c.orig 2023-11-11 22:44:34 UTC
++++ deps/quicly/lib/quicly.c
+@@ -21,6 +21,7 @@
+ */
+ #include <assert.h>
+ #include <inttypes.h>
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <netinet/ip.h>
+ #include <pthread.h>