aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2023-06-21 23:53:11 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2023-06-21 23:53:11 +0000
commit990aeac4b416ec4ef4e626b2aa312df63eceff5c (patch)
tree8956cd2d565ee4419d3363b706526ce71754fc9c
parent6be7ccd6164ed70f7d171c7a71c83357a6b1d791 (diff)
downloadports-990aeac4b416ec4ef4e626b2aa312df63eceff5c.tar.gz
ports-990aeac4b416ec4ef4e626b2aa312df63eceff5c.zip
lang/elixir-devel: update to 1.15.0
- https://elixir-lang.org/blog/2023/06/19/elixir-v1-15-0-released/ Note that Elixir now *requires* OTP25+ or better at runtime. For the -devel flavour you are still free to choose OTP25 or OTP26, but the default OTP24 from lang/erlang will *not* work.
-rw-r--r--UPDATING8
-rw-r--r--lang/elixir-devel/Makefile4
-rw-r--r--lang/elixir-devel/distinfo10
-rw-r--r--lang/elixir-devel/pkg-message9
-rw-r--r--lang/elixir-devel/pkg-plist6
5 files changed, 24 insertions, 13 deletions
diff --git a/UPDATING b/UPDATING
index 4988aa70f5bc..144a7b4d1df3 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20230620:
+ AFFECTS: users of lang/elixir-devel
+ AUTHOR: dch@FreeBSD.org
+
+ Note that Elixir now *requires* OTP25+ or better at runtime.
+ For the -devel flavour you are still free to choose OTP25 or
+ OTP26, but the default OTP24 from lang/erlang will *not* work.
+
20230618:
AFFECTS: users of devel/soft-serve
AUTHOR: ashish@FreeBSD.org
diff --git a/lang/elixir-devel/Makefile b/lang/elixir-devel/Makefile
index da5fee382f2f..87ce3f925c63 100644
--- a/lang/elixir-devel/Makefile
+++ b/lang/elixir-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= elixir
DISTVERSIONPREFIX= v
-DISTVERSION= 1.15.0-rc.2
+DISTVERSION= 1.15.0
CATEGORIES= lang
MASTER_SITES+= https://github.com/elixir-lang/elixir/releases/download/${DISTVERSIONPREFIX}${DISTVERSION}/:doc
PKGNAMESUFFIX= -devel
@@ -33,7 +33,7 @@ MAKE_ENV+= MAN_PREFIX=${PREFIX}/man \
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
-ERLANG_VER?= 24
+ERLANG_VER?= 25
.include <bsd.port.options.mk>
diff --git a/lang/elixir-devel/distinfo b/lang/elixir-devel/distinfo
index 7731d0ebf816..51715b4365d2 100644
--- a/lang/elixir-devel/distinfo
+++ b/lang/elixir-devel/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1686691136
-SHA256 (elixir/1.15.0.r.2/Docs.zip) = b3e69262c96bd133acdf767b9560d5cb7484f56861551f24c860852bcc1f324f
-SIZE (elixir/1.15.0.r.2/Docs.zip) = 4188118
-SHA256 (elixir/1.15.0.r.2/elixir-lang-elixir-v1.15.0-rc.2_GH0.tar.gz) = 9ba0153d0edac70d00c8f7cf2758030f744626c59f0950ac1fb4a36c2ecd4af9
-SIZE (elixir/1.15.0.r.2/elixir-lang-elixir-v1.15.0-rc.2_GH0.tar.gz) = 3145107
+TIMESTAMP = 1687358672
+SHA256 (elixir/1.15.0/Docs.zip) = 45449bedec04eb19a911ff90ce8a656fc9f9e3c97a5f2665e5551b7b68d3aa2b
+SIZE (elixir/1.15.0/Docs.zip) = 4185278
+SHA256 (elixir/1.15.0/elixir-lang-elixir-v1.15.0_GH0.tar.gz) = 0f4df7574a5f300b5c66f54906222cd46dac0df7233ded165bc8e80fd9ffeb7a
+SIZE (elixir/1.15.0/elixir-lang-elixir-v1.15.0_GH0.tar.gz) = 3144933
diff --git a/lang/elixir-devel/pkg-message b/lang/elixir-devel/pkg-message
index dfdb9e03e24e..dfe1cd411cea 100644
--- a/lang/elixir-devel/pkg-message
+++ b/lang/elixir-devel/pkg-message
@@ -4,8 +4,10 @@
Elixir requires a compatible Erlang/OTP runtime. Ensure that you have
one of the following installed:
-- lang/erlang
-- lang/erlang-runtime24 or newer
+- lang/erlang-runtime25 or newer
+- lang/erlang-runtime26 or newer
+
+Note that lang/erlang and erlang-runtime24 are no longer compatible.
EOM
}
{ type: upgrade
@@ -13,9 +15,10 @@ EOM
Elixir requires a compatible Erlang/OTP runtime. Ensure that you have
one of the following installed, as you prefer:
-- lang/erlang
- lang/erlang-runtime25 or newer
+- lang/erlang-runtime26 or newer
+Note that lang/erlang and erlang-runtime24 are no longer compatible.
EOM
}
]
diff --git a/lang/elixir-devel/pkg-plist b/lang/elixir-devel/pkg-plist
index d83ff85c2bbf..458e99b30cd7 100644
--- a/lang/elixir-devel/pkg-plist
+++ b/lang/elixir-devel/pkg-plist
@@ -99,8 +99,8 @@
%%PORTDOCS%%%%DOCSDIR%%/elixir/dist/merriweather-vietnamese-300-italic-EHHNZPUO.woff2
%%PORTDOCS%%%%DOCSDIR%%/elixir/dist/merriweather-vietnamese-300-normal-U376L4Z4.woff2
%%PORTDOCS%%%%DOCSDIR%%/elixir/dist/remixicon-NKANDIL5.woff2
-%%PORTDOCS%%%%DOCSDIR%%/elixir/dist/search_items-ECBB741F.js
-%%PORTDOCS%%%%DOCSDIR%%/elixir/dist/sidebar_items-6A89D53A.js
+%%PORTDOCS%%%%DOCSDIR%%/elixir/dist/search_items-6F601D23.js
+%%PORTDOCS%%%%DOCSDIR%%/elixir/dist/sidebar_items-3926EC1A.js
%%PORTDOCS%%%%DOCSDIR%%/elixir/docs_config.js
%%PORTDOCS%%%%DOCSDIR%%/elixir/DynamicSupervisor.html
%%PORTDOCS%%%%DOCSDIR%%/elixir/Enum.EmptyError.html
@@ -319,7 +319,7 @@
%%PORTDOCS%%%%DOCSDIR%%/logger/dist/merriweather-vietnamese-300-italic-EHHNZPUO.woff2
%%PORTDOCS%%%%DOCSDIR%%/logger/dist/merriweather-vietnamese-300-normal-U376L4Z4.woff2
%%PORTDOCS%%%%DOCSDIR%%/logger/dist/remixicon-NKANDIL5.woff2
-%%PORTDOCS%%%%DOCSDIR%%/logger/dist/search_items-47226FBF.js
+%%PORTDOCS%%%%DOCSDIR%%/logger/dist/search_items-B0E94E47.js
%%PORTDOCS%%%%DOCSDIR%%/logger/dist/sidebar_items-3A2299AD.js
%%PORTDOCS%%%%DOCSDIR%%/logger/docs_config.js
%%PORTDOCS%%%%DOCSDIR%%/logger/index.html