aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-11-05 01:44:11 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-11-05 01:48:25 +0000
commit999db79989e8558d63cb9442eb9ced71b28812cd (patch)
tree23ea297de43cda345c22677d138aa5b7cfbbc6d1
parent2fb8a4999bd5bfed0c397326fe42b768e17be114 (diff)
downloadports-999db79989e8558d63cb9442eb9ced71b28812cd.tar.gz
ports-999db79989e8558d63cb9442eb9ced71b28812cd.zip
emulators/qemu41: UNBREAK for 13.X and later
- Mark DEPRECATED as there are more recent versions in the tree - Update pkg-descr as https://oszoo.org no longer hosts qemu images and is totally an irrelevent site - Do some housekeeping to remove stage-qa errors
-rw-r--r--emulators/qemu41/Makefile16
-rw-r--r--emulators/qemu41/pkg-descr19
-rw-r--r--emulators/qemu41/pkg-plist2
3 files changed, 23 insertions, 14 deletions
diff --git a/emulators/qemu41/Makefile b/emulators/qemu41/Makefile
index baaa315a50c9..2f7b86f8bacf 100644
--- a/emulators/qemu41/Makefile
+++ b/emulators/qemu41/Makefile
@@ -13,11 +13,14 @@ COMMENT?= QEMU CPU Emulator - 4.1.X branch
LICENSE= GPLv2
+DEPRECATED= Use emulators/qemu or emulators/qemu-devel
+EXPIRATION_DATE=2021-12-10
+
BUILD_DEPENDS= sphinx-build:textproc/py-sphinx@${PY_FLAVOR}
-LIB_DEPENDS?= libnettle.so:security/nettle \
+LIB_DEPENDS?= libepoxy.so:graphics/libepoxy \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libepoxy.so:graphics/libepoxy \
+ libnettle.so:security/nettle \
libpcre2-8.so:devel/pcre2
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 powerpc64le
@@ -96,7 +99,8 @@ VDE_LIB_DEPENDS= libvdeplug.so:net/vde2
X11_CONFIGURE_ENABLE= sdl
X11_USE= SDL=sdl2 XORG=x11,xext GNOME=gdkpixbuf2
X11_USES= sdl
-X86_TARGETS_USE_OFF= XORG=pixman,x11
+X86_TARGETS_LIB_DEPENDS_OFF= libharfbuzz.so:print/harfbuzz
+X86_TARGETS_USE_OFF= GL=gbm XORG=pixman,x11
X86_TARGETS_USES_OFF= xorg
PORTDOCS?= docs interop/.buildinfo interop/* qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
@@ -134,6 +138,12 @@ MAKE_ARGS+= ARCH=ppc64
CONFIGURE_ARGS+= --sparc_cpu=v9
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300000
+PLIST_SUB+= IVSHMEM=""
+.else
+PLIST_SUB+= IVSHMEM="@comment "
+.endif
+
PLIST_SUB+= LINUXBOOT_DMA=""
post-patch-CDROM_DMA-off:
diff --git a/emulators/qemu41/pkg-descr b/emulators/qemu41/pkg-descr
index 018952f53cf1..670ece758532 100644
--- a/emulators/qemu41/pkg-descr
+++ b/emulators/qemu41/pkg-descr
@@ -1,19 +1,16 @@
-QEMU is a FAST! processor emulator using dynamic translation to achieve
-good emulation speed.
+QEMU is a FAST! processor emulator using dynamic translation to achieve good
+emulation speed.
QEMU has two operating modes:
* Full system emulation. In this mode, QEMU emulates a full system
-(for example a PC), including a processor and various peripherials.
-It can be used to launch different Operating Systems without rebooting
-the PC or to debug system code.
+ (for example a PC), including a processor and various peripherials.
+ It can be used to launch different Operating Systems without rebooting
+ the PC or to debug system code.
* User mode emulation (Linux host only). In this mode, QEMU can launch
-Linux processes compiled for one CPU on another CPU. It can be used to
-launch the Wine Windows API emulator or to ease cross-compilation and
-cross-debugging.
+ Linux processes compiled for one CPU on another CPU. It can be used to
+ launch the Wine Windows API emulator or to ease cross-compilation and
+ cross-debugging.
As QEMU requires no host kernel patches to run, it is very safe and easy to use.
-See also the preconfigured system images on http://oszoo.org/
-Many live cd isos also work.
-
WWW: http://wiki.qemu.org/Main_Page
diff --git a/emulators/qemu41/pkg-plist b/emulators/qemu41/pkg-plist
index 914c0fda4f58..519a8690d847 100644
--- a/emulators/qemu41/pkg-plist
+++ b/emulators/qemu41/pkg-plist
@@ -1,4 +1,6 @@
bin/elf2dmp
+%%IVSHMEM%%bin/ivshmem-client
+%%IVSHMEM%%bin/ivshmem-server
bin/qemu-edid
bin/qemu-ga
bin/qemu-i386