aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-07-25 11:50:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-07-25 11:50:32 +0000
commit9a74edf16627f0839415c57ce91636a70d3eb2bd (patch)
tree897c5c01609f41661bd477576e7cd8ec235053fa
parent7e35a471754c71abd510ae2773d102b9fa7101c1 (diff)
downloadports-9a74edf16627f0839415c57ce91636a70d3eb2bd.tar.gz
ports-9a74edf16627f0839415c57ce91636a70d3eb2bd.zip
- Pass maintainership to submitter
- Update to 0.6.2 - Cleanup and optimization PR: ports/100692 Submitted by: Stanislav Sedov <ssedov(at)mbsd.msk.ru> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=168718
-rw-r--r--lang/gforth/Makefile94
-rw-r--r--lang/gforth/distinfo6
-rw-r--r--lang/gforth/files/patch-engine::Makefile.in12
-rw-r--r--lang/gforth/files/patch-engine::signals.c21
-rw-r--r--lang/gforth/files/patch-getopt.c16
-rw-r--r--lang/gforth/pkg-plist96
6 files changed, 49 insertions, 196 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 28239a8c57be..e3ab84cb71cb 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -6,90 +6,51 @@
#
PORTNAME= gforth
-PORTVERSION= 0.6.1
-PORTREVISION= 2
+PORTVERSION= 0.6.2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gforth
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= Fast and portable Forth system
-# BROKEN= 0.6.2 runtime does Segmentation Fault at compilation time !
-# so, no update is planned right now... sorry.
-
-#ONLY_FOR_ARCHS= i386 amd64 ia64
-
-# Global variables
-#
-
STRIP= #none
GNU_CONFIGURE= yes
-USE_GMAKE= yes
CONFIGURE_ENV= CFLAGS=${CFLAGS:N-O*:N-f*}
-MAKE_ENV= CFLAGS=${CFLAGS:N-O*:N-f*}
+USE_GMAKE= yes
ALL_TARGET= all info
+USE_GNOME= gnometarget
+USE_EMACS= yes
+EMACS_PORT_NAME?= emacs22
+EMACS_NO_BUILD_DEPENDS= yes
+EMACS_NO_RUN_DEPENDS= yes
+
PLIST_SUB= PORTVERSION="${PORTVERSION}" \
- EMACS_DIR="${EMACS_DIR:S,^${PREFIX}/,,}" \
- FORTH_DIR="${FORTH_DIR:S,^${PREFIX}/,,}" \
- LIB_DIR="${LIB_DIR:S,^${PREFIX}/,,}" \
+ EMACS_DIR="${EMACS_SITE_LISPDIR}" \
WORDSIZE=${WORDSIZE} BYTEORDER=${BYTEORDER}
+DOC_FILES= AUTHORS BUGS Benchres COPYING COPYING.DOC \
+ INSTALL INSTALL.BINDIST NEWS README \
+ NEWS.vmgen README.vmgen ToDo
+
MAN1= gforth.1
INFO= gforth vmgen
+PORTDOCS= *
-# Local variables
-#
+.include <bsd.port.pre.mk>
-.if ${MACHINE_ARCH} == i386
+.if ${ARCH} == i386
WORDSIZE=32
.else
WORDSIZE=64
.endif
-.if ${MACHINE_ARCH} == sparc64
+.if ${ARCH} == sparc64
BYTEORDER=b
.else
BYTEORDER=l
.endif
-DOC_FILES= AUTHORS BUGS Benchres COPYING COPYING.DOC \
- INSTALL INSTALL.BINDIST NEWS README \
- NEWS.vmgen README.vmgen ToDo
-
-LIB_DIR= ${PREFIX}/lib/${PKGBASE}
-
-EMACS_FILES= gforth.el
-EMACS_DIR= ${PREFIX}/share/emacs/site-lisp
-
-EMPTY_FILES= siteinit.fs
-FORTH_DIR= ${DATADIR}/site-forth
-
-EMPTY_DIRS= generic hppa ia64 m68k power sparc
-EMPTY_DIRS+= 4stack 6502 8086 avr c165 h8 misc sharc shboom
-ARCH_DIR= ${DATADIR}/${PORTVERSION}/arch
-
-# Post-extract
-#
-
-post-extract: remove-info-files
-
-remove-info-files:
- @${RM} -f ${WRKSRC}/doc/*.info*
-
-# Post-patch
-#
-
-post-patch: patch-makefiles
-
-patch-makefiles:
- @${REINPLACE_CMD} -e 's|makeinfo|makeinfo --no-split|g' \
- ${WRKSRC}/Makefile.in
-
-#
-# Post-install
-#
-
post-install: install-doc install-el remove-empty-files remove-empty-dirs
install-doc:
@@ -100,21 +61,16 @@ install-doc:
.endfor
.endif
+# Install Emacs syntax file
install-el:
-.for filename in ${EMACS_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${filename} ${EMACS_DIR}
-.endfor
+ @${INSTALL_DATA} ${WRKSRC}/gforth.el ${PREFIX}/${EMACS_SITE_LISPDIR}
+# Remove unused file
remove-empty-files:
-.for filename in ${EMPTY_FILES}
- @${RM} -f ${FORTH_DIR}/${filename}
-.endfor
+ @${RM} -f ${DATADIR}/site-forth/siteinit.fs
+# Remove unused directories
remove-empty-dirs:
-.for dir in ${EMPTY_DIRS}
- @${RMDIR} ${ARCH_DIR}/${dir}
-.endfor
-
-.include <bsd.port.mk>
+ @${FIND} -d ${DATADIR}/${PORTVERSION}/arch/ -type d -empty -delete
-CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}
+.include <bsd.port.post.mk>
diff --git a/lang/gforth/distinfo b/lang/gforth/distinfo
index 44eefb182a20..c56306b42871 100644
--- a/lang/gforth/distinfo
+++ b/lang/gforth/distinfo
@@ -1,3 +1,3 @@
-MD5 (gforth-0.6.1.tar.gz) = 91855c11c3989d0ba92139e278f047d0
-SHA256 (gforth-0.6.1.tar.gz) = 0f8a4537f876719c3278a990fc540fe2f6b0a280d5da382622c0f06a17f217d3
-SIZE (gforth-0.6.1.tar.gz) = 1892711
+MD5 (gforth-0.6.2.tar.gz) = 869112bd762b07fc4d2038a2d9965148
+SHA256 (gforth-0.6.2.tar.gz) = 28a201ae78b073ef350d7ac4a8283233029c6afe6072620ac6dd6db1d192d462
+SIZE (gforth-0.6.2.tar.gz) = 1925536
diff --git a/lang/gforth/files/patch-engine::Makefile.in b/lang/gforth/files/patch-engine::Makefile.in
deleted file mode 100644
index eb239e282bd0..000000000000
--- a/lang/gforth/files/patch-engine::Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- engine/Makefile.in.orig Sun Mar 9 16:06:46 2003
-+++ engine/Makefile.in Tue Mar 9 14:47:19 2004
-@@ -72,7 +72,8 @@
- XCFLAGS = @CFLAGS@
- XDEFINES = @DEFS@
- SWITCHES = $(XCFLAGS) $(XDEFINES)
--ENGINE_FLAGS = @ENGINE_FLAGS@ -fno-defer-pop -fcaller-saves
-+#use -fno-inline to avoid register problems with asinh, atanh on gcc-3.3 on 386
-+ENGINE_FLAGS = @ENGINE_FLAGS@ -fno-defer-pop -fcaller-saves -fno-inline
- DEBUGFLAG = @DEBUGFLAG@
- CFLAGS = $(DEBUGFLAG) -I$(srcdir)/../arch/$(machine) -I. -O2 -Wall $(SWITCHES) -DDEFAULTPATH=\"$(FORTHPATH)\"
- CFLAGS2 = $(DEBUGFLAG) -I$(srcdir)/../arch/$(machine) -I. -O2 -Wall $(SWITCHES) -DDEFAULTPATH=\"$(FORTHPATH)\"
diff --git a/lang/gforth/files/patch-engine::signals.c b/lang/gforth/files/patch-engine::signals.c
deleted file mode 100644
index 9cb26b52aebd..000000000000
--- a/lang/gforth/files/patch-engine::signals.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- engine/signals.c.orig Sun Mar 9 16:06:56 2003
-+++ engine/signals.c Tue Mar 9 14:44:48 2004
-@@ -142,10 +142,18 @@
- #ifdef FPE_INTOVF
- case FPE_INTOVF: code=-11; break; /* integer overflow */
- #endif
-+#ifdef FPE_FLTDIV
- case FPE_FLTDIV: code=-42; break; /* floating point divide by zero */
-+#endif
-+#ifdef FPE_FLTOVF
- case FPE_FLTOVF: code=-43; break; /* floating point overflow */
-+#endif
-+#ifdef FPE_FLTUND
- case FPE_FLTUND: code=-54; break; /* floating point underflow */
-+#endif
-+#ifdef FPE_FLTRES
- case FPE_FLTRES: code=-41; break; /* floating point inexact result */
-+#endif
- #if 0 /* defined by Unix95, but unnecessary */
- case FPE_FLTINV: /* invalid floating point operation */
- case FPE_FLTSUB: /* subscript out of range */
diff --git a/lang/gforth/files/patch-getopt.c b/lang/gforth/files/patch-getopt.c
deleted file mode 100644
index 9175b4778c42..000000000000
--- a/lang/gforth/files/patch-getopt.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- engine/getopt.c.orig Sat Sep 23 20:22:09 2000
-+++ engine/getopt.c Fri Mar 16 01:42:49 2001
-@@ -177,12 +177,12 @@
- REQUIRE_ORDER, PERMUTE, RETURN_IN_ORDER
- } ordering, default_ordering = PERMUTE;
-
-+#include <string.h>
- #ifdef __GNU_LIBRARY__
- /* We want to avoid inclusion of string.h with non-GNU libraries
- because there are many ways it can cause trouble.
- On some systems, it contains special magic macros that don't work
- in GCC. */
--#include <string.h>
- #define my_index strchr
- #define my_bcopy(src, dst, n) memcpy ((dst), (src), (n))
- #else
diff --git a/lang/gforth/pkg-plist b/lang/gforth/pkg-plist
index 81f00143de01..b427a5c504ba 100644
--- a/lang/gforth/pkg-plist
+++ b/lang/gforth/pkg-plist
@@ -14,21 +14,8 @@ bin/gforthmi-%%PORTVERSION%%
bin/vmgen-%%PORTVERSION%%
@exec ln -fs %f %B/vmgen
@unexec rm -f %B/vmgen
-%%LIB_DIR%%/%%PORTVERSION%%/gforth-ditc
-%%LIB_DIR%%/%%PORTVERSION%%/gforth.fi
-@exec mkdir -p %D/lib/gforth/site-forth
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/BUGS
-%%PORTDOCS%%%%DOCSDIR%%/Benchres
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/COPYING.DOC
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.BINDIST
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/NEWS.vmgen
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.vmgen
-%%PORTDOCS%%%%DOCSDIR%%/ToDo
+lib/gforth/%%PORTVERSION%%/gforth-ditc
+lib/gforth/%%PORTVERSION%%/gforth.fi
%%EMACS_DIR%%/gforth.el
%%DATADIR%%/%%PORTVERSION%%/TAGS
%%DATADIR%%/%%PORTVERSION%%/add.fs
@@ -37,43 +24,11 @@ bin/vmgen-%%PORTVERSION%%
%%DATADIR%%/%%PORTVERSION%%/answords.fs
%%DATADIR%%/%%PORTVERSION%%/arch/386/asm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/386/disasm.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/4stack/asm.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/4stack/mach.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/4stack/prim.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/4stack/relocate.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/6502/asm.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/6502/cold.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/6502/mach.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/6502/prim.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/6502/softuart.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/6502/zero.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/8086/asm.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/8086/mach.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/8086/prim.fs
%%DATADIR%%/%%PORTVERSION%%/arch/alpha/asm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/alpha/disasm.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/avr/asm.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/c165/asm.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/c165/mach.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/c165/prim.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/h8/asm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/mips/asm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/mips/disasm.fs
%%DATADIR%%/%%PORTVERSION%%/arch/mips/insts.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/misc/asm.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/misc/mach.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/misc/prim.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/misc/sim.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/misc/sokoban.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/misc/tt.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/sharc/mach.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/shboom/asm.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/shboom/compiler.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/shboom/dis.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/shboom/dis2.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/shboom/doers.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/shboom/mach.fs
-@comment %%DATADIR%%/%%PORTVERSION%%/arch/shboom/prim.fs
%%DATADIR%%/%%PORTVERSION%%/asm/README
%%DATADIR%%/%%PORTVERSION%%/asm/basic.fs
%%DATADIR%%/%%PORTVERSION%%/asm/bitmask.fs
@@ -123,6 +78,7 @@ bin/vmgen-%%PORTVERSION%%
%%DATADIR%%/%%PORTVERSION%%/exboot.fs
%%DATADIR%%/%%PORTVERSION%%/except.fs
%%DATADIR%%/%%PORTVERSION%%/extend.fs
+%%DATADIR%%/%%PORTVERSION%%/fflib.fs
%%DATADIR%%/%%PORTVERSION%%/fi2c.fs
%%DATADIR%%/%%PORTVERSION%%/fib.fs
%%DATADIR%%/%%PORTVERSION%%/filedump.fs
@@ -149,7 +105,6 @@ bin/vmgen-%%PORTVERSION%%
%%DATADIR%%/%%PORTVERSION%%/kernel/errore.fs
%%DATADIR%%/%%PORTVERSION%%/kernel/files.fs
%%DATADIR%%/%%PORTVERSION%%/kernel/getdoers.fs
-%%DATADIR%%/%%PORTVERSION%%/kernel/groups.fs
%%DATADIR%%/%%PORTVERSION%%/kernel/input.fs
%%DATADIR%%/%%PORTVERSION%%/kernel/int.fs
%%DATADIR%%/%%PORTVERSION%%/kernel/io.fs
@@ -186,6 +141,7 @@ bin/vmgen-%%PORTVERSION%%
%%DATADIR%%/%%PORTVERSION%%/more.fs
%%DATADIR%%/%%PORTVERSION%%/objects.fs
%%DATADIR%%/%%PORTVERSION%%/objexamp.fs
+%%DATADIR%%/%%PORTVERSION%%/oldlib.fs
%%DATADIR%%/%%PORTVERSION%%/oof.fs
%%DATADIR%%/%%PORTVERSION%%/oofsampl.fs
%%DATADIR%%/%%PORTVERSION%%/other.fs
@@ -229,30 +185,20 @@ bin/vmgen-%%PORTVERSION%%
%%DATADIR%%/%%PORTVERSION%%/wordinfo.fs
%%DATADIR%%/%%PORTVERSION%%/wordsets.fs
@exec mkdir -p %D/%%DATADIR%%/site-forth
-@dirrm %%DATADIR%%/site-forth
-@dirrm %%DATADIR%%/%%PORTVERSION%%/unix
-@dirrm %%DATADIR%%/%%PORTVERSION%%/test
-@dirrm %%DATADIR%%/%%PORTVERSION%%/kernel
-@dirrm %%DATADIR%%/%%PORTVERSION%%/ec
-@dirrm %%DATADIR%%/%%PORTVERSION%%/doc
-@dirrm %%DATADIR%%/%%PORTVERSION%%/compat
-@dirrm %%DATADIR%%/%%PORTVERSION%%/asm
-@comment @dirrm %%DATADIR%%/%%PORTVERSION%%/arch/shboom
-@comment @dirrm %%DATADIR%%/%%PORTVERSION%%/arch/sharc
-@comment @dirrm %%DATADIR%%/%%PORTVERSION%%/arch/misc
-@dirrm %%DATADIR%%/%%PORTVERSION%%/arch/mips
-@comment @dirrm %%DATADIR%%/%%PORTVERSION%%/arch/h8
-@comment @dirrm %%DATADIR%%/%%PORTVERSION%%/arch/c165
-@comment @dirrm %%DATADIR%%/%%PORTVERSION%%/arch/avr
-@dirrm %%DATADIR%%/%%PORTVERSION%%/arch/alpha
-@comment @dirrm %%DATADIR%%/%%PORTVERSION%%/arch/8086
-@comment @dirrm %%DATADIR%%/%%PORTVERSION%%/arch/6205
-@comment @dirrm %%DATADIR%%/%%PORTVERSION%%/arch/4stack
-@dirrm %%DATADIR%%/%%PORTVERSION%%/arch/386
-@dirrm %%DATADIR%%/%%PORTVERSION%%/arch
-@dirrm %%DATADIR%%/%%PORTVERSION%%
-@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%LIB_DIR%%/site-forth
-@dirrm %%LIB_DIR%%/%%PORTVERSION%%
-@dirrm %%LIB_DIR%%
+@dirrmtry %%DATADIR%%/site-forth
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/unix
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/test
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/kernel
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/ec
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/doc
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/compat
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/asm
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/arch/mips
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/arch/alpha
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/arch/386
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/arch
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%
+@dirrmtry %%DATADIR%%
+@dirrmtry lib/gforth/site-forth
+@dirrmtry lib/gforth/%%PORTVERSION%%
+@dirrmtry lib/gforth