aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2023-08-25 01:28:10 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2023-08-29 03:07:06 +0000
commit9b2e4b0219bd4814b47c22e5901f3b1cc091fded (patch)
treefc7f80ee1f3c48dc56229f97eb6a863d73ff428a
parent042ea734575462e59b9901bf3dc037d17c1c3050 (diff)
downloadports-9b2e4b0219bd4814b47c22e5901f3b1cc091fded.tar.gz
ports-9b2e4b0219bd4814b47c22e5901f3b1cc091fded.zip
devel/boost-all: Adjust range to use llvm from ports
When boost was updated to 1.81.0, the problem was reported as PR 269067 that build of devel/boost-libs fails because of assertion failure of Clang in base system. According to the comment submitted to upstream issue tracker (*), the source of the problem is very long standing bug of LLVM/Clang. So the bug itself is included in all of supported branch of src repository. But the problem only happens with main because assertion is only enabled with it. To work it around compiled.mk was modified so llvm from ports is used instead of that of base system when __FreeBSD_version is 1400000 or later. This is what was done with commit 3efdfab9b59f. And recently stable/14 branch is created in src repository. After it is created __FreeBSD_version of the branch is bumped from 1400096 to 1400097. And the value of main is bumped from 1400096 to 1500000. So adjust range to use llvm from ports as following. Case 1: 1400000 <= OSVERSION < 1400097 (main before stable/14 is branched) Case 2: OSVERSION >= 1500000 (main after stable/14 is branched) Reference: https://github.com/llvm/llvm-project/issues/39319#issuecomment-1444452238 (*) PR: 273335 Approved by: sunpoet (office@, maintainer) MFH: 2023Q3
-rw-r--r--devel/boost-all/compiled.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index 3783dd5d74c5..c28fc60aeb7f 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -43,7 +43,8 @@ MAKE_ARGS+= pch=off
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400000
+.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1500000 || \
+ (${OSVERSION} >= 1400000 && ${OSVERSION} < 1400097))
USES+= llvm:build
CC= ${_LLVM_MK_PREFIX}/bin/clang
CPP= ${_LLVM_MK_PREFIX}/bin/clang-cpp