aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2021-12-02 03:14:43 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2021-12-02 03:20:52 +0000
commit9b869a4c17db42729cdfaca02c5c9c5ab2d22976 (patch)
tree1c420988b8ca7ce0eaa54b8d9fcd6a7957666c37
parentce8f614ad9b58ecd4655843b19d63a252d46221b (diff)
downloadports-9b869a4c17db42729cdfaca02c5c9c5ab2d22976.tar.gz
ports-9b869a4c17db42729cdfaca02c5c9c5ab2d22976.zip
editors/neovim: Update to 0.6.0 and switch lua backend
0.6.0 is an interval update that refines and extends the major lua overhaul of 0.5.0. Instead of using options for luajit vs PUC (mainline) lua, use luajit-openresty unconditionally. devel/luv needs to use the same backend as NeoVIM, so this commit switches it too. NeoVIM is designed specifically to run on luajit rather than PUC; upstream essentially doesn't develop for PUC. However, luajit is largely unmaintained, locked in an older lua dialect, and unbuildable on many architectures. The luajit-openresty fork is faster, more modern, and should work in more places. It's unclear to me which FreeBSD archs it does or doesn't work on, so the fallout will have to be addressed once the builders have a whack at it.
-rw-r--r--devel/luv/Makefile25
-rw-r--r--editors/neovim/Makefile20
-rw-r--r--editors/neovim/distinfo6
3 files changed, 12 insertions, 39 deletions
diff --git a/devel/luv/Makefile b/devel/luv/Makefile
index 47dd6bd45690..d4823eb8b3a1 100644
--- a/devel/luv/Makefile
+++ b/devel/luv/Makefile
@@ -9,7 +9,8 @@ COMMENT= libuv bindings for lua
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-LIB_DEPENDS= libuv.so:devel/libuv
+LIB_DEPENDS= libuv.so:devel/libuv \
+ libluajit-5.1.so:lang/luajit-openresty \
USES= cmake
USE_LDCONFIG= yes
@@ -19,27 +20,9 @@ GH_PROJECT= luv lua-compat-5.3:compat
GH_TAGNAME= bc91f40:compat
GH_SUBDIR= deps/lua-compat-5.3:compat
-OPTIONS_DEFINE= DOCS EXAMPLES LUAJIT
-OPTIONS_DEFAULT_aarch64= LUAJIT
-OPTIONS_DEFAULT_amd64= LUAJIT
-OPTIONS_DEFAULT_i386= LUAJIT
-OPTIONS_DEFAULT_powerpc= LUAJIT
-OPTIONS_DEFAULT_powerpc64= LUAJIT
-OPTIONS_DEFAULT_powerpc64le= LUAJIT
+OPTIONS_DEFINE= DOCS EXAMPLES
-LUAJIT_DESC= Use LuaJIT (instead of just Lua)
-LUAJIT_LIB_DEPENDS= ${LUAJIT_LIB_DEPENDS_${ARCH}}
-LUAJIT_LIB_DEPENDS_aarch64= libluajit-5.1.so:lang/luajit-openresty
-LUAJIT_LIB_DEPENDS_amd64= libluajit-5.1.so:lang/luajit
-LUAJIT_LIB_DEPENDS_i386= libluajit-5.1.so:lang/luajit
-LUAJIT_LIB_DEPENDS_powerpc= libluajit-5.1.so:lang/luajit
-LUAJIT_LIB_DEPENDS_powerpc64= libluajit-5.1.so:lang/luajit-openresty
-LUAJIT_LIB_DEPENDS_powerpc64le= libluajit-5.1.so:lang/luajit-openresty
-LUAJIT_CMAKE_ON= -DWITH_LUA_ENGINE=LuaJIT
-LUAJIT_USES_OFF= lua
-LUAJIT_CMAKE_OFF= -DWITH_LUA_ENGINE=Lua
-
-CMAKE_ON= BUILD_SHARED_LIBS WITH_SHARED_LIBUV
+CMAKE_ON= BUILD_SHARED_LIBS WITH_LUA_ENGINE=LuaJIT WITH_SHARED_LIBUV
CMAKE_OFF= BUILD_MODULE
CMAKE_ARGS= -DLUA_BUILD_TYPE=System \
-DLUA_COMPAT53_DIR=deps/lua-compat-5.3
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 5088f53b5deb..ab04cd1b5627 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -2,7 +2,7 @@
PORTNAME= neovim
DISTVERSIONPREFIX= v
-DISTVERSION= 0.5.1
+DISTVERSION= 0.6.0
CATEGORIES= editors
MAINTAINER= adamw@FreeBSD.org
@@ -13,7 +13,8 @@ LICENSE= APACHE20
BUILD_DEPENDS= gperf:devel/gperf \
${LUA_MODLIBDIR}/bit.so:devel/lua-bitop@${LUA_FLAVOR} \
${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg@${LUA_FLAVOR}
-LIB_DEPENDS= libluv.so:devel/luv \
+LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty \
+ libluv.so:devel/luv \
libmsgpackc.so:devel/msgpack \
libtermkey.so:devel/libtermkey \
libtree-sitter.so:devel/tree-sitter \
@@ -25,7 +26,7 @@ TEST_DEPENDS= autoconf>=0:devel/autoconf \
gmake:devel/gmake \
libtool:devel/libtool
-USES= cmake cpe iconv pathfix pkgconfig
+USES= cmake cpe iconv lua:build pathfix pkgconfig
USE_GITHUB= yes
GH_TUPLE= libmpack:libmpack:1.0.5:libmpack \
libmpack:libmpack-lua:1.0.7:libmpack_lua
@@ -38,21 +39,11 @@ CMAKE_ARGS= -DLUA_PRG:FILEPATH="${LUA_CMD}" \
DATADIR= ${PREFIX}/share/nvim
PORTDATA= runtime
-OPTIONS_DEFINE= LUAJIT NLS PYNVIM
-OPTIONS_DEFAULT=LUAJIT
-OPTIONS_EXCLUDE_aarch64=LUAJIT
-OPTIONS_EXCLUDE_mips64= LUAJIT
-OPTIONS_EXCLUDE_riscv64=LUAJIT
-OPTIONS_EXCLUDE_sparc64=LUAJIT
+OPTIONS_DEFINE= NLS PYNVIM
OPTIONS_SUB= yes
-LUAJIT_DESC= Use LuaJIT for faster Lua code
PYNVIM_DESC= Enable support for plugins written in python
-LUAJIT_CMAKE_OFF= -DPREFER_LUA:BOOL="ON"
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
-LUAJIT_USES= lua:build
-LUAJIT_USES_OFF= lua:52
NLS_CMAKE_BOOL= ENABLE_LIBINTL
NLS_USES= gettext
PYNVIM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pynvim>=0.3.0:editors/py-pynvim@${PY_FLAVOR}
@@ -61,7 +52,6 @@ PYNVIM_USES= python:run
.include <bsd.port.options.mk>
.if ${ARCH:Mpowerpc64*}
-LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
USES+= compiler:gcc-c++11-lib
.endif
diff --git a/editors/neovim/distinfo b/editors/neovim/distinfo
index c6e2860e1b74..2a9b354679c0 100644
--- a/editors/neovim/distinfo
+++ b/editors/neovim/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1632701733
-SHA256 (neovim-neovim-v0.5.1_GH0.tar.gz) = aa449795e5cc69bdd2eeed7095f20b9c086c6ecfcde0ab62ab97a9d04243ec84
-SIZE (neovim-neovim-v0.5.1_GH0.tar.gz) = 10349190
+TIMESTAMP = 1638413905
+SHA256 (neovim-neovim-v0.6.0_GH0.tar.gz) = 2cfd600cfa5bb57564cc22ffbbbcb2c91531053fc3de992df33656614384fa4c
+SIZE (neovim-neovim-v0.6.0_GH0.tar.gz) = 10592213
SHA256 (libmpack-libmpack-1.0.5_GH0.tar.gz) = 4ce91395d81ccea97d3ad4cb962f8540d166e59d3e2ddce8a22979b49f108956
SIZE (libmpack-libmpack-1.0.5_GH0.tar.gz) = 32966
SHA256 (libmpack-libmpack-lua-1.0.7_GH0.tar.gz) = 2ebe9c8972c378040c9b8505f5fb40a0c64d990cd68be6a62989362b18294d0a