aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-07-19 18:32:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-07-19 18:37:00 +0000
commit9b98cb5c003c46f6cfb7b0c35d33fe1343e8ed17 (patch)
tree00b2584b6c904301f5dfbe8184840d4792aabe8c
parentb6927dad6398576f56e618f765483380db47ff98 (diff)
downloadports-9b98cb5c003c46f6cfb7b0c35d33fe1343e8ed17.tar.gz
ports-9b98cb5c003c46f6cfb7b0c35d33fe1343e8ed17.zip
games/xonotic: update 0.8.2 → 0.8.5
-rw-r--r--games/xonotic/Makefile7
-rw-r--r--games/xonotic/distinfo6
-rw-r--r--games/xonotic/files/patch-source_darkplaces_makefile.inc11
3 files changed, 15 insertions, 9 deletions
diff --git a/games/xonotic/Makefile b/games/xonotic/Makefile
index c007a42be7da..d94f3010a540 100644
--- a/games/xonotic/Makefile
+++ b/games/xonotic/Makefile
@@ -1,8 +1,7 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= xonotic
-PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTVERSION= 0.8.5
CATEGORIES= games
MASTER_SITES= http://nl.dl.xonotic.org/ \
http://mirror.bitmissile.com/xonotic/releases/
@@ -23,14 +22,12 @@ BUILD_WRKSRC= ${WRKSRC}/source/darkplaces
MAKEFILE= makefile
MAKE_ARGS= DP_FS_BASEDIR="${DATADIR}" \
DP_PRELOAD_DEPENDENCIES=yes \
- OPTIM_RELEASE="${CFLAGS}" \
STRIP="${STRIP_CMD}"
MAKE_JOBS_UNSAFE=yes
ALL_TARGET= # empty
PORTDATA= *
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS
OPTIONS_MULTI= COMPONENTS
OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
OPTIONS_DEFAULT= CLIENT DEDICATED
@@ -56,8 +53,6 @@ DEDICATED_DESC= Build dedicated server
DEDICATED_ALL_TARGET= sv-release
DEDICATED_PLIST_FILES= bin/${PORTNAME}-dedicated
-OPTIMIZED_CFLAGS_CFLAGS= -O3 -fno-strict-aliasing -fno-math-errno -ffinite-math-only -fno-rounding-math -fno-signaling-nans -fno-trapping-math
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},' \
${BUILD_WRKSRC}/makefile ${BUILD_WRKSRC}/makefile.inc
diff --git a/games/xonotic/distinfo b/games/xonotic/distinfo
index c65c22c89716..fbcf94b3343c 100644
--- a/games/xonotic/distinfo
+++ b/games/xonotic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1491306088
-SHA256 (xonotic-0.8.2.zip) = a22f7230f486c5825b55cfdadd73399c9b0fae98c9e081dd8ac76eca08359ad5
-SIZE (xonotic-0.8.2.zip) = 991045679
+TIMESTAMP = 1656693570
+SHA256 (xonotic-0.8.5.zip) = 0f92aa238362aeb059b9d9026a9bd38d6217423a35c19f126fb39e38736e37e5
+SIZE (xonotic-0.8.5.zip) = 1228561792
diff --git a/games/xonotic/files/patch-source_darkplaces_makefile.inc b/games/xonotic/files/patch-source_darkplaces_makefile.inc
new file mode 100644
index 000000000000..1101c2469db9
--- /dev/null
+++ b/games/xonotic/files/patch-source_darkplaces_makefile.inc
@@ -0,0 +1,11 @@
+--- source/darkplaces/makefile.inc.orig 2022-06-27 17:32:38 UTC
++++ source/darkplaces/makefile.inc
+@@ -194,7 +194,7 @@ OPTIM_DEBUG=$(CPUOPTIMIZATIONS)
+ #OPTIM_RELEASE=-O2 -fno-strict-aliasing -fno-math-errno -fno-trapping-math -fno-signaling-nans -fcx-limited-range -funroll-loops $(CPUOPTIMIZATIONS)
+ #OPTIM_RELEASE=-O2 -fno-strict-aliasing -funroll-loops $(CPUOPTIMIZATIONS)
+ #OPTIM_RELEASE=-O2 -fno-strict-aliasing $(CPUOPTIMIZATIONS)
+-OPTIM_RELEASE=-O3 -fno-strict-aliasing $(CPUOPTIMIZATIONS)
++OPTIM_RELEASE=${CFLAGS} -fno-strict-aliasing $(CPUOPTIMIZATIONS)
+ # NOTE: *never* *ever* use the -ffast-math or -funsafe-math-optimizations flag
+ # Also, since gcc 5, -ffinite-math-only makes NaN and zero compare equal inside engine code but not inside QC, which causes error spam for seemingly valid QC code like if (x != 0) return 1 / x;
+