aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-03-27 21:19:11 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-03-27 21:19:11 +0000
commit9bdca5221641fb3fc38551907654d7830576fb79 (patch)
tree79899b6c14c87ce3ae40baa6fd0fa5d54bebb84c
parent0d575cf87ebee2cba53de1a33faf57f261111f2d (diff)
downloadports-9bdca5221641fb3fc38551907654d7830576fb79.tar.gz
ports-9bdca5221641fb3fc38551907654d7830576fb79.zip
mailman: add -postfix and -exim4 slave ports
This is to avoid accidents on upgrading, for instance, if the POSTFIX option is getting lost and mail starts to bounce. The slave ports prevent that.
Notes
Notes: svn path=/head/; revision=569359
-rw-r--r--mail/Makefile2
-rw-r--r--mail/mailman-exim4/Makefile14
-rw-r--r--mail/mailman-postfix/Makefile14
-rw-r--r--mail/mailman/Makefile31
4 files changed, 46 insertions, 15 deletions
diff --git a/mail/Makefile b/mail/Makefile
index f68086560a1a..54234efba2bf 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -203,6 +203,8 @@
SUBDIR += mailgraph
SUBDIR += mailhog
SUBDIR += mailman
+ SUBDIR += mailman-exim4
+ SUBDIR += mailman-postfix
SUBDIR += mailman3
SUBDIR += mailscanner
SUBDIR += mailsync
diff --git a/mail/mailman-exim4/Makefile b/mail/mailman-exim4/Makefile
new file mode 100644
index 000000000000..5a8241ec5254
--- /dev/null
+++ b/mail/mailman-exim4/Makefile
@@ -0,0 +1,14 @@
+# Created by: Matthias Andree <mandree@FreeBSD.org>
+
+PKGNAMESUFFIX= -exim4
+
+COMMENT= mailman with Exim4 configuration and dependency
+
+CONFLICTS_INSTALL= mailman*postfix* mailman-2* mailman-with-htdig-2*
+
+OPTIONS_EXCLUDE= COURIER OPENSMTPD POSTFIX SENDMAIL
+OPTIONS_SLAVE= EXIM4
+
+MASTERDIR= ${.CURDIR}/../../mail/mailman
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/mailman-postfix/Makefile b/mail/mailman-postfix/Makefile
new file mode 100644
index 000000000000..e692b2d647ff
--- /dev/null
+++ b/mail/mailman-postfix/Makefile
@@ -0,0 +1,14 @@
+# Created by: Matthias Andree <mandree@FreeBSD.org>
+
+PKGNAMESUFFIX= -postfix
+
+COMMENT= mailman with postfix dependency
+
+CONFLICTS_INSTALL= mailman*exim* mailman-2* mailman-with-htdig-2*
+
+OPTIONS_EXCLUDE= COURIER EXIM4 OPENSMTPD SENDMAIL
+OPTIONS_SLAVE= POSTFIX
+
+MASTERDIR= ${.CURDIR}/../../mail/mailman
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 896e644d213d..cc328ddf89b6 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -36,7 +36,7 @@ CONFIGURE_ARGS+=--with-python=${PYTHON_CMD} \
--with-mailhost=localhost \
--with-urlhost=localhost
-CONFLICTS= ja-mailman-2.1.*
+CONFLICTS= ja-mailman-2.1.* mailman*exim* mailman*postfix*
# The Mailman port supports a number of variables that may be tweaked at
# build time. Getting the values of some of them right is crucial!
@@ -68,19 +68,21 @@ PORTDOCS= ACKNOWLEDGMENTS BUGS FAQ INSTALL NEWS README README-I18N.en \
mailman-member.txt \
FreeBSD-post-install-notes
-OPTIONS_SINGLE= MTA
+OPTIONS_SINGLE= MTA
OPTIONS_SINGLE_MTA= COURIER EXIM4 OPENSMTPD POSTFIX SENDMAIL
-OPTIONS_DEFINE= HTDIG NAMAZU2 NOMAILPWD NLS DOCS
+OPTIONS_DEFINE= HTDIG NAMAZU2 NOMAILPWD NLS DOCS
OPTIONS_DEFAULT= SENDMAIL NOMAILPWD
-COURIER_DESC= for use with courier
-EXIM4_DESC= for use with exim4
-OPENSMTPD_DESC= for use with opensmtpd - EXPERIMENTAL -
-POSTFIX_DESC= for use with postfix
-SENDMAIL_DESC= for use with sendmail
-HTDIG_DESC= - EXPERIMENTAL - htdig integration patches
-NAMAZU2_DESC= Make private archives searchable with namazu2
-NOMAILPWD_DESC= Elide plaintext passwords from monthly reminders
-MTA_DESC= Integrate with which MTA?
+COURIER_DESC= for use with courier
+EXIM4_DESC= for use with exim4
+EXIM4_RUN_DEPENDS= exim>=0:mail/exim
+OPENSMTPD_DESC= for use with opensmtpd - EXPERIMENTAL -
+POSTFIX_DESC= for use with postfix
+POSTFIX_RUN_DEPENDS= postfix:mail/postfix
+SENDMAIL_DESC= for use with sendmail
+HTDIG_DESC= - EXPERIMENTAL - htdig integration patches
+NAMAZU2_DESC= Make private archives searchable with namazu2
+NOMAILPWD_DESC= Elide plaintext passwords from monthly reminders
+MTA_DESC= Integrate with which MTA?
.include <bsd.port.options.mk>
@@ -109,8 +111,6 @@ MAIL_GID?= mail
.endif
.if ${PORT_OPTIONS:MPOSTFIX}
-BUILD_DEPENDS+= postfix:mail/postfix
-RUN_DEPENDS+= postfix:mail/postfix
MAIL_GID?= mailman
EXTRA_PATCHES+= ${FILESDIR}/postfix-verp.diff
.endif
@@ -124,7 +124,8 @@ MAIL_GID?= _smtpd
.endif
.if ${PORT_OPTIONS:MHTDIG}
-PKGNAMESUFFIX+= -with-htdig
+# no whitespace here!
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-with-htdig
# how to create PATCHFILES:
#X identify what is the version of msapiro's patches corresponding to the release.
#X fetch http://bazaar.launchpad.net/~msapiro/mailman/htdig/tarball/1822