aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-02-26 03:14:48 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-02-26 03:14:48 +0000
commit9c0575fcdf3356376fc3b17c29e0f8cf9157f83d (patch)
tree3a3f35d53c1eef301ded4d1f00376c8e6709d12b
parent33bbb326afed0eaaf031abc7285aabfb982c0e6d (diff)
downloadports-9c0575fcdf3356376fc3b17c29e0f8cf9157f83d.tar.gz
ports-9c0575fcdf3356376fc3b17c29e0f8cf9157f83d.zip
Add port of the playable demo of Myth II: Soulblighter.
Notes
Notes: svn path=/head/; revision=55247
-rw-r--r--games/Makefile1
-rw-r--r--games/myth2_demo/Makefile61
-rw-r--r--games/myth2_demo/distinfo1
-rw-r--r--games/myth2_demo/pkg-comment1
-rw-r--r--games/myth2_demo/pkg-descr24
5 files changed, 88 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index e7bc5ffb2d74..ed9ecf2deb55 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -177,6 +177,7 @@
SUBDIR += mindguard
SUBDIR += mirrormagic
SUBDIR += miscom
+ SUBDIR += myth2_demo
SUBDIR += mythserver
SUBDIR += nadar
SUBDIR += nethack
diff --git a/games/myth2_demo/Makefile b/games/myth2_demo/Makefile
new file mode 100644
index 000000000000..e2551aa981af
--- /dev/null
+++ b/games/myth2_demo/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: myth2_demo
+# Date created: 2000-01-22
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= myth2_demo
+PORTVERSION= 1.3
+CATEGORIES= games linux
+MASTER_SITES= ftp://ftp.linux.tucows.com/pub/Loki/updates/loki_demos/ \
+ ftp://ftp.sunsite.auc.dk/disk2/lokigames/updates/loki_demos/
+PKGNAMEPREFIX= linux-
+DISTNAME= myth2-demo
+EXTRACT_SUFX= .run
+EXTRACT_ONLY=
+
+MAINTAINER= trevor@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+PLIST= ${WRKDIR}/plist
+RESTRICTED= "no license"
+NO_CDROM= ${RESTRICTED}
+NO_FTP= ${RESTRICTED}
+USE_LINUX= yes
+USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/update/demos/myth2_demo/
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${SED} -e 1,174d < ${DISTDIR}/${DISTFILES} | ${TAR} -C ${WRKDIR} -xzvf -
+
+do-patch:
+ ${MKDIR} ${WRKSRC}
+ cd ${WRKDIR} && bin/Linux/x86/loki_patch patch.dat ${WRKDIR}/update
+ ${RM} -f ${WRKSRC}/myth2_demo.ppc
+ - ${MV} ${WRKSRC}/README ${WRKDIR}
+
+pre-install:
+ ${ECHO_CMD} bin/myth2_demo.x86 > ${PLIST}
+.ifndef(NOPORTDOCS)
+ ${ECHO_CMD} share/doc/myth2_demo/README >> ${PLIST}
+.endif
+ ${FIND} ${WRKSRC}/ -type f | \
+ ${PERL} -pi -e "s:^${WRKSRC}/:lib/myth2_demo/:g" >> ${PLIST}
+ ${FIND} -d ${WRKSRC}/ -type d | \
+ ${PERL} -pi -e "s:^${WRKSRC}/:\@dirrm lib/myth2_demo/:g" >> \
+ ${PLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/myth2_demo
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/README ${DOCSDIR}
+.endif
+ cd ${WRKSRC} && pax -r -w * ${PREFIX}/lib/myth2_demo
+ cd ${PREFIX}/bin && ${LN} -s ../lib/myth2_demo/myth2_demo.x86
+
+.include <bsd.port.mk>
diff --git a/games/myth2_demo/distinfo b/games/myth2_demo/distinfo
new file mode 100644
index 000000000000..91b49ede83bb
--- /dev/null
+++ b/games/myth2_demo/distinfo
@@ -0,0 +1 @@
+MD5 (myth2-demo.run) = 2e5384cf95540d1ae8d6d0aa0b6bfd5c
diff --git a/games/myth2_demo/pkg-comment b/games/myth2_demo/pkg-comment
new file mode 100644
index 000000000000..9b6dda1f5fef
--- /dev/null
+++ b/games/myth2_demo/pkg-comment
@@ -0,0 +1 @@
+Demo of Myth II: Soulblighter
diff --git a/games/myth2_demo/pkg-descr b/games/myth2_demo/pkg-descr
new file mode 100644
index 000000000000..7d7b0e8ab481
--- /dev/null
+++ b/games/myth2_demo/pkg-descr
@@ -0,0 +1,24 @@
+from the README:
+ This playable demo of Myth II: Soulblighter for Linux has the following
+ limitations over the full game:
+ - Only three maps are available: two for solo games and one
+ for multi-player games.
+ - Guest-only login to Bungie.net
+ [...] you will only be able to play this demo with other Myth II for Linux
+ Demo v1.3 users.
+from the Web page:
+ Sharpen your swords and fire up the cauldrons--Soulblighter is back!
+ Bungie's thrilling strategy adventure, Myth II: Soulblighter, brings back the
+ scourge of the West and challenges you with all-new scenarios and improved
+ graphics and 3D rendering.
+ In command of a ragtag army of berserkers, dwarves, soldiers and sorcerers,
+ you are the last hope (yet again) of saving the folk of Madrigal and the West
+ from the evil might of Soulblighter and his minions. Test your fortitiude by
+ challenging others on your network or online to a battle to the death, or cross
+ swords and sages with Soulblighter himself. For fantasy gamers, this is far
+ better than a slab of roast beast washed down with a tall ale...
+
+On FreeBSD it crashes after playing the introductory movie, if /dev/dsp is
+available.
+
+WWW: http://www.lokigames.com/products/myth2/