aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Chen <jonc@chen.org.nz>2023-08-25 16:55:12 +0000
committerKurt Jaeger <pi@FreeBSD.org>2023-08-25 16:55:12 +0000
commit9c0deb570f306ebeb35c512ba8dbac83d9300ffa (patch)
tree6a7b7d76480cf129ef95e5697c5645bc347e7f52
parentb1298cd2fbae7de26f5e4c7982e65a726a76c25f (diff)
downloadports-9c0deb570f306ebeb35c512ba8dbac83d9300ffa.tar.gz
ports-9c0deb570f306ebeb35c512ba8dbac83d9300ffa.zip
converters/wkhtmltopdf: unbreak build
- remove "register" keyword usage from C++ files This fixes breakage introduced in 95274bf4f99c71fc056013d966aec239161dfd74 PR: 273334
-rw-r--r--converters/wkhtmltopdf/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index 02c79969074a..95a2d2c62c0f 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -15,7 +15,6 @@ EXPIRATION_DATE= 2024-06-30
BROKEN_armv6= fails to build: error: Not supported ARM architecture
BROKEN_armv7= fails to build: error: invalid operand for instruction
BROKEN_mips64= fails to link: undefined reference to __sync_add_and_fetch_4
-BROKEN_FreeBSD_14= fails to build: use of undeclared identifier 'needsToUnregister'
RUN_DEPENDS= webfonts>=0:x11-fonts/webfonts
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
@@ -84,7 +83,7 @@ post-patch:
${WRKSRC}/build/wkhtmltox
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
@${FIND} ${PATCH_WRKSRC}/../qt-5db36ec -name "*.cpp" -o -name "*.h" | \
- ${XARGS} ${REINPLACE_CMD} -e 's|register ||g'
+ ${XARGS} ${REINPLACE_CMD} -E 's|register ([a-zA-Z])|\1|g'
.endif