aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2023-09-17 21:22:52 +0000
committerCharlie Li <vishwin@FreeBSD.org>2023-09-17 21:22:52 +0000
commit9c77ef5e7bc3d595fa9acee59059c9f948fc8ff8 (patch)
tree5de7f015e3da7fcfad31520ae03c12122b68482b
parent817d2bd2b8bc8ff1e27b8120b70bd06eb9845d43 (diff)
downloadports-9c77ef5e7bc3d595fa9acee59059c9f948fc8ff8.tar.gz
ports-9c77ef5e7bc3d595fa9acee59059c9f948fc8ff8.zip
graphics/inkscape: update upstream patch
-rw-r--r--graphics/inkscape/Makefile2
-rw-r--r--graphics/inkscape/distinfo6
-rw-r--r--graphics/inkscape/files/patch-src_helper_geom.h11
3 files changed, 4 insertions, 15 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 5a8fc572d682..72bc51dcdb42 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -5,7 +5,7 @@ MASTER_SITES= https://media.inkscape.org/dl/resources/file/
PATCH_SITES= https://gitlab.com/${PORTNAME}/${PORTNAME}/-/commit/
PATCHFILES+= 3db96bfbac475022a32b70473b767b21a8d70c7f.patch:-p1 # https://gitlab.com/inkscape/inkscape/-/issues/4427
-PATCHFILES+= 00851fede7f9162cbcacf81258d1dda823b88a5c.patch:-p1 # https://gitlab.com/inkscape/inkscape/-/merge_requests/5650
+PATCHFILES+= 5183d14d331e4f2022b9ab0f83d45e4e17951013.patch:-p1 # https://gitlab.com/inkscape/inkscape/-/merge_requests/5650
MAINTAINER= gnome@FreeBSD.org
COMMENT= Full featured open source SVG editor
diff --git a/graphics/inkscape/distinfo b/graphics/inkscape/distinfo
index 5ba7f41d16ee..cef2325763ed 100644
--- a/graphics/inkscape/distinfo
+++ b/graphics/inkscape/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1692891317
+TIMESTAMP = 1694983728
SHA256 (inkscape-1.3.tar.xz) = bf4f286b025e0169b8948cc14d5199a9b4c204d761c894c4b48496571ec76307
SIZE (inkscape-1.3.tar.xz) = 85764028
SHA256 (3db96bfbac475022a32b70473b767b21a8d70c7f.patch) = fb572fa3b566149293b0ffeae468ff6025d0e54a090d928eb8c2037afe2d3f8d
SIZE (3db96bfbac475022a32b70473b767b21a8d70c7f.patch) = 2003
-SHA256 (00851fede7f9162cbcacf81258d1dda823b88a5c.patch) = d0ebfcb85682345d7e10d97931894acd171881a8467b70a777f37a293d255a59
-SIZE (00851fede7f9162cbcacf81258d1dda823b88a5c.patch) = 5207
+SHA256 (5183d14d331e4f2022b9ab0f83d45e4e17951013.patch) = f62186b0655ea0aae5802b464c71e107155a4c93b6e0c9bae7c870dad956f4fa
+SIZE (5183d14d331e4f2022b9ab0f83d45e4e17951013.patch) = 7711
diff --git a/graphics/inkscape/files/patch-src_helper_geom.h b/graphics/inkscape/files/patch-src_helper_geom.h
deleted file mode 100644
index 6c6a70977402..000000000000
--- a/graphics/inkscape/files/patch-src_helper_geom.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/helper/geom.h.orig 2023-08-24 15:45:30 UTC
-+++ src/helper/geom.h
-@@ -55,7 +55,7 @@ inline Geom::Coord triangle_area(Geom::Point const &p1
- return p1[X] * p2[Y] + p1[Y] * p3[X] + p2[X] * p3[Y] - p2[Y] * p3[X] - p1[Y] * p2[X] - p1[X] * p3[Y];
- }
-
--inline auto rounddown(Geom::IntPoint const &a, Geom::IntPoint const &b)
-+inline auto round_down(Geom::IntPoint const &a, Geom::IntPoint const &b)
- {
- using namespace Inkscape::Util;
- return Geom::IntPoint(round_down(a.x(), b.x()), round_down(a.y(), b.y()));