aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2013-08-01 20:22:27 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2013-08-01 20:22:27 +0000
commit9c7a77ab1e2aff61f3f6d7e6f08fdf7089ef125a (patch)
tree7bb62db90d2a538c347e596844736cd7fe4d260b
parent51688d427c2e13b8a128f217d0aa01a7c140d09a (diff)
downloadports-9c7a77ab1e2aff61f3f6d7e6f08fdf7089ef125a.tar.gz
ports-9c7a77ab1e2aff61f3f6d7e6f08fdf7089ef125a.zip
For all my ports
* remove MAKE_JOBS_SAFE (default now) * change USE_GMAKE=yes to USES=gmake
Notes
Notes: svn path=/head/; revision=324122
-rw-r--r--archivers/gcpio/Makefile1
-rw-r--r--archivers/gtar/Makefile3
-rw-r--r--astro/xworld/Makefile1
-rw-r--r--audio/libao/Makefile1
-rw-r--r--audio/libogg/Makefile1
-rw-r--r--audio/libvorbis/Makefile1
-rw-r--r--audio/mpg321/Makefile1
-rw-r--r--audio/opus-tools/Makefile1
-rw-r--r--audio/opus/Makefile1
-rw-r--r--audio/vorbis-tools/Makefile1
-rw-r--r--audio/xmms-flac/Makefile1
-rw-r--r--audio/xmms-shn/Makefile1
-rw-r--r--audio/xmms-wavpack/Makefile1
-rw-r--r--comms/wy60/Makefile1
-rw-r--r--games/gtypist/Makefile1
-rw-r--r--games/xsoldier/Makefile1
-rw-r--r--mail/bsmtp/Makefile1
-rw-r--r--math/calcoo/Makefile1
-rw-r--r--math/galculator/Makefile3
-rw-r--r--sysutils/sdd/Makefile2
-rw-r--r--x11/xlogout/Makefile1
21 files changed, 3 insertions, 23 deletions
diff --git a/archivers/gcpio/Makefile b/archivers/gcpio/Makefile
index c6a3d9cddf1e..d3e4df2b1d64 100644
--- a/archivers/gcpio/Makefile
+++ b/archivers/gcpio/Makefile
@@ -13,7 +13,6 @@ COMMENT= GNU cpio copies files to and from archives
USE_BZIP2= yes
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --program-prefix=g \
--disable-silent-rules \
--with-rmt=/etc/rmt
diff --git a/archivers/gtar/Makefile b/archivers/gtar/Makefile
index f78a99a7e85b..511934414131 100644
--- a/archivers/gtar/Makefile
+++ b/archivers/gtar/Makefile
@@ -16,11 +16,10 @@ COMMENT= GNU version of the traditional tape archiver
INFO= tar
-USES= iconv
+USES= iconv
USE_AUTOTOOLS= autoconf:env # autom4te
USE_XZ= yes
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --program-prefix=g \
--disable-silent-rules
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/astro/xworld/Makefile b/astro/xworld/Makefile
index fbdfada06d8a..b22cfe4beb34 100644
--- a/astro/xworld/Makefile
+++ b/astro/xworld/Makefile
@@ -23,7 +23,6 @@ CONFIGURE_ENV= CAT=${CAT} \
INCLUDES="-I${LOCALBASE}/include" \
LDLIBS="-lm -L${LOCALBASE}/lib -lX11" \
MORELIBS=""
-MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/xworld
STRIP= #don't strip out image data on install
diff --git a/audio/libao/Makefile b/audio/libao/Makefile
index 1f8955db4954..621f678fa0aa 100644
--- a/audio/libao/Makefile
+++ b/audio/libao/Makefile
@@ -19,7 +19,6 @@ WANT_GNOME= yes
USE_GNOME= gnomehack pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --disable-arts
MAN5= libao.conf.5
diff --git a/audio/libogg/Makefile b/audio/libogg/Makefile
index 303e5250e0ff..99ff97364ec8 100644
--- a/audio/libogg/Makefile
+++ b/audio/libogg/Makefile
@@ -14,7 +14,6 @@ USES= pathfix
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= DOCS
diff --git a/audio/libvorbis/Makefile b/audio/libvorbis/Makefile
index 7a78e7a6ffc2..c6d0547c36c3 100644
--- a/audio/libvorbis/Makefile
+++ b/audio/libvorbis/Makefile
@@ -21,7 +21,6 @@ USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ogg=${LOCALBASE} \
--disable-docs # don't rebuild
-MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= DOCS
diff --git a/audio/mpg321/Makefile b/audio/mpg321/Makefile
index bd0e14949047..1849974e0ad7 100644
--- a/audio/mpg321/Makefile
+++ b/audio/mpg321/Makefile
@@ -33,7 +33,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-mpg123-symlink
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_JOBS_SAFE= yes
MAN1= mpg321.1
diff --git a/audio/opus-tools/Makefile b/audio/opus-tools/Makefile
index 52d9af7939c7..1df6674d009e 100644
--- a/audio/opus-tools/Makefile
+++ b/audio/opus-tools/Makefile
@@ -15,7 +15,6 @@ LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
GNU_CONFIGURE= yes
USES= pkgconfig
-MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/opusdec bin/opusenc bin/opusinfo
MAN1= opusdec.1 opusenc.1 opusinfo.1
diff --git a/audio/opus/Makefile b/audio/opus/Makefile
index bf667c7112c9..0af53f9f1dc2 100644
--- a/audio/opus/Makefile
+++ b/audio/opus/Makefile
@@ -17,7 +17,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-custom-modes \
--disable-maintainer-mode \
--disable-doc # requires doxygen
-MAKE_JOBS_SAFE= yes
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index 0891f55d589e..72dbfb83bd1d 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -23,7 +23,6 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_JOBS_SAFE= yes
.include <bsd.port.options.mk>
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index b0515a026bb0..63cb5b3bd6f2 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -26,7 +26,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
MAKEFILE= ${FILESDIR}/Makefile
-MAKE_JOBS_SAFE= yes
# XXX
post-install:
diff --git a/audio/xmms-shn/Makefile b/audio/xmms-shn/Makefile
index be0a18afb333..108093ebbee8 100644
--- a/audio/xmms-shn/Makefile
+++ b/audio/xmms-shn/Makefile
@@ -15,7 +15,6 @@ RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
USE_GNOME= gtk12
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
.include <bsd.port.options.mk>
diff --git a/audio/xmms-wavpack/Makefile b/audio/xmms-wavpack/Makefile
index 16040425cf80..411c918e7026 100644
--- a/audio/xmms-wavpack/Makefile
+++ b/audio/xmms-wavpack/Makefile
@@ -16,7 +16,6 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_JOBS_SAFE= yes
post-install:
${RM} ${PREFIX}/lib/xmms/Input/libwavpack.la
diff --git a/comms/wy60/Makefile b/comms/wy60/Makefile
index 8b94eca6cba7..7e1d2e6cdc04 100644
--- a/comms/wy60/Makefile
+++ b/comms/wy60/Makefile
@@ -9,7 +9,6 @@ MAINTAINER= naddy@FreeBSD.org
COMMENT= Curses-based emulator for the Wyse 60 terminal
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
MAKE_ARGS= etc_DATA=wy60.rc.sample
diff --git a/games/gtypist/Makefile b/games/gtypist/Makefile
index 9f8d7d9f2433..03e10a62df5e 100644
--- a/games/gtypist/Makefile
+++ b/games/gtypist/Makefile
@@ -13,7 +13,6 @@ USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= EMACS=no
CPPFLAGS= -I${WRKDIR}/include
-MAKE_JOBS_SAFE= yes
INFO= gtypist gtypist.cs gtypist.es
MAN1= gtypist.1 typefortune.1
diff --git a/games/xsoldier/Makefile b/games/xsoldier/Makefile
index f531c6605d09..e5505a241b1b 100644
--- a/games/xsoldier/Makefile
+++ b/games/xsoldier/Makefile
@@ -16,7 +16,6 @@ COMMENT= Space-based shoot-em up game for X11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
MAKE_ARGS= CC_OPTIMIZE="${CFLAGS}"
-MAKE_JOBS_SAFE= yes
USE_XORG= x11 ice sm xpm
MAN6= xsoldier.6
diff --git a/mail/bsmtp/Makefile b/mail/bsmtp/Makefile
index 952b1885dd62..fa6b47cc46eb 100644
--- a/mail/bsmtp/Makefile
+++ b/mail/bsmtp/Makefile
@@ -17,7 +17,6 @@ USE_PERL5= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --redo
-MAKE_JOBS_SAFE= yes
SHEBANG_FILES= configure
.include <bsd.port.pre.mk>
diff --git a/math/calcoo/Makefile b/math/calcoo/Makefile
index c3d74b35ec12..2fceeeb01e00 100644
--- a/math/calcoo/Makefile
+++ b/math/calcoo/Makefile
@@ -12,7 +12,6 @@ COMMENT= RPN and algebraic scientific calculator
USES= pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
MAN1= calcoo.1
diff --git a/math/galculator/Makefile b/math/galculator/Makefile
index 5bab044e8f98..71ef8dbf68cb 100644
--- a/math/galculator/Makefile
+++ b/math/galculator/Makefile
@@ -8,14 +8,13 @@ MASTER_SITES= SF
MAINTAINER= naddy@FreeBSD.org
COMMENT= GTK-based scientific calculator
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-gtk3
-MAKE_JOBS_SAFE= yes
MAN1= galculator.1
diff --git a/sysutils/sdd/Makefile b/sysutils/sdd/Makefile
index e9d5a3ca7611..e697f48f7d47 100644
--- a/sysutils/sdd/Makefile
+++ b/sysutils/sdd/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= ftp://ftp.berlios.de/pub/sdd/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Faster and improved version of dd
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= MAKEPROG="${GMAKE}" CCOM="${CC}" COPTX="${CFLAGS}"
MAN1= sdd.1
PLIST_FILES= bin/sdd
diff --git a/x11/xlogout/Makefile b/x11/xlogout/Makefile
index a9ea9517dec1..09f6f51c766d 100644
--- a/x11/xlogout/Makefile
+++ b/x11/xlogout/Makefile
@@ -13,7 +13,6 @@ COMMENT= Simple logout button
USES= imake
WRKSRC= ${WRKDIR}/xlogout
USE_XORG= ice sm x11 xaw xext xmu xpm xt
-MAKE_JOBS_SAFE= yes
MAN1= xlogout.1
PLIST_FILES= bin/xlogout \