aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:39:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:39:03 +0000
commit9cfefedd40d926640153e0bbb4537e69f050c77e (patch)
treee646133b0d21f215d4fef52b712039b0968e89fa
parentb17f2f1d390b31c475590b8adfe6551c234116f5 (diff)
downloadports-9cfefedd40d926640153e0bbb4537e69f050c77e.tar.gz
ports-9cfefedd40d926640153e0bbb4537e69f050c77e.zip
devel/p5-Config-AWS: Add p5-Config-AWS 0.10
Config::AWS is a small distribution with generic methods to correctly parse the contents of config files for the AWS CLI client as described in the AWS documentation. Although it is common to see these files parsed as standard INI files, this is not appropriate since AWS config files have an idiosyncratic format for nested values (as shown in the link above). Standard INI parsers (like Config::INI) are not made to parse this sort of structure (nor should they). So Config::AWS exists to provide a suitable and lightweight ad-hoc parser that can be used in other applications. WWW: https://metacpan.org/dist/Config-AWS
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-AWS/Makefile27
-rw-r--r--devel/p5-Config-AWS/distinfo3
-rw-r--r--devel/p5-Config-AWS/pkg-descr13
-rw-r--r--devel/p5-Config-AWS/pkg-plist2
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fb84c9646f6f..cc1cf1757c76 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2001,6 +2001,7 @@
SUBDIR += p5-Complete-Sequence
SUBDIR += p5-Complete-Util
SUBDIR += p5-Config-AST
+ SUBDIR += p5-Config-AWS
SUBDIR += p5-Config-Any
SUBDIR += p5-Config-ApacheFormat
SUBDIR += p5-Config-Auto
diff --git a/devel/p5-Config-AWS/Makefile b/devel/p5-Config-AWS/Makefile
new file mode 100644
index 000000000000..73e5d2c00c40
--- /dev/null
+++ b/devel/p5-Config-AWS/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= Config-AWS
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parse AWS config files
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Exporter-Tiny>=1:devel/p5-Exporter-Tiny \
+ p5-Path-Tiny>=0.076:devel/p5-Path-Tiny \
+ p5-Ref-Util>=0:devel/p5-Ref-Util
+TEST_DEPENDS= p5-Test2-Suite>=0:devel/p5-Test2-Suite
+
+USES= perl5
+USE_PERL5= modbuildtiny
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-AWS/distinfo b/devel/p5-Config-AWS/distinfo
new file mode 100644
index 000000000000..911f8fc60258
--- /dev/null
+++ b/devel/p5-Config-AWS/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1650228640
+SHA256 (Config-AWS-0.10.tar.gz) = 27be65b5b0a9fe94d32da60003cd9348199319908c0ba8ab17167170b3864d19
+SIZE (Config-AWS-0.10.tar.gz) = 21988
diff --git a/devel/p5-Config-AWS/pkg-descr b/devel/p5-Config-AWS/pkg-descr
new file mode 100644
index 000000000000..7594277afce4
--- /dev/null
+++ b/devel/p5-Config-AWS/pkg-descr
@@ -0,0 +1,13 @@
+Config::AWS is a small distribution with generic methods to correctly parse the
+contents of config files for the AWS CLI client as described in the AWS
+documentation.
+
+Although it is common to see these files parsed as standard INI files, this is
+not appropriate since AWS config files have an idiosyncratic format for nested
+values (as shown in the link above).
+
+Standard INI parsers (like Config::INI) are not made to parse this sort of
+structure (nor should they). So Config::AWS exists to provide a suitable and
+lightweight ad-hoc parser that can be used in other applications.
+
+WWW: https://metacpan.org/dist/Config-AWS
diff --git a/devel/p5-Config-AWS/pkg-plist b/devel/p5-Config-AWS/pkg-plist
new file mode 100644
index 000000000000..ed38fa26c8d4
--- /dev/null
+++ b/devel/p5-Config-AWS/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Config/AWS.pm
+%%PERL5_MAN3%%/Config::AWS.3.gz