aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2021-07-09 18:28:22 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2021-07-09 18:28:22 +0000
commit9d0bb93ec1fa400903e3634a79ceda614c0142d9 (patch)
tree765164887c1b960c71c2605b24e9377a459a2cba
parentf8a0151c2fbfdfedd776234f07f7d0e30f2a2b50 (diff)
downloadports-9d0bb93ec1fa400903e3634a79ceda614c0142d9.tar.gz
ports-9d0bb93ec1fa400903e3634a79ceda614c0142d9.zip
www/yarr: Add new port
yarr (yet another rss reader) is a web-based feed aggregator which can be used both as a desktop application and a personal self-hosted server. It is written in Go with the frontend in Vue.js. The storage is backed by SQLite. WWW: https://github.com/nkanaev/yarr
-rw-r--r--www/Makefile1
-rw-r--r--www/yarr/Makefile30
-rw-r--r--www/yarr/distinfo11
-rw-r--r--www/yarr/files/yarr.in18
-rw-r--r--www/yarr/pkg-descr7
5 files changed, 67 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c161d5d00161..1675fe2842c2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2329,6 +2329,7 @@
SUBDIR += yanopaste
SUBDIR += yarn
SUBDIR += yarn-node14
+ SUBDIR += yarr
SUBDIR += yaws
SUBDIR += you-get
SUBDIR += yourls
diff --git a/www/yarr/Makefile b/www/yarr/Makefile
new file mode 100644
index 000000000000..21b4c213f1fb
--- /dev/null
+++ b/www/yarr/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= yarr
+DISTVERSIONPREFIX=v
+DISTVERSION= 2.0
+CATEGORIES= www
+
+MAINTAINER= decke@FreeBSD.org
+COMMENT= Yet another rss reader
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/license
+
+USES= go:modules
+
+USE_RC_SUBR= ${PORTNAME}
+
+USE_GITHUB= yes
+GH_ACCOUNT= nkanaev
+GH_TAGNAME= 0c5385c
+GH_TUPLE= \
+ golang:net:d3edc9973b7e:golang_net/vendor/golang.org/x/net \
+ golang:sys:eeed37f84f13:golang_sys/vendor/golang.org/x/sys \
+ golang:text:v0.3.0:golang_text/vendor/golang.org/x/text \
+ mattn:go-sqlite3:v1.14.0:mattn_go_sqlite3/vendor/github.com/mattn/go-sqlite3
+
+GO_TARGET= ./src/main.go:yarr
+GO_BUILDFLAGS= -tags "sqlite_foreign_keys release" -ldflags "-X main.Version=${PORTVERSION}"
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/www/yarr/distinfo b/www/yarr/distinfo
new file mode 100644
index 000000000000..99a851914896
--- /dev/null
+++ b/www/yarr/distinfo
@@ -0,0 +1,11 @@
+TIMESTAMP = 1624304403
+SHA256 (nkanaev-yarr-v2.0-0c5385c_GH0.tar.gz) = 83558d4962d2e27195fc0a484c2c8b45bb8f8278ded9d110278ca4c141e34898
+SIZE (nkanaev-yarr-v2.0-0c5385c_GH0.tar.gz) = 924613
+SHA256 (golang-net-d3edc9973b7e_GH0.tar.gz) = 3f1ba89024d8a03881a5f308e820f1beb0fa6f3a03eff3dca42c4cc9f59869f9
+SIZE (golang-net-d3edc9973b7e_GH0.tar.gz) = 1174466
+SHA256 (golang-sys-eeed37f84f13_GH0.tar.gz) = f656a17b77d0b695e8bb6537e3650e971f33222271da42419c60e49a6ceae9c3
+SIZE (golang-sys-eeed37f84f13_GH0.tar.gz) = 1069057
+SHA256 (golang-text-v0.3.0_GH0.tar.gz) = 8f4c9a048345befc7beccd09267737ee1f55c7b35e5ff80f344ec9e0aa90febb
+SIZE (golang-text-v0.3.0_GH0.tar.gz) = 6102619
+SHA256 (mattn-go-sqlite3-v1.14.0_GH0.tar.gz) = 84f86e4619915791b5a67d8fa4ba6e0101abd9be827548b27b54a954b374bf54
+SIZE (mattn-go-sqlite3-v1.14.0_GH0.tar.gz) = 2350479
diff --git a/www/yarr/files/yarr.in b/www/yarr/files/yarr.in
new file mode 100644
index 000000000000..8549256b9f64
--- /dev/null
+++ b/www/yarr/files/yarr.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+# PROVIDE: yarr
+# REQUIRE: NETWORKING
+
+. /etc/rc.subr
+
+name="yarr"
+rcvar="yarr_enable"
+
+pidfile="/var/run/${name}.pid"
+command="/usr/sbin/daemon"
+command_args="-P ${pidfile} -r -f -o /var/log/${name}.log %%PREFIX%%/bin/${name}"
+
+load_rc_config $name
+: ${yarr_enable:=NO}
+
+run_rc_command "$1"
diff --git a/www/yarr/pkg-descr b/www/yarr/pkg-descr
new file mode 100644
index 000000000000..021900e2a369
--- /dev/null
+++ b/www/yarr/pkg-descr
@@ -0,0 +1,7 @@
+yarr (yet another rss reader) is a web-based feed aggregator which can
+be used both as a desktop application and a personal self-hosted server.
+
+It is written in Go with the frontend in Vue.js. The storage is backed
+by SQLite.
+
+WWW: https://github.com/nkanaev/yarr