aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Certner <olce.freebsd@certner.fr>2023-09-09 21:57:59 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-12 14:54:16 +0000
commit9d17dd45c04a6d934b838cc076272b430c440072 (patch)
tree6395b3932292b3a0e562b5d1ace78a5789e64dd3
parent2c07ec8e2dce042f4719152fb9b5d6343c39679f (diff)
downloadports-9d17dd45c04a6d934b838cc076272b430c440072.tar.gz
ports-9d17dd45c04a6d934b838cc076272b430c440072.zip
devel/universal-ctags: New option GLOBAL_CONFIG
This new option makes Universal Ctags read a global configuration file (at ${LOCALBASE}/etc/uctags.conf) before the user's one. This is useful in order to apply some common configuration to all users, who can then tweak whichever part they want in their own file. PR: 273645 Approved by: dereks@lifeofadishwasher.com (maintainer)
-rw-r--r--devel/universal-ctags/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/devel/universal-ctags/Makefile b/devel/universal-ctags/Makefile
index e69a955894d1..c71e6155f486 100644
--- a/devel/universal-ctags/Makefile
+++ b/devel/universal-ctags/Makefile
@@ -20,15 +20,19 @@ TEST_TARGET= check
PORTSCOUT= skipv:v6.0.0
-OPTIONS_DEFINE= DEBUG ICONV JSON LIBXML2 MANPAGES PCRE2 YAML
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE:NDEBUG}
+OPTIONS_DEFINE= DEBUG GLOBAL_CONFIG ICONV JSON LIBXML2 MANPAGES PCRE2 \
+ YAML
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE:NDEBUG:NGLOBAL_CONFIG}
OPTIONS_SUB= yes
-JSON_DESC= JSON output support
-PCRE2_DESC= ${PCRE_DESC} v2
+GLOBAL_CONFIG_DESC= Enable reading global config from ${LOCALBASE}/etc/uctags.conf
+JSON_DESC= JSON output support
+PCRE2_DESC= ${PCRE_DESC} v2
DEBUG_CONFIGURE_ENABLE= debugging
+GLOBAL_CONFIG_CONFIGURE_ENABLE= custom-config="${LOCALBASE}/etc/uctags.conf"
+
ICONV_USES= iconv
ICONV_CONFIGURE_ENABLE= iconv