aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-07-28 20:38:41 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-07-30 22:59:09 +0000
commit9dd6866b0fce90bb540ee50dc176d01105c92ade (patch)
tree52c60c308b2beebbff990151218ebcc7a250a7e7
parent1b46f3bddda1f8e0ba018aa94f7e206408c30331 (diff)
downloadports-9dd6866b0fce90bb540ee50dc176d01105c92ade.tar.gz
ports-9dd6866b0fce90bb540ee50dc176d01105c92ade.zip
misc/cuttlefish: fix build on armv7
Tell clang that it's ok to use fp16 instructions as the port assumes the corresponding intrinsics are present. Approved by: portmgr (build fix blanket) MFH: 2023Q3
-rw-r--r--misc/cuttlefish/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/misc/cuttlefish/Makefile b/misc/cuttlefish/Makefile
index e60a69391c1a..2b8b9c814506 100644
--- a/misc/cuttlefish/Makefile
+++ b/misc/cuttlefish/Makefile
@@ -32,6 +32,7 @@ CMAKE_OFF= CUTTLEFISH_BUILD_DOCS CUTTLEFISH_BUILD_TESTS
CMAKE_ON= CUTTLEFISH_SHARED
CMAKE_TESTING_ON= CUTTLEFISH_BUILD_TESTS # many tests fail, see https://github.com/akb825/Cuttlefish/issues/19
+CXXFLAGS_armv7= -mfpu=neon-fp16
CXXFLAGS_powerpc= -maltivec
.include <bsd.port.mk>