aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-09-20 06:53:53 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-09-20 07:43:40 +0000
commit9de718aaf747cace995ffcf592edf64e3fdd9317 (patch)
treeda67047e7be3f556dcfa5865a3ee01ad311a60d5
parent71f0f861cedf2a7ddcc0cc4909fc01f630453da8 (diff)
downloadports-9de718aaf747cace995ffcf592edf64e3fdd9317.tar.gz
ports-9de718aaf747cace995ffcf592edf64e3fdd9317.zip
www/elinks: Fix build with ssl from ports
Building with ssl from ports used the headers from ports, but still linked the libs from base and therefore failed. Patch meson.build to look for OpenSSL libs in ${OPENSSLLIB} to fix this. Approved by: portmgr (blanket, build fix)
-rw-r--r--www/elinks/Makefile1
-rw-r--r--www/elinks/files/patch-meson.build17
2 files changed, 15 insertions, 3 deletions
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index 89663e541e0a..82bf889d751f 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -117,6 +117,7 @@ ZSTD_USES= localbase
ZSTD_MESON_TRUE= zstd
post-patch:
+ @${REINPLACE_CMD} -e 's|%%OPENSSLLIB%%|${OPENSSLLIB}|g' ${WRKSRC}/meson.build
@${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|g' ${WRKSRC}/doc/tools/help2xml
@${REINPLACE_CMD} -e 's|/usr/bin/env python3|${PYTHON_CMD}|g' ${WRKSRC}/doc/tools/asciidoc/asciidoc.py
diff --git a/www/elinks/files/patch-meson.build b/www/elinks/files/patch-meson.build
index 6b13996f5ce9..8ca2f7d08468 100644
--- a/www/elinks/files/patch-meson.build
+++ b/www/elinks/files/patch-meson.build
@@ -1,6 +1,6 @@
--- meson.build.orig 2023-05-01 08:45:22 UTC
+++ meson.build
-@@ -178,6 +178,10 @@ endif
+@@ -178,6 +178,10 @@ if compiler.has_header('fcntl.h')
conf_data.set('HAVE_FCNTL_H', 1)
endif
@@ -11,7 +11,18 @@
if compiler.has_header('libgen.h')
conf_data.set('HAVE_LIBGEN_H', 1)
endif
-@@ -845,7 +849,7 @@ endif
+@@ -344,8 +348,8 @@ gnutlsdeps = []
+ ssldeps = []
+
+ if conf_data.get('CONFIG_OPENSSL')
+- ssldeps = dependency('openssl', static: st)
+- deps += ssldeps
++ deps += compiler.find_library('crypto', dirs: '%%OPENSSLLIB%%')
++ deps += compiler.find_library('ssl', dirs: '%%OPENSSLLIB%%')
+ conf_data.set('USE_OPENSSL', true)
+ conf_data.set('CONFIG_GNUTLS', false)
+ elif conf_data.get('CONFIG_GNUTLS')
+@@ -845,7 +849,7 @@ if compiler.has_function('iconv', prefix: '#include <i
conf_data.set('HAVE_ICONV', 1)
endif
@@ -20,7 +31,7 @@
conf_data.set('HAVE_ALLOCA', 1)
endif
-@@ -861,7 +865,7 @@ endif
+@@ -861,7 +865,7 @@ if compiler.has_function('gnutls_certificate_set_x509_
conf_data.set('HAVE_GNUTLS_CERTIFICATE_SET_X509_SYSTEM_TRUST', 1)
endif