aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-02-14 18:57:16 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-14 19:03:33 +0000
commit9dfb90986ff4763903a99bc9df403706051ca360 (patch)
tree52025938076a786e0838fa906cfabb94a7b64cda
parent6558c25069901328610d155bea362aeb7ab00f17 (diff)
downloadports-9dfb90986ff4763903a99bc9df403706051ca360.tar.gz
ports-9dfb90986ff4763903a99bc9df403706051ca360.zip
x11-wm/kwinft: mark BROKEN after 3a490e8f310d
kcmkwin/kwindecoration/declarative-plugin/previewbridge.cpp:64:51: error: allocating an object of abstract class type 'KDecoration2::Preview::PreviewClient' auto ptr = std::unique_ptr<PreviewClient>(new PreviewClient(client, decoration)); ^ /usr/local/include/KDecoration2/kdecoration2/private/decoratedclientprivate.h:80:21: note: unimplemented pure virtual method 'windowClass' in 'PreviewClient' virtual QString windowClass() const = 0; ^ In file included from base/backend/x11/randr_filter.cpp:6: In file included from base/backend/x11/randr_filter.h:8: In file included from base/x11/event_filter.h:11: In file included from /usr/local/include/qt5/QtCore/QVector:1: In file included from /usr/local/include/qt5/QtCore/qvector.h:43: In file included from /usr/local/include/qt5/QtCore/qalgorithms.h:43: In file included from /usr/local/include/qt5/QtCore/qglobal.h:142: In file included from /usr/include/c++/v1/algorithm:653: In file included from /usr/include/c++/v1/functional:500: In file included from /usr/include/c++/v1/__functional/function.h:20: In file included from /usr/include/c++/v1/__memory/shared_ptr.h:25: /usr/include/c++/v1/__memory/unique_ptr.h:728:32: error: allocating an object of abstract class type 'KWin::win::deco::client_impl<KWin::win::x11::window<KWin::win::x11::space<KWin::base::x11::platform>>>' return unique_ptr<_Tp>(new _Tp(_VSTD::forward<_Args>(__args)...)); ^ win/deco/bridge.h:135:29: note: in instantiation of function template specialization 'std::make_unique<KWin::win::deco::client_impl<KWin::win::x11::window<KWin::win::x11::space<KWin::base::x11::platform>>>, KWin::win::x11::window<KWin::win::x11::space<KWin::base::x11::platform>> *&, KDecoration2::DecoratedClient *&, KDecoration2::Decoration *&>' requested here return std::make_unique<client_impl<win_t>>(win, client, decoration); ^ /usr/include/c++/v1/type_traits:3924:23: note: in instantiation of function template specialization 'KWin::win::deco::bridge<KWin::win::x11::space<KWin::base::x11::platform>>::createClient(KDecoration2::DecoratedClient *, KDecoration2::Decoration *)::(anonymous class)::operator()<KWin::win::x11::window<KWin::win::x11::space<KWin::base::x11::platform>> *>' requested here _LIBCPP_INVOKE_RETURN(static_cast<_Fp&&>(__f)(static_cast<_Args&&>(__args)...)) ^ /usr/include/c++/v1/variant:659:21: note: in instantiation of function template specialization 'std::__invoke_constexpr<KWin::overload<(lambda at win/deco/bridge.h:133:22)>, KWin::win::x11::window<KWin::win::x11::space<KWin::base::x11::platform>> *&>' requested here return _VSTD::__invoke_constexpr(_VSTD::forward<_Visitor>(__visitor), ^ /usr/include/c++/v1/type_traits:3924:23: note: in instantiation of function template specialization 'std::__variant_detail::__visitation::__variant::__value_visitor<KWin::overload<(lambda at win/deco/bridge.h:133:22)>>::operator()<std::__variant_detail::__alt<0, KWin::win::x11::window<KWin::win::x11::space<KWin::base::x11::platform>> *> &>' requested here _LIBCPP_INVOKE_RETURN(static_cast<_Fp&&>(__f)(static_cast<_Args&&>(__args)...)) ^ /usr/include/c++/v1/variant:539:16: note: while substituting deduced template arguments into function template '__invoke_constexpr' [with _Fp = std::__variant_detail::__visitation::__variant::__value_visitor<KWin::overload<(lambda at win/deco/bridge.h:133:22)>>, _Args = <std::__variant_detail::__alt<0, KWin::win::x11::window<KWin::win::x11::space<KWin::base::x11::platform>> *> &>] return _VSTD::__invoke_constexpr( ^ /usr/include/c++/v1/__config:808:15: note: expanded from macro '_VSTD' #define _VSTD std::_LIBCPP_ABI_NAMESPACE ^ /usr/include/c++/v1/variant:548:43: note: (skipping 12 contexts in backtrace; use -ftemplate-backtrace-limit=0 to see all) return __dispatcher<_Is...>::template __dispatch<_Fp, _Vs...>; ^ win/x11/space.h:110:5: note: in instantiation of member function 'std::unique_ptr<KWin::win::deco::bridge<KWin::win::x11::space<KWin::base::x11::platform>>>::~unique_ptr' requested here ~space() override ^ /usr/include/c++/v1/__memory/unique_ptr.h:57:5: note: in instantiation of member function 'KWin::win::x11::space<KWin::base::x11::platform>::~space' requested here delete __ptr; ^ /usr/include/c++/v1/__memory/unique_ptr.h:318:7: note: in instantiation of member function 'std::default_delete<KWin::win::x11::space<KWin::base::x11::platform>>::operator()' requested here __ptr_.second()(__tmp); ^ /usr/include/c++/v1/__memory/unique_ptr.h:272:19: note: in instantiation of member function 'std::unique_ptr<KWin::win::x11::space<KWin::base::x11::platform>>::reset' requested here ~unique_ptr() { reset(); } ^ base/x11/platform.h:28:5: note: in instantiation of member function 'std::unique_ptr<KWin::win::x11::space<KWin::base::x11::platform>>::~unique_ptr' requested here ~platform() override ^ /usr/local/include/KDecoration2/kdecoration2/private/decoratedclientprivate.h:80:21: note: unimplemented pure virtual method 'windowClass' in 'client_impl' virtual QString windowClass() const = 0; ^
-rw-r--r--x11-wm/kwinft/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/x11-wm/kwinft/Makefile b/x11-wm/kwinft/Makefile
index a2175235d230..76807c830a8c 100644
--- a/x11-wm/kwinft/Makefile
+++ b/x11-wm/kwinft/Makefile
@@ -11,6 +11,8 @@ WWW= https://gitlab.com/kwinft/kwinft
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN= requires https://invent.kde.org/plasma/kwin/-/commit/9e97c7383c73
+
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto
LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
libwayland-server.so:graphics/wayland \