aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaul Newman <saul.newman@gmail.com>2022-05-15 03:47:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-15 03:49:24 +0000
commit9e821db3403b83c81a105745f9a73f71083f6dee (patch)
treebd23def0410c27ffe020f1391aff741cc8d77d6b
parent9b7025946f5d6eaac8554e4c313de4dbb5e8dec9 (diff)
downloadports-9e821db3403b83c81a105745f9a73f71083f6dee.tar.gz
ports-9e821db3403b83c81a105745f9a73f71083f6dee.zip
www/yt-dlp: Fix error: Unsupported platform: freebsd13
-rw-r--r--www/yt-dlp/Makefile1
-rw-r--r--www/yt-dlp/files/patch-yt__dlp_cookies.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/yt-dlp/Makefile b/www/yt-dlp/Makefile
index 4b276f14d3f1..a27bd05f3715 100644
--- a/www/yt-dlp/Makefile
+++ b/www/yt-dlp/Makefile
@@ -1,5 +1,6 @@
PORTNAME= yt-dlp
DISTVERSION= 2022.04.08
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= yuri@FreeBSD.org
diff --git a/www/yt-dlp/files/patch-yt__dlp_cookies.py b/www/yt-dlp/files/patch-yt__dlp_cookies.py
new file mode 100644
index 000000000000..b9562230e38b
--- /dev/null
+++ b/www/yt-dlp/files/patch-yt__dlp_cookies.py
@@ -0,0 +1,11 @@
+--- yt_dlp/cookies.py.orig 2022-05-14 11:34:22.365323000 -0400
++++ yt_dlp/cookies.py 2022-05-14 11:34:52.544340000 -0400
+@@ -140,7 +140,7 @@
+
+
+ def _firefox_browser_dir():
+- if sys.platform in ('linux', 'linux2'):
++ if sys.platform in ('linux', 'linux2','freebsd13','freebsd14'):
+ return os.path.expanduser('~/.mozilla/firefox')
+ elif sys.platform == 'win32':
+ return os.path.expandvars(r'%APPDATA%\Mozilla\Firefox\Profiles')