aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-03-01 14:02:25 +0000
committerSteve Wills <swills@FreeBSD.org>2017-03-01 14:02:25 +0000
commit9e86894aa2e84de44f7b0eab3b072d384b60ed9c (patch)
tree7007e507f2af56f97d70b9c68dbb336583167d32
parentddd87a4c4a06ba9d312068d15bafecd382fe59cf (diff)
downloadports-9e86894aa2e84de44f7b0eab3b072d384b60ed9c.tar.gz
ports-9e86894aa2e84de44f7b0eab3b072d384b60ed9c.zip
devel/py-qtconsole: create port
Qt-based console for Jupyter with support for rich media output WWW: https://qtconsole.readthedocs.io/
Notes
Notes: svn path=/head/; revision=435148
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-qtconsole/Makefile23
-rw-r--r--devel/py-qtconsole/distinfo3
-rw-r--r--devel/py-qtconsole/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 926ea3ef71a1..29280155fe2f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4614,6 +4614,7 @@
SUBDIR += py-qt5-help
SUBDIR += py-qt5-qscintilla2
SUBDIR += py-qt5-test
+ SUBDIR += py-qtconsole
SUBDIR += py-rauth
SUBDIR += py-raven
SUBDIR += py-rcsparse
diff --git a/devel/py-qtconsole/Makefile b/devel/py-qtconsole/Makefile
new file mode 100644
index 000000000000..397fccae23d9
--- /dev/null
+++ b/devel/py-qtconsole/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= qtconsole
+PORTVERSION= 4.2.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Qt-based console for Jupyter with support for rich media output
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}traitlets>=0:devel/py-traitlets \
+ ${PYTHON_PKGNAMEPREFIX}jupyter_core>=0:devel/py-jupyter_core \
+ ${PYTHON_PKGNAMEPREFIX}jupyter_client>=4.1:devel/py-jupyter_client \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments \
+ ${PYTHON_PKGNAMEPREFIX}ipykernel>=4.1:devel/py-ipykernel
+
+USES= pyqt:4 python
+USE_PYQT= core gui svg
+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-qtconsole/distinfo b/devel/py-qtconsole/distinfo
new file mode 100644
index 000000000000..731da71b4657
--- /dev/null
+++ b/devel/py-qtconsole/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1487848048
+SHA256 (qtconsole-4.2.1.tar.gz) = 25ec7d345528b3e8f3c91be349dd3c699755f206dc4b6ec668e2e5dd60ea18ef
+SIZE (qtconsole-4.2.1.tar.gz) = 408430
diff --git a/devel/py-qtconsole/pkg-descr b/devel/py-qtconsole/pkg-descr
new file mode 100644
index 000000000000..57476af4c9ab
--- /dev/null
+++ b/devel/py-qtconsole/pkg-descr
@@ -0,0 +1,3 @@
+Qt-based console for Jupyter with support for rich media output
+
+WWW: https://qtconsole.readthedocs.io/