aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:05:36 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 07:05:36 +0000
commit9e8fbe04ba2ed65f94ad48bb8f44033a7b5575ca (patch)
treeb69250d8f402e9e966fbc0d9a438c1f1d3c60ed4
parentd62c1c7105721d8586493e0dffe9dc40cb4b8d35 (diff)
downloadports-9e8fbe04ba2ed65f94ad48bb8f44033a7b5575ca.tar.gz
ports-9e8fbe04ba2ed65f94ad48bb8f44033a7b5575ca.zip
textproc/py-terminaltables: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--textproc/py-terminaltables/Makefile5
-rw-r--r--textproc/py-terminaltables/files/patch-pyproject.toml10
2 files changed, 14 insertions, 1 deletions
diff --git a/textproc/py-terminaltables/Makefile b/textproc/py-terminaltables/Makefile
index dd3da88aa552..5d372279cf00 100644
--- a/textproc/py-terminaltables/Makefile
+++ b/textproc/py-terminaltables/Makefile
@@ -1,5 +1,6 @@
PORTNAME= terminaltables
PORTVERSION= 3.1.10
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +12,10 @@ WWW= https://github.com/matthewdeanmartin/terminaltables
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
+
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/textproc/py-terminaltables/files/patch-pyproject.toml b/textproc/py-terminaltables/files/patch-pyproject.toml
new file mode 100644
index 000000000000..7730edd3cc11
--- /dev/null
+++ b/textproc/py-terminaltables/files/patch-pyproject.toml
@@ -0,0 +1,10 @@
+--- pyproject.toml.orig 2021-12-07 19:03:34 UTC
++++ pyproject.toml
+@@ -62,5 +62,5 @@ python = ">=2.6 || >=3.0"
+ pytest = "==6.0.1"
+
+ [build-system]
+-requires = ["poetry>=0.12"]
+-build-backend = "poetry.masonry.api"
++requires = ["poetry-core>=1.0.0"]
++build-backend = "poetry.core.masonry.api"