aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-01-11 23:03:19 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-01-11 23:03:19 +0000
commit9efb3c81b2494fa3cd9130a05da1957c539b3d7e (patch)
tree5bf7374a35388c9b9d5e28f2db64a64a754d9ed9
parent7d188b8bad7df0366619c058ed2d0c30ad31d43c (diff)
downloadports-9efb3c81b2494fa3cd9130a05da1957c539b3d7e.tar.gz
ports-9efb3c81b2494fa3cd9130a05da1957c539b3d7e.zip
www/firefox-esr: update to 91.5.0
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/distinfo6
-rw-r--r--www/firefox-esr/files/patch-bug161891450
3 files changed, 4 insertions, 54 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index ee4011d5141c..89a26d5e4d07 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -1,7 +1,7 @@
# Created by: Alan Eldridge <alane@FreeBSD.org>
PORTNAME= firefox
-DISTVERSION= 91.4.1
+DISTVERSION= 91.5.0
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index ab5c3031fc1e..49475234db73 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1639658837
-SHA256 (firefox-91.4.1esr.source.tar.xz) = 75e98daf53c5aea19d711a625d5d5e6dfdc8335965d3a19567c62f9d2961fc75
-SIZE (firefox-91.4.1esr.source.tar.xz) = 378159528
+TIMESTAMP = 1641929589
+SHA256 (firefox-91.5.0esr.source.tar.xz) = f45cd9c96227e3e6eabe37962ce924b7a7ca86b6c191326c1bab18e082b4c813
+SIZE (firefox-91.5.0esr.source.tar.xz) = 381371300
diff --git a/www/firefox-esr/files/patch-bug1618914 b/www/firefox-esr/files/patch-bug1618914
deleted file mode 100644
index c52ac49018b2..000000000000
--- a/www/firefox-esr/files/patch-bug1618914
+++ /dev/null
@@ -1,50 +0,0 @@
-From cea8e6a01bb03bbe565c9bf5dd4f439f30ca953f Mon Sep 17 00:00:00 2001
-From: Jan Beich <jbeich@FreeBSD.org>
-Date: Fri, 28 Feb 2020 16:49:38 +0000
-Subject: Bug 1618914 - [Wayland] Fall back to ftruncate if posix_fallocate isn't supported by filesystem.
-
-diff --git widget/gtk/WaylandShmBuffer.cpp widget/gtk/WaylandShmBuffer.cpp
-index 42eeedd3429ac..2a5c23d287413 100644
---- widget/gtk/WaylandShmBuffer.cpp
-+++ widget/gtk/WaylandShmBuffer.cpp
-@@ -67,36 +67,37 @@ static int WaylandAllocateShmMemory(int aSize) {
- return -1;
- }
-
- int ret = 0;
- #ifdef HAVE_POSIX_FALLOCATE
- do {
- ret = posix_fallocate(fd, 0, aSize);
- } while (ret == EINTR);
-- if (ret != 0) {
-+ if (ret == 0) {
-+ return fd;
-+ } else if (ret != ENODEV && ret != EINVAL && ret != EOPNOTSUPP) {
- NS_WARNING(
- nsPrintfCString("posix_fallocate() fails to allocate shm memory: %s",
- strerror(ret))
- .get());
- close(fd);
- return -1;
- }
--#else
-+#endif
- do {
- ret = ftruncate(fd, aSize);
- } while (ret < 0 && errno == EINTR);
- if (ret < 0) {
- NS_WARNING(nsPrintfCString("ftruncate() fails to allocate shm memory: %s",
- strerror(ret))
- .get());
- close(fd);
- fd = -1;
- }
--#endif
-
- return fd;
- }
-
- /* static */
- RefPtr<WaylandShmPool> WaylandShmPool::Create(
- const RefPtr<nsWaylandDisplay>& aWaylandDisplay, int aSize) {
- RefPtr<WaylandShmPool> shmPool = new WaylandShmPool(aSize);