aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2022-11-04 21:13:09 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2022-11-04 21:22:03 +0000
commit9f0cd13014d0962aedfa016c86a5af07ca3ba814 (patch)
tree278e7d965d281babade6ed3c64f989b0fff5d899
parentceb3689e9badb27e967a82dca308f953772dafdc (diff)
downloadports-9f0cd13014d0962aedfa016c86a5af07ca3ba814.tar.gz
ports-9f0cd13014d0962aedfa016c86a5af07ca3ba814.zip
lang/gcc11: Revert "Fix conflict on libgccjit.h and libgccjit++.h"
This reverts commit dc67e7d3009de2b78d96136c8ad09cf186e553df. The revert is necessary as - lang/gcc11/files/patch-gcc_Makefile.in was wrong: it should have used $(version) instead of $(gcc_version); - even after correcting the above mistake, the patch still does not work: lang/emacs fails to configure and hence to build. See also https://reviews.freebsd.org/D37266 . PR: 257060 Reported by: yasu
-rw-r--r--lang/gcc11/Makefile2
-rw-r--r--lang/gcc11/files/patch-gcc_Makefile.in19
-rw-r--r--lang/gcc11/files/patch-gcc_jit_Make-lang.in14
-rw-r--r--lang/gcc11/pkg-plist2
4 files changed, 3 insertions, 34 deletions
diff --git a/lang/gcc11/Makefile b/lang/gcc11/Makefile
index 70abb2e30e68..e88adb3c28c4 100644
--- a/lang/gcc11/Makefile
+++ b/lang/gcc11/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gcc
PORTVERSION= 11.3.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= GCC
PKGNAMESUFFIX= ${SUFFIX}
diff --git a/lang/gcc11/files/patch-gcc_Makefile.in b/lang/gcc11/files/patch-gcc_Makefile.in
deleted file mode 100644
index 6d1d926a66ff..000000000000
--- a/lang/gcc11/files/patch-gcc_Makefile.in
+++ /dev/null
@@ -1,19 +0,0 @@
---- gcc/Makefile.in.orig 2022-11-02 20:13:34 UTC
-+++ gcc/Makefile.in
-@@ -630,6 +630,8 @@ libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/
-
- # Directory in which the compiler finds libraries etc.
- libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
-+# Directory in which the compiler finds headers.
-+libsubincludedir = $(libdir)/gcc/$(target_alias)/$(gcc_version)/include
- # Directory in which the compiler finds executables
- libexecsubdir = $(libexecdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
- # Directory in which all plugin resources are installed
-@@ -3609,6 +3611,7 @@ installdirs:
- # $(libdir)/gcc/include isn't currently searched by cpp.
- installdirs:
- $(mkinstalldirs) $(DESTDIR)$(libsubdir)
-+ $(mkinstalldirs) $(DESTDIR)$(libsubincludedir)
- $(mkinstalldirs) $(DESTDIR)$(libexecsubdir)
- $(mkinstalldirs) $(DESTDIR)$(bindir)
- $(mkinstalldirs) $(DESTDIR)$(includedir)
diff --git a/lang/gcc11/files/patch-gcc_jit_Make-lang.in b/lang/gcc11/files/patch-gcc_jit_Make-lang.in
deleted file mode 100644
index 85728a1cb0d0..000000000000
--- a/lang/gcc11/files/patch-gcc_jit_Make-lang.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- gcc/jit/Make-lang.in.orig 2022-11-02 17:25:43 UTC
-+++ gcc/jit/Make-lang.in
-@@ -355,9 +355,9 @@ jit.install-headers: installdirs
- # Install hooks:
- jit.install-headers: installdirs
- $(INSTALL_DATA) $(srcdir)/jit/libgccjit.h \
-- $(DESTDIR)$(includedir)/libgccjit.h
-+ $(DESTDIR)$(libsubincludedir)/libgccjit.h
- $(INSTALL_DATA) $(srcdir)/jit/libgccjit++.h \
-- $(DESTDIR)$(includedir)/libgccjit++.h
-+ $(DESTDIR)$(libsubincludedir)/libgccjit++.h
-
- ifneq (,$(findstring mingw,$(target)))
- jit.install-common: installdirs jit.install-headers
diff --git a/lang/gcc11/pkg-plist b/lang/gcc11/pkg-plist
index b55927fab0f9..86cafdfda739 100644
--- a/lang/gcc11/pkg-plist
+++ b/lang/gcc11/pkg-plist
@@ -20,6 +20,8 @@ bin/gcov-tool%%SUFFIX%%
bin/gdc%%SUFFIX%%
bin/gfortran%%SUFFIX%%
bin/lto-dump%%SUFFIX%%
+include/libgccjit++.h
+include/libgccjit.h
man/man1/cpp%%SUFFIX%%.1.gz
man/man1/g++%%SUFFIX%%.1.gz
man/man1/gcc%%SUFFIX%%.1.gz