aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-04-13 00:50:31 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-04-14 14:16:07 +0000
commit9f0f032b1f0dd9fc2013b6742061b4e2e31c51cc (patch)
treea7c27615ad30d62464e5f10e5e3e9c7085577ba5
parentacbf6fa6cb42a609fec8fcaf5f0a5a3f8810817b (diff)
downloadports-9f0f032b1f0dd9fc2013b6742061b4e2e31c51cc.tar.gz
ports-9f0f032b1f0dd9fc2013b6742061b4e2e31c51cc.zip
games/joequake: work around duplicate symbol issues
Supply -fcommon to enable a build with recent clang. This fixes the build on FreeBSD 13+.
-rw-r--r--games/joequake/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/games/joequake/Makefile b/games/joequake/Makefile
index 0990f58dee6d..e7a62c5b3590 100644
--- a/games/joequake/Makefile
+++ b/games/joequake/Makefile
@@ -1,6 +1,6 @@
PORTNAME= joequake
PORTVERSION= 0.15b1329
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= http://joequake.runecentral.com/
DISTNAME= ${PORTNAME}-v${PORTVERSION}-source
@@ -14,17 +14,14 @@ WWW= http://runecentral.com/joequake/
LICENSE= GPLv2+
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: com_searchpaths
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: com_searchpaths
-
LIB_DEPENDS= libpng.so:graphics/png
-WRKSRC= ${WRKDIR}/src
-
USES= gmake zip
USE_CSTD= gnu89
MAKEFILE= Makefile.linux
+CFLAGS+= -fcommon
+WRKSRC= ${WRKDIR}/src
OPTIONS_MULTI= UI
OPTIONS_MULTI_UI= OPENGL X11