aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-27 05:38:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-27 05:38:03 +0000
commit9f1e799a0b1209bbfe98e1da627ff4039ebe70fb (patch)
tree4619a212642b9c63a34fec72e54022bc76d9f0e6
parentc30de349ad0bf4aa2f163130147a270b02c25a42 (diff)
downloadports-9f1e799a0b1209bbfe98e1da627ff4039ebe70fb.tar.gz
ports-9f1e799a0b1209bbfe98e1da627ff4039ebe70fb.zip
*: Change {RUN,TEST}_DEPENDS from security/py-service_identity to security/py-service-identity
- Bump PORTREVISION for dependency change (except security/py-trustme) PR: 275167 Reported by: Joakim Bergman <jocke@gipset.se>
-rw-r--r--databases/py-carbon/Makefile4
-rw-r--r--devel/py-buildbot-www/Makefile3
-rw-r--r--devel/py-twisted/Makefile3
-rw-r--r--mail/py-alot/Makefile3
-rw-r--r--multimedia/syncplay/Makefile4
-rw-r--r--net-im/py-matrix-synapse/Makefile3
-rw-r--r--net-im/py-unmessage/Makefile4
-rw-r--r--net-p2p/deluge-cli/Makefile3
-rw-r--r--net/py-matrix-synapse-ldap3/Makefile3
-rw-r--r--security/cowrie/Makefile3
-rw-r--r--security/py-trustme/Makefile2
-rw-r--r--sysutils/datadog-integrations/Makefile3
-rw-r--r--www/py-autobahn/Makefile3
-rw-r--r--www/py-scrapy/Makefile3
-rw-r--r--www/py-treq/Makefile3
15 files changed, 29 insertions, 18 deletions
diff --git a/databases/py-carbon/Makefile b/databases/py-carbon/Makefile
index d8ffba242949..89318ac71662 100644
--- a/databases/py-carbon/Makefile
+++ b/databases/py-carbon/Makefile
@@ -1,6 +1,6 @@
PORTNAME= carbon
PORTVERSION= 1.1.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cachetools>=1.1.0:devel/py-cachetools@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=13.2.0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}txamqp>=0.3:net/py-txamqp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urllib3>=0:net/py-urllib3@${PY_FLAVOR} \
diff --git a/devel/py-buildbot-www/Makefile b/devel/py-buildbot-www/Makefile
index 332669c5ec03..26af35d680c5 100644
--- a/devel/py-buildbot-www/Makefile
+++ b/devel/py-buildbot-www/Makefile
@@ -1,5 +1,6 @@
PORTNAME= buildbot-www
PORTVERSION= 3.9.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot-pkg==${PORTVERSION}:devel/py-buil
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}buildbot-console-view==${PORTVERSION}:devel/py-buildbot-console-view@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}buildbot-grid-view==${PORTVERSION}:devel/py-buildbot-grid-view@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}buildbot-waterfall-view==${PORTVERSION}:devel/py-buildbot-waterfall-view@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=16.0.0:security/py-service_identity@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=16.0.0:security/py-service-identity@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
diff --git a/devel/py-twisted/Makefile b/devel/py-twisted/Makefile
index 201d05d62ca0..b212392df098 100644
--- a/devel/py-twisted/Makefile
+++ b/devel/py-twisted/Makefile
@@ -1,5 +1,6 @@
PORTNAME= twisted
PORTVERSION= 23.8.0
+PORTREVISION= 1
CATEGORIES= devel net python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -46,7 +47,7 @@ HTTP2_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}h2>=3.0<5.0:www/py-h2@${PY_FLAVOR} \
SERIAL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyserial>=3.0:comms/py-pyserial@${PY_FLAVOR}
TLS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}idna>=2.4:dns/py-idna@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=21.0.0,1:security/py-openssl@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=18.1.0:security/py-service_identity@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=18.1.0:security/py-service-identity@${PY_FLAVOR}
# We need twisted.trial in PYTHONPATH
# twisted.conch tests depend on finding certain scripts in PATH
diff --git a/mail/py-alot/Makefile b/mail/py-alot/Makefile
index 8ae07abfa6d4..91644f046619 100644
--- a/mail/py-alot/Makefile
+++ b/mail/py-alot/Makefile
@@ -1,5 +1,6 @@
PORTNAME= alot
DISTVERSION= 0.9
+PORTREVISION= 1
CATEGORIES= mail python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notmuch>=0.27:mail/py-notmuch@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-magic>0:devel/py-python-magic@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=18.4.0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urwidtrees>1.0:devel/py-urwidtrees@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>0:security/py-service_identity@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}service-identity>0:security/py-service-identity@${PY_FLAVOR}
USES= python
USE_GITHUB= yes
diff --git a/multimedia/syncplay/Makefile b/multimedia/syncplay/Makefile
index 108894833b88..a735699839b4 100644
--- a/multimedia/syncplay/Makefile
+++ b/multimedia/syncplay/Makefile
@@ -1,7 +1,7 @@
PORTNAME= syncplay
DISTVERSIONPREFIX= v
DISTVERSION= 1.6.4a
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MAINTAINER= heckendorfc@gmail.com
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=0:security/py-openssl@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}idna>=0:dns/py-idna@${PY_FLAVOR}
USES= desktop-file-utils gmake python shebangfix
diff --git a/net-im/py-matrix-synapse/Makefile b/net-im/py-matrix-synapse/Makefile
index e807839ff381..127cc849eef7 100644
--- a/net-im/py-matrix-synapse/Makefile
+++ b/net-im/py-matrix-synapse/Makefile
@@ -1,5 +1,6 @@
PORTNAME= matrix-synapse
DISTVERSION= 1.96.1
+PORTREVISION= 1
CATEGORIES= net-im python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_F
${PYTHON_PKGNAMEPREFIX}unpaddedbase64>=2.1.0:devel/py-unpaddedbase64@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}canonicaljson>=2.0.0<3.0.0:devel/py-canonicaljson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}signedjson>=1.1.0<2.0.0:security/py-signedjson@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=18.1.0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=18.1.0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=18.9.0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}treq>=15.1:www/py-treq@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${PY_FLAVOR} \
diff --git a/net-im/py-unmessage/Makefile b/net-im/py-unmessage/Makefile
index 7f65a49c3529..96bbbb98540e 100644
--- a/net-im/py-unmessage/Makefile
+++ b/net-im/py-unmessage/Makefile
@@ -1,6 +1,6 @@
PORTNAME= unmessage
DISTVERSION= 0.2.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-im net-p2p python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -23,7 +23,7 @@ RUN_DEPENDS= tor:security/tor \
${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
# Twisted[tls]
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}idna>=0.6:dns/py-idna@${PY_FLAVOR}
USES= python
diff --git a/net-p2p/deluge-cli/Makefile b/net-p2p/deluge-cli/Makefile
index 704d3967c71b..50a6006c4a29 100644
--- a/net-p2p/deluge-cli/Makefile
+++ b/net-p2p/deluge-cli/Makefile
@@ -1,5 +1,6 @@
PORTNAME= deluge
DISTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= net-p2p python
MASTER_SITES= PYPI
PKGNAMESUFFIX= -cli
@@ -19,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>=0.18:devel/py-xdg@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=0.8:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}chardet>=1.0.1:textproc/py-chardet@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mako>=0.2.5:textproc/py-mako@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rencode>0:converters/py-rencode@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
diff --git a/net/py-matrix-synapse-ldap3/Makefile b/net/py-matrix-synapse-ldap3/Makefile
index 36795cc941f2..108957a55852 100644
--- a/net/py-matrix-synapse-ldap3/Makefile
+++ b/net/py-matrix-synapse-ldap3/Makefile
@@ -1,5 +1,6 @@
PORTNAME= matrix-synapse-ldap3
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=39.2.0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ldap3>=2.8:net/py-ldap3@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=15.1.0:devel/py-twisted@${PY_FLAVOR}
USES= python
diff --git a/security/cowrie/Makefile b/security/cowrie/Makefile
index 98b772c8e646..ff3593c4fca8 100644
--- a/security/cowrie/Makefile
+++ b/security/cowrie/Makefile
@@ -1,6 +1,7 @@
PORTNAME= cowrie
DISTVERSIONPREFIX= v
DISTVERSION= 2.5.0
+PORTREVISION= 1
CATEGORIES= security python
MAINTAINER= yuri@FreeBSD.org
@@ -23,7 +24,7 @@ RUN_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}packaging>0:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1-modules>0:devel/py-pyasn1-modules@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyparsing>0:devel/py-pyparsing@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tftpy>0:ftp/py-tftpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>0:devel/py-twisted@${PY_FLAVOR}
diff --git a/security/py-trustme/Makefile b/security/py-trustme/Makefile
index eba4bfc8f22a..e579b32971b2 100644
--- a/security/py-trustme/Makefile
+++ b/security/py-trustme/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}idna>=0:dns/py-idna@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=0:security/py-openssl@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=0:security/py-service_identity@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=0:security/py-service-identity@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist cryptography distutils pytest
diff --git a/sysutils/datadog-integrations/Makefile b/sysutils/datadog-integrations/Makefile
index adec374a541d..f5123adb4539 100644
--- a/sysutils/datadog-integrations/Makefile
+++ b/sysutils/datadog-integrations/Makefile
@@ -1,5 +1,6 @@
PORTNAME= datadog-integrations
DISTVERSION= 7.24.0
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= uros@gruber.si
@@ -101,7 +102,7 @@ REDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}redis>0:databases/py-redis@${PY_FLAVOR
SSH_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko@${PY_FLAVOR}
SYS_CORE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR}
SYS_SWAP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR}
-TLS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}service_identity>0:security/py-service_identity@${PY_FLAVOR}
+TLS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}service-identity>0:security/py-service-identity@${PY_FLAVOR}
.include <bsd.port.options.mk>
diff --git a/www/py-autobahn/Makefile b/www/py-autobahn/Makefile
index 950a2c11e7e3..699605775ee1 100644
--- a/www/py-autobahn/Makefile
+++ b/www/py-autobahn/Makefile
@@ -1,5 +1,6 @@
PORTNAME= autobahn
PORTVERSION= 23.6.2
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -43,7 +44,7 @@ ENCRYPTION_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>=20.0.1:security/py-open
${PYTHON_PKGNAMEPREFIX}pynacl>=1.4.0:security/py-pynacl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}qrcode>=7.3.1:textproc/py-qrcode@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytrie>=0.4.0:devel/py-pytrie@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=18.1.0:security/py-service_identity@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=18.1.0:security/py-service-identity@${PY_FLAVOR}
SCRAM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argon2-cffi>=20.1.0:security/py-argon2-cffi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cffi>=1.14.5:devel/py-cffi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}passlib>=1.7.4:security/py-passlib@${PY_FLAVOR}
diff --git a/www/py-scrapy/Makefile b/www/py-scrapy/Makefile
index c484c623984f..a5669dfa555d 100644
--- a/www/py-scrapy/Makefile
+++ b/www/py-scrapy/Makefile
@@ -1,5 +1,6 @@
PORTNAME= Scrapy
DISTVERSION= 2.5.1
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cssselect>=0.9.1:www/py-cssselect@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}parsel>=1.5:textproc/py-parsel@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=16.2.0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}queuelib>=1.4.2:sysutils/py-queuelib@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=16.0.0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=16.0.0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}w3lib>=1.17.0:www/py-w3lib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zope.interface>=4.1.3:devel/py-zope.interface@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}protego>=0.1.15:www/py-protego@${PY_FLAVOR} \
diff --git a/www/py-treq/Makefile b/www/py-treq/Makefile
index f33ccebac8a5..4bde0602b854 100644
--- a/www/py-treq/Makefile
+++ b/www/py-treq/Makefile
@@ -1,5 +1,6 @@
PORTNAME= treq
PORTVERSION= 22.2.0
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR} \
# Depend directly on twisted[tls] dependencies
# As Twisted port may not (optionally) install them
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>=18.1.0:security/py-service_identity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}service-identity>=18.1.0:security/py-service-identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}idna>=2.4:dns/py-idna@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httpbin>=0.5.0:www/py-httpbin@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \