aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-24 19:59:31 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-24 20:01:01 +0000
commit9f5034f55a47591288167cd49fe4bb963143caed (patch)
tree0b6c120ab49d54122cd04ffd61a0cd6f42f9bf51
parente6b5fb28a560cda9f101a2c2fc55ef70f00a2179 (diff)
downloadports-9f5034f55a47591288167cd49fe4bb963143caed.tar.gz
ports-9f5034f55a47591288167cd49fe4bb963143caed.zip
Mk/Uses/php.mk: Refactor
- Replace old USE_APACHE_RUN with USES=apache:run - Prior to php8.0 there was a check for the required libname which contained the version number of php. Remove the conditional. Sponsored by: Bounce Experts
-rw-r--r--Mk/Uses/php.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index 4d142472d140..c87eb96c4ad8 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -273,14 +273,9 @@ BUILD_DEPENDS+= ${PHPBASE}/include/php/main/php.h:${PHP_PORT}
. endif
RUN_DEPENDS+= ${PHPBASE}/include/php/main/php.h:${PHP_PORT}
. if ${php_ARGS:Mmod} || (${php_ARGS:Mweb} && defined(PHP_VERSION) && ${PHP_SAPI:Mcgi} == "" && ${PHP_SAPI:Mfpm} == "")
-USE_APACHE_RUN= 22+
+USES= apache:run
.include "${PORTSDIR}/Mk/Uses/apache.mk"
-. if ${PHP_VER} < 80
-# libphpX.so only has the major version number in it, so remove the last digit of PHP_VER to get it.
-RUN_DEPENDS+= ${PHPBASE}/${APACHEMODDIR}/libphp${PHP_VER:C/.$//}.so:${MOD_PHP_PORT}
-. else
RUN_DEPENDS+= ${PHPBASE}/${APACHEMODDIR}/libphp.so:${MOD_PHP_PORT}
-. endif
. endif
PLIST_SUB+= PHP_EXT_DIR=${PHP_EXT_DIR}