aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-05-17 02:28:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-05-17 18:21:12 +0000
commit9f8efcf04b1456fc1be529b09d84981aa6e8cf5b (patch)
treea9f3d4a6c2cdf4fce2857a119506793b4797025f
parentf6c8fb6feb635f9368fa1b6fc70119d2fbe5d237 (diff)
downloadports-9f8efcf04b1456fc1be529b09d84981aa6e8cf5b.tar.gz
ports-9f8efcf04b1456fc1be529b09d84981aa6e8cf5b.zip
x11/libei: add new port
libei is a library for Emulated Input, primarily aimed at the Wayland stack. It provides three parts: - EI (Emulated Input) for the client side (libei) - EIS (Emulated Input Server) for the server side (libeis) - oeffis is an optional helper library for DBus communication with the XDG RemoteDesktop portal (liboeffis) https://gitlab.freedesktop.org/libinput/libei
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libei/Makefile56
-rw-r--r--x11/libei/distinfo17
-rw-r--r--x11/libei/pkg-descr6
-rw-r--r--x11/libei/pkg-plist16
5 files changed, 96 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 187431083ad5..586222390f75 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -185,6 +185,7 @@
SUBDIR += libXxf86dga
SUBDIR += libXxf86vm
SUBDIR += libclipboard
+ SUBDIR += libei
SUBDIR += libexo
SUBDIR += libfakekey
SUBDIR += libfm
diff --git a/x11/libei/Makefile b/x11/libei/Makefile
new file mode 100644
index 000000000000..5c7dd44078fc
--- /dev/null
+++ b/x11/libei/Makefile
@@ -0,0 +1,56 @@
+PORTNAME= libei
+DISTVERSION= 0.99.1
+CATEGORIES= x11
+
+PATCH_SITES= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/-/commit/
+PATCHFILES+= e01ce3480e9a.patch:-p1 # https://gitlab.freedesktop.org/libinput/libei/-/merge_requests/202
+PATCHFILES+= dd817c8ddec6.patch:-p1 # https://gitlab.freedesktop.org/libinput/libei/-/merge_requests/202
+PATCHFILES+= a6e5bae3e0bd.patch:-p1 # https://gitlab.freedesktop.org/libinput/libei/-/merge_requests/202
+PATCHFILES+= 58371a9f1143.patch:-p1 # https://gitlab.freedesktop.org/libinput/libei/-/merge_requests/202
+PATCHFILES+= 143bfd52603f.patch:-p1 # https://gitlab.freedesktop.org/libinput/libei/-/merge_requests/202
+PATCHFILES+= 57a9059d644c.patch:-p1 # https://gitlab.freedesktop.org/libinput/libei/-/merge_requests/202
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Library for Emulated Input
+WWW= https://gitlab.freedesktop.org/libinput/libei
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ ${PYTHON_PKGNAMEPREFIX}attrs>0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR}
+LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
+ libevdev.so:devel/libevdev
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-dbusmock>0:devel/py-python-dbusmock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}StrEnum>0:devel/py-strenum@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}structlog>0:devel/py-structlog@${PY_FLAVOR} \
+
+USES= compiler:c11 localbase meson pkgconfig python:build
+USE_GITHUB= nodefault
+USE_GITLAB= yes
+GH_TUPLE= nemequ:munit:v0.2.0-38-gfbbdf14:munit/subprojects/munit
+GL_SITE= https://gitlab.freedesktop.org
+GL_ACCOUNT= libinput
+GL_COMMIT= df268d618a199ca5c71f47b1e17cd6cd3d87fc0e
+BINARY_ALIAS= python3=${PYTHON_CMD}
+MESON_ARGS= -Dsd-bus-provider=basu -Dtests=disabled
+CFLAGS+= -Wno-typedef-redefinition # https://gitlab.freedesktop.org/libinput/libei/-/issues/31
+
+OPTIONS_DEFINE= BASU
+OPTIONS_DEFAULT=BASU
+OPTIONS_SUB= yes
+
+BASU_DESC= XDG RemoteDesktop portal via basu
+BASU_LIB_DEPENDS= libbasu.so:devel/basu
+BASU_MESON_ENABLED= liboeffis
+
+pre-test:
+ @if [ ! -e ${WRKDIR}/.meson_build_tests ]; then \
+ ${RM} ${CONFIGURE_COOKIE} ${BUILD_COOKIE}; \
+ ${MAKE} -C${.CURDIR} build MESON_ARGS="${MESON_ARGS} --reconfigure -Dtests=enabled"; \
+ ${TOUCH} ${WRKDIR}/.meson_build_tests; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/x11/libei/distinfo b/x11/libei/distinfo
new file mode 100644
index 000000000000..c10bb8d02b61
--- /dev/null
+++ b/x11/libei/distinfo
@@ -0,0 +1,17 @@
+TIMESTAMP = 1684290492
+SHA256 (nemequ-munit-v0.2.0-38-gfbbdf14_GH0.tar.gz) = c37c11b5e66e8cec78d2a365f7dd1e999e61cfd3d2e9a4fa9d4f50cd9711007a
+SIZE (nemequ-munit-v0.2.0-38-gfbbdf14_GH0.tar.gz) = 27712
+SHA256 (libinput-libei-df268d618a199ca5c71f47b1e17cd6cd3d87fc0e_GL0.tar.gz) = c574611e3cc8d15e68012746d19e84b2b384ce764fe08a126deaf56433d61368
+SIZE (libinput-libei-df268d618a199ca5c71f47b1e17cd6cd3d87fc0e_GL0.tar.gz) = 215194
+SHA256 (e01ce3480e9a.patch) = eacb590aae92625ada9c1812b9e7eb025261564592bc09ab31b224509c05ae2d
+SIZE (e01ce3480e9a.patch) = 1819
+SHA256 (dd817c8ddec6.patch) = 7918d80113b38ae14774be12db1b638ecd06c23ba2573b7494184a33ca593eaa
+SIZE (dd817c8ddec6.patch) = 2552
+SHA256 (a6e5bae3e0bd.patch) = f7774147e8cf83edcc6814a3b778621efd92e0bc293a1dad39ae4e306f9a1037
+SIZE (a6e5bae3e0bd.patch) = 1444
+SHA256 (58371a9f1143.patch) = 0994bf913360f246d857b82534dbb0da2868bc6ed6fec5286c0388e913020614
+SIZE (58371a9f1143.patch) = 3959
+SHA256 (143bfd52603f.patch) = 7ef7cf41fc2204ee86fe2248145b66e03f8ee806cbcfd9863f9e393b7f9460fe
+SIZE (143bfd52603f.patch) = 1020
+SHA256 (57a9059d644c.patch) = e81a2dbdc3e21cd1a46474b183d343952bb008597a80b54608e684768b2446cf
+SIZE (57a9059d644c.patch) = 1893
diff --git a/x11/libei/pkg-descr b/x11/libei/pkg-descr
new file mode 100644
index 000000000000..d097616cc87c
--- /dev/null
+++ b/x11/libei/pkg-descr
@@ -0,0 +1,6 @@
+libei is a library for Emulated Input, primarily aimed at the Wayland
+stack. It provides three parts:
+- EI (Emulated Input) for the client side (libei)
+- EIS (Emulated Input Server) for the server side (libeis)
+- oeffis is an optional helper library for DBus communication with the
+ XDG RemoteDesktop portal (liboeffis)
diff --git a/x11/libei/pkg-plist b/x11/libei/pkg-plist
new file mode 100644
index 000000000000..ca3ae37c0c1e
--- /dev/null
+++ b/x11/libei/pkg-plist
@@ -0,0 +1,16 @@
+bin/ei-debug-events
+include/libei-1.0/libei.h
+include/libei-1.0/libeis.h
+%%BASU%%include/libei-1.0/liboeffis.h
+lib/libei.so
+lib/libei.so.1
+lib/libei.so.1.0.0
+lib/libeis.so
+lib/libeis.so.1
+lib/libeis.so.1.0.0
+%%BASU%%lib/liboeffis.so
+%%BASU%%lib/liboeffis.so.1
+%%BASU%%lib/liboeffis.so.1.0.0
+libdata/pkgconfig/libei-1.0.pc
+libdata/pkgconfig/libeis-1.0.pc
+%%BASU%%libdata/pkgconfig/liboeffis-1.0.pc