aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-02-14 08:30:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-02-14 09:28:06 +0000
commit9fbf3d33dfa9e44940c71276b94a4d0241a46dbb (patch)
tree76f3e7981122fb05655701e530f29a1892f9622f
parent2ec2de96fe6b5feaac79a6ba5b3e2e79baded952 (diff)
downloadports-9fbf3d33dfa9e44940c71276b94a4d0241a46dbb.tar.gz
ports-9fbf3d33dfa9e44940c71276b94a4d0241a46dbb.zip
devel/actor-framework: update 0.19.2 → 0.19.6
Reported by: portscout
-rw-r--r--devel/actor-framework/Makefile2
-rw-r--r--devel/actor-framework/distinfo6
-rw-r--r--devel/actor-framework/pkg-plist110
3 files changed, 86 insertions, 32 deletions
diff --git a/devel/actor-framework/Makefile b/devel/actor-framework/Makefile
index 00c0ebdda77b..6dd55bdf219d 100644
--- a/devel/actor-framework/Makefile
+++ b/devel/actor-framework/Makefile
@@ -1,5 +1,5 @@
PORTNAME= actor-framework
-DISTVERSION= 0.19.2
+DISTVERSION= 0.19.6
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
diff --git a/devel/actor-framework/distinfo b/devel/actor-framework/distinfo
index 4d6e53568deb..73b85df54ba1 100644
--- a/devel/actor-framework/distinfo
+++ b/devel/actor-framework/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1687735259
-SHA256 (actor-framework-actor-framework-0.19.2_GH0.tar.gz) = aa3fcc494424e0e20b177125458a6a6ed39c751a3d3d5193054e88bdf8a146d2
-SIZE (actor-framework-actor-framework-0.19.2_GH0.tar.gz) = 3188536
+TIMESTAMP = 1707893875
+SHA256 (actor-framework-actor-framework-0.19.6_GH0.tar.gz) = 48dc4c4abf5ab5a7c6f84b9259cc8be1b02c601d31893647ab44e143cdc4b6d5
+SIZE (actor-framework-actor-framework-0.19.6_GH0.tar.gz) = 3277725
diff --git a/devel/actor-framework/pkg-plist b/devel/actor-framework/pkg-plist
index 57e4948488c7..48b6590b64b1 100644
--- a/devel/actor-framework/pkg-plist
+++ b/devel/actor-framework/pkg-plist
@@ -3,6 +3,7 @@ bin/caf-vec
include/caf/abstract_actor.hpp
include/caf/abstract_channel.hpp
include/caf/abstract_group.hpp
+include/caf/abstract_mailbox.hpp
include/caf/action.hpp
include/caf/actor.hpp
include/caf/actor_addr.hpp
@@ -12,6 +13,7 @@ include/caf/actor_companion.hpp
include/caf/actor_config.hpp
include/caf/actor_control_block.hpp
include/caf/actor_factory.hpp
+include/caf/actor_from_state.hpp
include/caf/actor_ostream.hpp
include/caf/actor_pool.hpp
include/caf/actor_profiler.hpp
@@ -30,12 +32,14 @@ include/caf/async/blocking_producer.hpp
include/caf/async/consumer.hpp
include/caf/async/consumer_adapter.hpp
include/caf/async/execution_context.hpp
+include/caf/async/file.hpp
include/caf/async/future.hpp
include/caf/async/fwd.hpp
include/caf/async/policy.hpp
include/caf/async/producer.hpp
include/caf/async/producer_adapter.hpp
include/caf/async/promise.hpp
+include/caf/async/publisher.hpp
include/caf/async/read_result.hpp
include/caf/async/spsc_buffer.hpp
include/caf/async/write_result.hpp
@@ -54,6 +58,8 @@ include/caf/callback.hpp
include/caf/catch_all.hpp
include/caf/check_typed_input.hpp
include/caf/chrono.hpp
+include/caf/chunk.hpp
+include/caf/chunked_string.hpp
include/caf/composed_type.hpp
include/caf/config.hpp
include/caf/config_option.hpp
@@ -77,6 +83,7 @@ include/caf/deserializer.hpp
include/caf/detail/abstract_worker.hpp
include/caf/detail/abstract_worker_hub.hpp
include/caf/detail/accept_handler.hpp
+include/caf/detail/actor_local_printer.hpp
include/caf/detail/algorithms.hpp
include/caf/detail/append_hex.hpp
include/caf/detail/apply_args.hpp
@@ -99,13 +106,13 @@ include/caf/detail/consumer.hpp
include/caf/detail/convert_ip_endpoint.hpp
include/caf/detail/core_export.hpp
include/caf/detail/default_invoke_result_visitor.hpp
+include/caf/detail/default_mailbox.hpp
include/caf/detail/dispose_on_call.hpp
include/caf/detail/double_ended_queue.hpp
include/caf/detail/flow_bridge_base.hpp
+include/caf/detail/format.hpp
include/caf/detail/functor_attachable.hpp
-include/caf/detail/get_mac_addresses.hpp
include/caf/detail/get_process_id.hpp
-include/caf/detail/get_root_uuid.hpp
include/caf/detail/glob_match.hpp
include/caf/detail/group_tunnel.hpp
include/caf/detail/ieee_754.hpp
@@ -121,7 +128,9 @@ include/caf/detail/json.hpp
include/caf/detail/latch.hpp
include/caf/detail/local_group_module.hpp
include/caf/detail/log_level.hpp
+include/caf/detail/log_level_map.hpp
include/caf/detail/lp_flow_bridge.hpp
+include/caf/detail/mailbox_factory.hpp
include/caf/detail/make_meta_object.hpp
include/caf/detail/mask_bits.hpp
include/caf/detail/message_builder_element.hpp
@@ -130,6 +139,7 @@ include/caf/detail/message_flow_bridge.hpp
include/caf/detail/meta_object.hpp
include/caf/detail/monotonic_buffer_resource.hpp
include/caf/detail/mtl_util.hpp
+include/caf/detail/nearly_equal.hpp
include/caf/detail/net_export.hpp
include/caf/detail/net_syscall.hpp
include/caf/detail/network_order.hpp
@@ -160,7 +170,6 @@ include/caf/detail/parser/read_unsigned_integer.hpp
include/caf/detail/parser/read_uri.hpp
include/caf/detail/parser/sub_ascii.hpp
include/caf/detail/plain_ref_counted.hpp
-include/caf/detail/pollset_updater.hpp
include/caf/detail/pp.hpp
include/caf/detail/pretty_type_name.hpp
include/caf/detail/print.hpp
@@ -169,9 +178,9 @@ include/caf/detail/private_thread_pool.hpp
include/caf/detail/profiled_send.hpp
include/caf/detail/prometheus_broker.hpp
include/caf/detail/remote_group_module.hpp
+include/caf/detail/rfc3629.hpp
include/caf/detail/rfc6455.hpp
-include/caf/detail/ringbuffer.hpp
-include/caf/detail/ripemd_160.hpp
+include/caf/detail/ring_buffer.hpp
include/caf/detail/scope_guard.hpp
include/caf/detail/select_all.hpp
include/caf/detail/set_thread_name.hpp
@@ -179,6 +188,7 @@ include/caf/detail/sockaddr_members.hpp
include/caf/detail/socket_guard.hpp
include/caf/detail/socket_sys_aliases.hpp
include/caf/detail/socket_sys_includes.hpp
+include/caf/detail/source_location.hpp
include/caf/detail/spawn_fwd.hpp
include/caf/detail/spawnable.hpp
include/caf/detail/split_join.hpp
@@ -186,8 +196,9 @@ include/caf/detail/squashed_int.hpp
include/caf/detail/stream_bridge.hpp
include/caf/detail/stringification_inspector.hpp
include/caf/detail/sync_request_bouncer.hpp
+include/caf/detail/sync_ring_buffer.hpp
include/caf/detail/tbind.hpp
-include/caf/detail/test_actor_clock.hpp
+include/caf/detail/test_export.hpp
include/caf/detail/thread_safe_actor_clock.hpp
include/caf/detail/type_id_list_builder.hpp
include/caf/detail/type_list.hpp
@@ -206,6 +217,7 @@ include/caf/execution_unit.hpp
include/caf/exit_reason.hpp
include/caf/expected.hpp
include/caf/extend.hpp
+include/caf/flow/byte.hpp
include/caf/flow/coordinated.hpp
include/caf/flow/coordinator.hpp
include/caf/flow/fwd.hpp
@@ -216,6 +228,7 @@ include/caf/flow/gen/iota.hpp
include/caf/flow/gen/just.hpp
include/caf/flow/gen/repeat.hpp
include/caf/flow/item_publisher.hpp
+include/caf/flow/multicaster.hpp
include/caf/flow/observable.hpp
include/caf/flow/observable_builder.hpp
include/caf/flow/observable_decl.hpp
@@ -238,6 +251,7 @@ include/caf/flow/op/merge.hpp
include/caf/flow/op/never.hpp
include/caf/flow/op/prefix_and_tail.hpp
include/caf/flow/op/publish.hpp
+include/caf/flow/op/pullable.hpp
include/caf/flow/op/state.hpp
include/caf/flow/op/ucast.hpp
include/caf/flow/op/zip_with.hpp
@@ -249,15 +263,24 @@ include/caf/flow/step/do_finally.hpp
include/caf/flow/step/do_on_complete.hpp
include/caf/flow/step/do_on_error.hpp
include/caf/flow/step/do_on_next.hpp
+include/caf/flow/step/element_at.hpp
include/caf/flow/step/filter.hpp
include/caf/flow/step/fwd.hpp
+include/caf/flow/step/ignore_elements.hpp
include/caf/flow/step/map.hpp
include/caf/flow/step/on_error_complete.hpp
+include/caf/flow/step/on_error_return.hpp
+include/caf/flow/step/on_error_return_item.hpp
include/caf/flow/step/reduce.hpp
+include/caf/flow/step/scan.hpp
include/caf/flow/step/skip.hpp
+include/caf/flow/step/skip_last.hpp
include/caf/flow/step/take.hpp
+include/caf/flow/step/take_last.hpp
include/caf/flow/step/take_while.hpp
+include/caf/flow/string.hpp
include/caf/flow/subscription.hpp
+include/caf/format_string_with_location.hpp
include/caf/forwarding_actor_proxy.hpp
include/caf/function_view.hpp
include/caf/fwd.hpp
@@ -274,18 +297,12 @@ include/caf/inspector_access.hpp
include/caf/inspector_access_base.hpp
include/caf/inspector_access_type.hpp
include/caf/interface_mismatch.hpp
-include/caf/intrusive/drr_cached_queue.hpp
-include/caf/intrusive/drr_queue.hpp
-include/caf/intrusive/fifo_inbox.hpp
include/caf/intrusive/forward_iterator.hpp
include/caf/intrusive/inbox_result.hpp
include/caf/intrusive/lifo_inbox.hpp
-include/caf/intrusive/new_round_result.hpp
+include/caf/intrusive/linked_list.hpp
include/caf/intrusive/singly_linked.hpp
-include/caf/intrusive/task_queue.hpp
-include/caf/intrusive/task_result.hpp
-include/caf/intrusive/wdrr_dynamic_multiplexed_queue.hpp
-include/caf/intrusive/wdrr_fixed_multiplexed_queue.hpp
+include/caf/intrusive/stack.hpp
include/caf/intrusive_cow_ptr.hpp
include/caf/intrusive_ptr.hpp
include/caf/invoke_message_result.hpp
@@ -343,7 +360,6 @@ include/caf/io/network/scribe_impl.hpp
include/caf/io/network/stream.hpp
include/caf/io/network/stream_impl.hpp
include/caf/io/network/stream_manager.hpp
-include/caf/io/network/test_multiplexer.hpp
include/caf/io/open.hpp
include/caf/io/publish.hpp
include/caf/io/receive_policy.hpp
@@ -376,6 +392,14 @@ include/caf/json_writer.hpp
include/caf/load_inspector.hpp
include/caf/load_inspector_base.hpp
include/caf/local_actor.hpp
+include/caf/log/core.hpp
+include/caf/log/event.hpp
+include/caf/log/io.hpp
+include/caf/log/level.hpp
+include/caf/log/net.hpp
+include/caf/log/openssl.hpp
+include/caf/log/system.hpp
+include/caf/log/test.hpp
include/caf/logger.hpp
include/caf/mailbox_element.hpp
include/caf/make_actor.hpp
@@ -410,7 +434,8 @@ include/caf/net/dsl/get_name.hpp
include/caf/net/dsl/has_accept.hpp
include/caf/net/dsl/has_connect.hpp
include/caf/net/dsl/has_context.hpp
-include/caf/net/dsl/has_ctx.hpp
+include/caf/net/dsl/has_lazy_context.hpp
+include/caf/net/dsl/has_make_ctx.hpp
include/caf/net/dsl/has_uri_connect.hpp
include/caf/net/dsl/server_config.hpp
include/caf/net/dsl/server_factory_base.hpp
@@ -418,13 +443,18 @@ include/caf/net/fwd.hpp
include/caf/net/generic_lower_layer.hpp
include/caf/net/generic_upper_layer.hpp
include/caf/net/http/arg_parser.hpp
+include/caf/net/http/async_client.hpp
+include/caf/net/http/client.hpp
+include/caf/net/http/client_factory.hpp
include/caf/net/http/config.hpp
+include/caf/net/http/header.hpp
include/caf/net/http/lower_layer.hpp
include/caf/net/http/method.hpp
include/caf/net/http/request.hpp
include/caf/net/http/request_header.hpp
include/caf/net/http/responder.hpp
include/caf/net/http/response.hpp
+include/caf/net/http/response_header.hpp
include/caf/net/http/route.hpp
include/caf/net/http/router.hpp
include/caf/net/http/server.hpp
@@ -508,8 +538,6 @@ include/caf/others.hpp
include/caf/parser_state.hpp
include/caf/pec.hpp
include/caf/policy/arg.hpp
-include/caf/policy/categorized.hpp
-include/caf/policy/normal_messages.hpp
include/caf/policy/scheduler_policy.hpp
include/caf/policy/select_all.hpp
include/caf/policy/select_any.hpp
@@ -517,7 +545,6 @@ include/caf/policy/single_response.hpp
include/caf/policy/tcp.hpp
include/caf/policy/udp.hpp
include/caf/policy/unprofiled.hpp
-include/caf/policy/urgent_messages.hpp
include/caf/policy/work_sharing.hpp
include/caf/policy/work_stealing.hpp
include/caf/prohibit_top_level_spawn_marker.hpp
@@ -538,7 +565,6 @@ include/caf/scheduler.hpp
include/caf/scheduler/abstract_coordinator.hpp
include/caf/scheduler/coordinator.hpp
include/caf/scheduler/profiled_coordinator.hpp
-include/caf/scheduler/test_coordinator.hpp
include/caf/scheduler/worker.hpp
include/caf/scoped_actor.hpp
include/caf/scoped_execution_unit.hpp
@@ -571,11 +597,38 @@ include/caf/telemetry/metric_registry.hpp
include/caf/telemetry/metric_type.hpp
include/caf/telemetry/timer.hpp
include/caf/term.hpp
+include/caf/test/and_given.hpp
+include/caf/test/and_then.hpp
+include/caf/test/and_when.hpp
include/caf/test/bdd_dsl.hpp
+include/caf/test/binary_predicate.hpp
+include/caf/test/block.hpp
+include/caf/test/block_type.hpp
+include/caf/test/caf_test_main.hpp
+include/caf/test/context.hpp
include/caf/test/dsl.hpp
-include/caf/test/io_dsl.hpp
+include/caf/test/factory.hpp
+include/caf/test/fixture/deterministic.hpp
+include/caf/test/fixture/flow.hpp
+include/caf/test/fwd.hpp
+include/caf/test/given.hpp
+include/caf/test/nesting_error.hpp
+include/caf/test/nil.hpp
+include/caf/test/outline.hpp
+include/caf/test/registry.hpp
+include/caf/test/reporter.hpp
+include/caf/test/requirement_failed.hpp
+include/caf/test/runnable.hpp
+include/caf/test/runner.hpp
+include/caf/test/scenario.hpp
+include/caf/test/scope.hpp
+include/caf/test/section.hpp
+include/caf/test/suite.hpp
+include/caf/test/test.hpp
+include/caf/test/then.hpp
include/caf/test/unit_test.hpp
include/caf/test/unit_test_impl.hpp
+include/caf/test/when.hpp
include/caf/thread_hook.hpp
include/caf/thread_owner.hpp
include/caf/timeout_definition.hpp
@@ -607,13 +660,15 @@ lib/cmake/CAF/CAFConfigVersion.cmake
lib/cmake/CAF/CAFTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/CAF/CAFTargets.cmake
lib/libcaf_core.so
-lib/libcaf_core.so.0.19.2
+lib/libcaf_core.so.0.19.6
lib/libcaf_io.so
-lib/libcaf_io.so.0.19.2
+lib/libcaf_io.so.0.19.6
lib/libcaf_net.so
-lib/libcaf_net.so.0.19.2
+lib/libcaf_net.so.0.19.6
lib/libcaf_openssl.so
-lib/libcaf_openssl.so.0.19.2
+lib/libcaf_openssl.so.0.19.6
+lib/libcaf_test.so
+lib/libcaf_test.so.0.19.6
share/caf/examples/aout.cpp
share/caf/examples/config/read-json.cpp
share/caf/examples/custom_type/custom_types_1.cpp
@@ -626,20 +681,19 @@ share/caf/examples/flow/iota.cpp
share/caf/examples/flow/observe-on.cpp
share/caf/examples/flow/spsc-buffer-resource.cpp
share/caf/examples/hello_world.cpp
+share/caf/examples/http/client.cpp
share/caf/examples/http/rest.cpp
share/caf/examples/http/time-server.cpp
share/caf/examples/length_prefix_framing/chat-client.cpp
share/caf/examples/length_prefix_framing/chat-server.cpp
+share/caf/examples/message_passing/after.cpp
share/caf/examples/message_passing/calculator.cpp
-share/caf/examples/message_passing/cell.cpp
share/caf/examples/message_passing/dancing_kirby.cpp
share/caf/examples/message_passing/delegating.cpp
share/caf/examples/message_passing/divider.cpp
share/caf/examples/message_passing/fan_out_request.cpp
-share/caf/examples/message_passing/fixed_stack.cpp
share/caf/examples/message_passing/promises.cpp
share/caf/examples/message_passing/request.cpp
-share/caf/examples/message_passing/typed_calculator.cpp
share/caf/examples/remoting/distributed_calculator.cpp
share/caf/examples/remoting/remote_spawn.cpp
share/caf/examples/testing/ping_pong.cpp