aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Luis Duran <jlduran@gmail.com>2022-10-26 14:35:42 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2022-10-26 14:35:42 +0000
commita0103c803b137d9cd95310bbfd315103d8e046b2 (patch)
tree1e7756f5bf2b97390b120e1ac30a9ec8b2fe91a0
parent0674c92121aa41f60b82c3a8ebf15503b85538c1 (diff)
downloadports-a0103c803b137d9cd95310bbfd315103d8e046b2.tar.gz
ports-a0103c803b137d9cd95310bbfd315103d8e046b2.zip
security/strongswan: Add GCM option to OPTIONS_DEFAULT
Avoid the message: "plugin 'gcm': failed to load - gcm_plugin_create not found and no plugin file available" According to strongSwan's 5.9.8 release notes[1]: The gcm plugin has been enabled by default, so that the TLS 1.3 unit tests (now indirectly enabled if the pki tool is built due to the implementation of EST) can be completed successfully with just the default plugins. Let's also enable it by default. [1]: https://github.com/strongswan/strongswan/releases/tag/5.9.8 PR: 267352
-rw-r--r--security/strongswan/Makefile3
-rw-r--r--security/strongswan/pkg-message1
2 files changed, 2 insertions, 2 deletions
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index ade37ff9ae0b..b3c29a523c09 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -1,5 +1,6 @@
PORTNAME= strongswan
DISTVERSION= 5.9.8
+PORTREVISION= 1
CATEGORIES= security net-vpn
MASTER_SITES= https://download.strongswan.org/ \
https://download2.strongswan.org/
@@ -45,7 +46,7 @@ OPTIONS_DEFINE= CTR CURL EAPAKA3GPP2 EAPDYNAMIC EAPRADIUS \
PKCS11 PKI PYTHON SCEP SMP SQLITE SWANCTL \
TESTVECTOR TPM TSS2 UNBOUND UNITY VICI XAUTH
OPTIONS_DEFINE_i386= VIA
-OPTIONS_DEFAULT= BUILTIN CURL IKEV1 KDF PKI SWANCTL VICI
+OPTIONS_DEFAULT= BUILTIN CURL GCM IKEV1 KDF PKI SWANCTL VICI
OPTIONS_SINGLE= PRINTF_HOOKS
OPTIONS_SINGLE_PRINTF_HOOKS= BUILTIN LIBC VSTR
OPTIONS_SUB= yes
diff --git a/security/strongswan/pkg-message b/security/strongswan/pkg-message
index e882f4d0f7c0..bb3363279483 100644
--- a/security/strongswan/pkg-message
+++ b/security/strongswan/pkg-message
@@ -16,4 +16,3 @@ set 'strongswan_interface="stroke"' in your rc.conf file.
EOM
}
]
-