aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-04-14 16:39:44 +0000
committerSteve Wills <swills@FreeBSD.org>2016-04-14 16:39:44 +0000
commita010ac0b814af7770df840c87ce2bab398953ffe (patch)
tree8184ee5059cc143c554051b91b770f6d2461121f
parent37e46002437a7359c2cc5c2bc7ed174df6c20551 (diff)
downloadports-a010ac0b814af7770df840c87ce2bab398953ffe.tar.gz
ports-a010ac0b814af7770df840c87ce2bab398953ffe.zip
www/py-django-cors-headers: create port
A Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses. WWW: https://github.com/ottoyiu/django-cors-headers
Notes
Notes: svn path=/head/; revision=413287
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-cors-headers/Makefile19
-rw-r--r--www/py-django-cors-headers/distinfo2
-rw-r--r--www/py-django-cors-headers/pkg-descr4
4 files changed, 26 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1c01ea20ee7f..745e41c72db5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1535,6 +1535,7 @@
SUBDIR += py-django-configurations
SUBDIR += py-django-contact-form
SUBDIR += py-django-contrib-comments
+ SUBDIR += py-django-cors-headers
SUBDIR += py-django-countries
SUBDIR += py-django-crispy-forms
SUBDIR += py-django-datetime-widget
diff --git a/www/py-django-cors-headers/Makefile b/www/py-django-cors-headers/Makefile
new file mode 100644
index 000000000000..d40fe4fde44c
--- /dev/null
+++ b/www/py-django-cors-headers/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= django-cors-headers
+PORTVERSION= 1.1.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Handles server headers required for Cross-Origin Resource Sharing
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django18>0:www/py-django18
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/www/py-django-cors-headers/distinfo b/www/py-django-cors-headers/distinfo
new file mode 100644
index 000000000000..600aa56dc707
--- /dev/null
+++ b/www/py-django-cors-headers/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-cors-headers-1.1.0.tar.gz) = fcd96e2be47c8eef34c650e007a6d546e19e7ee61041b89edbbbbe7619aa3987
+SIZE (django-cors-headers-1.1.0.tar.gz) = 4633
diff --git a/www/py-django-cors-headers/pkg-descr b/www/py-django-cors-headers/pkg-descr
new file mode 100644
index 000000000000..52f4a0864c6a
--- /dev/null
+++ b/www/py-django-cors-headers/pkg-descr
@@ -0,0 +1,4 @@
+A Django App that adds CORS (Cross-Origin Resource Sharing) headers to
+responses.
+
+WWW: https://github.com/ottoyiu/django-cors-headers