aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-12 17:57:20 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-12 19:45:16 +0000
commita053d7c04f8bb49a49fae7d0556ee63cdd2f9085 (patch)
treeef2568ecd69b26528894d9e3da789d06bd2ed16c
parenta4021dd9e20bca9ada21837282e476b6c1356f23 (diff)
downloadports-a053d7c04f8bb49a49fae7d0556ee63cdd2f9085.tar.gz
ports-a053d7c04f8bb49a49fae7d0556ee63cdd2f9085.zip
devel/libexplain: Fix build on 14
- Refactor USES=localbase - Pet portclippy Approved by: portmgr (blanket)
-rw-r--r--devel/libexplain/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/devel/libexplain/Makefile b/devel/libexplain/Makefile
index 0d65b10a40fd..1f2546cb7e6e 100644
--- a/devel/libexplain/Makefile
+++ b/devel/libexplain/Makefile
@@ -12,20 +12,31 @@ WWW= http://libexplain.sourceforge.net/
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Upstream last release was in 2014
+#BROKEN_FreeBSD_14= Build fails with lots of error on llvm15
+
BUILD_DEPENDS= gsed:textproc/gsed
RUN_DEPENDS= lsof:sysutils/lsof
-USES= bison gettext ghostscript:build gmake groff iconv libtool:build
+USES= bison gettext ghostscript:build gmake groff iconv libtool:build localbase
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_linux_kd_h=no
-USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS
PATCHLEVEL= D012
-OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+USES+= llvm:max=14
+CPP= clang-cpp${LLVM_VERSION}
+CC= clang${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+MAKE_JOBS_UNSAFE= yes
+.endif
.include <bsd.port.pre.mk>