aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-03-26 19:39:25 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-03-27 17:19:00 +0000
commita08652fdd9e22b7345445c87a95e4c3ca9fa6b9f (patch)
treeaf48f89a8f35fe0580f9d3be1327f8d7bec3c66b
parentbde47bef8e552bec8b3fc4667fcbbb6baf2f9411 (diff)
downloadports-a08652fdd9e22b7345445c87a95e4c3ca9fa6b9f.tar.gz
ports-a08652fdd9e22b7345445c87a95e4c3ca9fa6b9f.zip
devel/caf: update to 0.18.6
-rw-r--r--devel/caf/Makefile2
-rw-r--r--devel/caf/distinfo6
-rw-r--r--devel/caf/pkg-plist15
3 files changed, 8 insertions, 15 deletions
diff --git a/devel/caf/Makefile b/devel/caf/Makefile
index dd2184c56ff2..e2dd757a7892 100644
--- a/devel/caf/Makefile
+++ b/devel/caf/Makefile
@@ -1,7 +1,7 @@
# Created by: vanilla@
PORTNAME= caf
-PORTVERSION= 0.18.5
+PORTVERSION= 0.18.6
CATEGORIES= devel
MAINTAINER= ports@FreeBSD.org
diff --git a/devel/caf/distinfo b/devel/caf/distinfo
index 786936c33848..05730652e11f 100644
--- a/devel/caf/distinfo
+++ b/devel/caf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1628143309
-SHA256 (actor-framework-actor-framework-0.18.5_GH0.tar.gz) = 4c96f896f000218bb65890b4d7175451834add73750d5f33b0c7fe82b7d5a679
-SIZE (actor-framework-actor-framework-0.18.5_GH0.tar.gz) = 2827181
+TIMESTAMP = 1648323549
+SHA256 (actor-framework-actor-framework-0.18.6_GH0.tar.gz) = c2ead63a0322d992fea8813a7f7d15b4d16cbb8bbe026722f2616a79109b91cc
+SIZE (actor-framework-actor-framework-0.18.6_GH0.tar.gz) = 2824066
diff --git a/devel/caf/pkg-plist b/devel/caf/pkg-plist
index 13294a56dc60..ef3fb7f728f4 100644
--- a/devel/caf/pkg-plist
+++ b/devel/caf/pkg-plist
@@ -1,6 +1,7 @@
include/caf/abstract_actor.hpp
include/caf/abstract_channel.hpp
include/caf/abstract_group.hpp
+include/caf/action.hpp
include/caf/actor.hpp
include/caf/actor_addr.hpp
include/caf/actor_cast.hpp
@@ -88,8 +89,8 @@ include/caf/detail/consumer.hpp
include/caf/detail/core_export.hpp
include/caf/detail/default_invoke_result_visitor.hpp
include/caf/detail/delegate_serialize.hpp
+include/caf/detail/dispose_on_call.hpp
include/caf/detail/double_ended_queue.hpp
-include/caf/detail/encode_base64.hpp
include/caf/detail/enqueue_result.hpp
include/caf/detail/functor_attachable.hpp
include/caf/detail/gcd.hpp
@@ -167,7 +168,6 @@ include/caf/detail/select_integer_type.hpp
include/caf/detail/serialized_size.hpp
include/caf/detail/set_thread_name.hpp
include/caf/detail/shared_spinlock.hpp
-include/caf/detail/simple_actor_clock.hpp
include/caf/detail/size_based_credit_controller.hpp
include/caf/detail/socket_guard.hpp
include/caf/detail/spawn_fwd.hpp
@@ -200,6 +200,7 @@ include/caf/detail/unordered_flat_map.hpp
include/caf/detail/variant_data.hpp
include/caf/detail/worker_hub.hpp
include/caf/dictionary.hpp
+include/caf/disposable.hpp
include/caf/downstream.hpp
include/caf/downstream_manager.hpp
include/caf/downstream_manager_base.hpp
@@ -342,20 +343,11 @@ include/caf/make_sink_result.hpp
include/caf/make_source_result.hpp
include/caf/make_stage_result.hpp
include/caf/may_have_timeout.hpp
-include/caf/memory_managed.hpp
include/caf/message.hpp
include/caf/message_builder.hpp
include/caf/message_handler.hpp
include/caf/message_id.hpp
include/caf/message_priority.hpp
-include/caf/meta/annotation.hpp
-include/caf/meta/hex_formatted.hpp
-include/caf/meta/load_callback.hpp
-include/caf/meta/omittable.hpp
-include/caf/meta/omittable_if_empty.hpp
-include/caf/meta/omittable_if_none.hpp
-include/caf/meta/save_callback.hpp
-include/caf/meta/type_name.hpp
include/caf/mixin/actor_widget.hpp
include/caf/mixin/behavior_changer.hpp
include/caf/mixin/requester.hpp
@@ -506,6 +498,7 @@ lib/libcaf_openssl.so.%%PORTVERSION%%
%%DATADIR%%/examples/aout.cpp
%%DATADIR%%/examples/broker/simple_broker.cpp
%%DATADIR%%/examples/broker/simple_http_broker.cpp
+%%DATADIR%%/examples/config/read-json.cpp
%%DATADIR%%/examples/custom_type/custom_types_1.cpp
%%DATADIR%%/examples/custom_type/custom_types_2.cpp
%%DATADIR%%/examples/custom_type/custom_types_3.cpp