aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2011-07-07 09:16:40 +0000
committerNicola Vitale <nivit@FreeBSD.org>2011-07-07 09:16:40 +0000
commita0af13d7fde8789c49659f5fd84ab48a8fdcefb8 (patch)
tree7b00565165f1da0afdba230e1424a3bf48258802
parent3303d27313e04233121d834f0d0d2733aa792a41 (diff)
downloadports-a0af13d7fde8789c49659f5fd84ab48a8fdcefb8.tar.gz
ports-a0af13d7fde8789c49659f5fd84ab48a8fdcefb8.zip
- Update to 0.6.16
- Add code to Makefile to support the installation fo py-distribute with different versions of Python - Add files/pkg-message.in - Pass maintainership to python@, in anticipation of a possible use of py-distribute as default (or Python 3k only) tool to install Python eggs (see PR http://goo.gl/0pNai )
Notes
Notes: svn path=/head/; revision=277218
-rw-r--r--devel/py-distribute/Makefile25
-rw-r--r--devel/py-distribute/distinfo4
-rw-r--r--devel/py-distribute/files/pkg-install.in2
-rw-r--r--devel/py-distribute/files/pkg-message.in8
-rw-r--r--devel/py-distribute/pkg-plist2
5 files changed, 31 insertions, 10 deletions
diff --git a/devel/py-distribute/Makefile b/devel/py-distribute/Makefile
index 18833d68fd4d..6c4fa3917b5c 100644
--- a/devel/py-distribute/Makefile
+++ b/devel/py-distribute/Makefile
@@ -6,17 +6,15 @@
#
PORTNAME= distribute
-PORTVERSION= 0.6.15
-PORTREVISION= 1
+PORTVERSION= 0.6.16
+PORTREVISION= 0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= nivit@FreeBSD.org
+MAINTAINER= python@FreeBSD.org
COMMENT= A Python packages installer, and Setuptools replacement
-CONFLICTS= py[2-3][0-9]-setuptools-[0-9]*
-
PLIST_SUB= PYVER=${PYTHON_VER} VERSION=${PORTVERSION} SETUPTOOLS_VER=0.6c11
PYDISTUTILS_NOEGGINFO= yes
@@ -24,7 +22,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
SUB_FILES= pkg-install
-SUB_LIST= EASYINSTALL_PTH=${EASYINSTALL_PTH}
+SUB_LIST= EASYINSTALL_PTH=${EASYINSTALL_PTH} \
+ IF_DEFAULT=${IF_DEFAULT}
EASYINSTALL_PTH= ${PYTHON_SITELIBDIR}/easy-install.pth
SITE_PY= ${PYTHON_SITELIBDIR}/site.py
@@ -45,6 +44,19 @@ PLIST_FILES+= "${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}/${PYCACHE:S,%%PYMOD%%,$
.endfor
.endfor
+.if exists(${LOCALBASE}/bin/easy_install-${PYTHON_VER})
+CONFLICTS= py[2-3][0-9]-setuptools-[0-9]*
+.elif !exists(${LOCALBASE}/bin/easy_install)
+PLIST_SUB+= IF_DEFAULT=""
+.else
+PLIST_SUB+= IF_DEFAULT="@comment "
+SUB_FILES+= pkg-message
+SUB_LIST+= PYVER=${PYTHON_VER}
+# remove the console script easy_install
+post-patch:
+ ${SED} -i.bak -e '/easy_install =/d' ${WRKSRC}/setup.py
+.endif
+
pre-install:
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -54,5 +66,6 @@ post-install:
${PYTHON_CMD} -OO -m py_compile ${SITE_PY}
${CP} ${EASYINSTALL_PTH} ${EASYINSTALL_PTH}.dist
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ if [ -f ${PKGMESSAGE} ]; then ${CAT} ${PKGMESSAGE}; fi
.include <bsd.port.post.mk>
diff --git a/devel/py-distribute/distinfo b/devel/py-distribute/distinfo
index 342a8d0ff008..eb506fa4fb10 100644
--- a/devel/py-distribute/distinfo
+++ b/devel/py-distribute/distinfo
@@ -1,2 +1,2 @@
-SHA256 (distribute-0.6.15.tar.gz) = 5913f99039d78fde1a47057b07c8d3e5ef9ee55ce769b8a1ed8e01e2ff03cb50
-SIZE (distribute-0.6.15.tar.gz) = 289103
+SHA256 (distribute-0.6.16.tar.gz) = 1edb8f34303a9af42db419bc5cfd189572351797d57b62c03e6dc7bf61168b56
+SIZE (distribute-0.6.16.tar.gz) = 288263
diff --git a/devel/py-distribute/files/pkg-install.in b/devel/py-distribute/files/pkg-install.in
index 38e7ce7a351b..292250cd2cb2 100644
--- a/devel/py-distribute/files/pkg-install.in
+++ b/devel/py-distribute/files/pkg-install.in
@@ -1,5 +1,5 @@
+@comment $FreeBSD$
#!/bin/sh
-# $FreeBSD$
EASYINSTALL_PTH=%%EASYINSTALL_PTH%%
diff --git a/devel/py-distribute/files/pkg-message.in b/devel/py-distribute/files/pkg-message.in
new file mode 100644
index 000000000000..01b19c3d445a
--- /dev/null
+++ b/devel/py-distribute/files/pkg-message.in
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+*********************************************************************
+
+ The script %%PREFIX%%/bin/easy_install was already installed
+ on your system, so the only script %%PREFIX%%/bin/easy_install-%%PYVER%%
+ has been added.
+
+*********************************************************************
diff --git a/devel/py-distribute/pkg-plist b/devel/py-distribute/pkg-plist
index 9d7a781ac7e1..4ed1d6d9471d 100644
--- a/devel/py-distribute/pkg-plist
+++ b/devel/py-distribute/pkg-plist
@@ -1,5 +1,5 @@
@comment $FreeBSD$
-bin/easy_install
+%%IF_DEFAULT%%bin/easy_install
bin/easy_install-%%PYVER%%
%%PYTHON_SITELIBDIR%%/distribute-%%VERSION%%-py%%PYVER%%.egg
@unexec if cmp -s %B/easy-install.pth %B/easy-install.pth.dist; then rm %B/easy-install.pth; fi