aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 03:18:38 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 03:22:48 +0000
commita0cd8fe305e3c128e4de1ab570b29ac3f49e2cc6 (patch)
tree604ca800b884c5e27020b2ec5c80bfb2deec0b33
parent5dff756fbe4ed7037a37789040b48553c851001b (diff)
downloadports-a0cd8fe305e3c128e4de1ab570b29ac3f49e2cc6.tar.gz
ports-a0cd8fe305e3c128e4de1ab570b29ac3f49e2cc6.zip
textproc/kibana7: Fix build with abseil 20230125.0+ and re2 20230601+
-rw-r--r--textproc/kibana7/Makefile5
-rw-r--r--textproc/kibana7/files/patch-abseil50
2 files changed, 53 insertions, 2 deletions
diff --git a/textproc/kibana7/Makefile b/textproc/kibana7/Makefile
index ff8e25d75561..70e03c3bb3d0 100644
--- a/textproc/kibana7/Makefile
+++ b/textproc/kibana7/Makefile
@@ -18,13 +18,14 @@ LIB_DEPENDS= libre2.so:devel/re2 \
libuv.so:devel/libuv
RUN_DEPENDS= ${LOCALBASE}/bin/node:www/node16
-USES= compiler:c++14-lang cpe nodejs:16,build,run python:build
+USES= compiler:c++17-lang cpe nodejs:16,build,run python:build
CPE_VENDOR= elastic
USE_GITHUB= nodefault
GH_TUPLE= nodejs:nan:v${_NODE_NAN_VER}:node_nan \
uhop:node-re2:${_NODE_RE2_VER}:node_re2
+USE_CXXSTD= c++17
USE_RC_SUBR= ${PORTNAME}
WWWDIR= ${PREFIX}/www/${PORTNAME}${PKGNAMESUFFIX}
@@ -57,7 +58,7 @@ post-patch:
${FIND} -s ${WRKSRC}/node_modules -type d -empty -delete
cd ${_RE2DIR} && ${PATCH} -p0 < ${_RE2PATCHES}
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
- -e "s|%%DEVDIR%%|${_DEVDIR}|g" ${_RE2DIR}/binding.gyp \
+ -e "s|%%DEVDIR%%|${_DEVDIR}|g" ${_RE2DIR}/binding.gyp
pre-configure:
( \
diff --git a/textproc/kibana7/files/patch-abseil b/textproc/kibana7/files/patch-abseil
new file mode 100644
index 000000000000..e85f151b88cd
--- /dev/null
+++ b/textproc/kibana7/files/patch-abseil
@@ -0,0 +1,50 @@
+--- ../node-re2-1.19.1/binding.gyp.orig 2023-06-16 04:48:53.000000000 +0800
++++ ../node-re2-1.19.1/binding.gyp 2023-09-10 23:36:50.297531000 +0800
+@@ -50,6 +50,9 @@
+ "-O3",
+ "-g"
+ ],
++ "cflags_cc": [
++ "-std=c++17",
++ ],
+ "defines": [
+ "NDEBUG",
+ "NOMINMAX"
+--- ../node-re2-1.19.1/lib/replace.cc.orig 2023-06-16 04:48:53.000000000 +0800
++++ ../node-re2-1.19.1/lib/replace.cc 2023-09-10 21:35:52.639876000 +0800
+@@ -107,7 +107,7 @@
+ i += 2;
+ continue;
+ case '&':
+- result += groups[0].as_string();
++ result += std::string(groups[0]);
+ i += 2;
+ continue;
+ case '`':
+@@ -139,7 +139,7 @@
+ index2 = index * 10 + (ch - '0');
+ if (index2 && index2 < groups.size())
+ {
+- result += groups[index2].as_string();
++ result += std::string(groups[index2]);
+ continue;
+ }
+ result += '$';
+@@ -152,7 +152,7 @@
+ i += 2;
+ if (index && index < groups.size())
+ {
+- result += groups[index].as_string();
++ result += std::string(groups[index]);
+ continue;
+ }
+ result += '$';
+@@ -170,7 +170,7 @@
+ if (group != namedGroups.end())
+ {
+ index = group->second;
+- result += groups[index].as_string();
++ result += std::string(groups[index]);
+ }
+ i = nameEnd + 1 - data;
+ }