aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2023-05-19 15:50:33 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2023-05-19 15:50:33 +0000
commita0ef5898beb4c6a73e9d94aaa452c0eb37cbb14c (patch)
tree6968dab4d28937f0721fc1d05c6e0378fb875bad
parent910c14f7c70d1baba849732ab97e5853c21e46e5 (diff)
downloadports-a0ef5898beb4c6a73e9d94aaa452c0eb37cbb14c.tar.gz
ports-a0ef5898beb4c6a73e9d94aaa452c0eb37cbb14c.zip
emulators/virtualbox-ose[-legacy]: rename option MANUAL to DOCS and make it enabled by default
PR: 266992 Approved by: arrowd (mentor) Differential Revision: https://reviews.freebsd.org/D40118
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile13
-rw-r--r--emulators/virtualbox-ose-legacy/pkg-plist2
-rw-r--r--emulators/virtualbox-ose/Makefile12
-rw-r--r--emulators/virtualbox-ose/pkg-plist2
4 files changed, 14 insertions, 15 deletions
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index fe7e00fe1be7..ef5aa96c2056 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -1,6 +1,6 @@
PORTNAME= virtualbox-ose
PORTVERSION= 5.2.44
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= emulators
MASTER_SITES= https://download.oracle.com/virtualbox/${PORTVERSION}/
PKGNAMESUFFIX?= -legacy
@@ -59,14 +59,13 @@ VBOX_PROGS= VBoxAutostart VBoxBalloonCtrl VBoxBugReport VBoxHeadless \
VBOX_UTILS= VBoxExtPackHelperApp VBoxNetAdpCtl VBoxNetDHCP VBoxNetNAT \
VBoxSVC VBoxXPCOMIPCD
-OPTIONS_DEFINE= ALSA DBUS DEBUG GUESTADDITIONS MANUAL NLS PULSEAUDIO \
+OPTIONS_DEFINE= ALSA DBUS DEBUG DOCS GUESTADDITIONS NLS PULSEAUDIO \
PYTHON QT5 R0LOGGING UDPTUNNEL VDE VNC WEBSERVICE VPX X11
OPTIONS_DEFAULT= DBUS QT5 UDPTUNNEL VNC WEBSERVICE X11
OPTIONS_SUB= yes
DEBUG_DESC= Debug symbols, additional logs and assertions
GUESTADDITIONS_DESC= Build with Guest Additions
-MANUAL_DESC= Build with user manual
NLS_DESC= Native language support (requires QT5)
QT5_DESC= Build with QT5 frontend (requires X11)
R0LOGGING_DESC= Enable R0 logging (requires DEBUG)
@@ -81,8 +80,8 @@ ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
DBUS_CONFIGURE_OFF= --disable-dbus
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DEBUG_CONFIGURE_ON= --build-debug
-MANUAL_BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd:textproc/docbook-xml
-MANUAL_CONFIGURE_OFF= --disable-docs
+DOCS_BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd:textproc/docbook-xml
+DOCS_CONFIGURE_OFF= --disable-docs
NLS_IMPLIES= QT5
PULSEAUDIO_CONFIGURE_OFF= --disable-pulse
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
@@ -139,7 +138,7 @@ LICENSE_PERMS_Additions= auto-accept
LICENSE_DISTFILES_Additions= ${GUESTADDITIONS}
.endif
-.if ${PORT_OPTIONS:MMANUAL}
+.if ${PORT_OPTIONS:MDOCS}
DBKXMLDIR= ${LOCALBASE}/share/xml/docbook/4.4
DBKXSLDIR= ${LOCALBASE}/share/xsl/docbook
USES+= tex
@@ -378,7 +377,7 @@ do-install:
${STAGEDIR}${VBOX_DIR}/additions/VBoxGuestAdditions.iso
.endif
-.if ${PORT_OPTIONS:MMANUAL}
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${KMK_BUILDDIR}/bin/UserManual*.pdf \
${STAGEDIR}${DOCSDIR}
diff --git a/emulators/virtualbox-ose-legacy/pkg-plist b/emulators/virtualbox-ose-legacy/pkg-plist
index 9f2ed04af928..ecaa95f51ab1 100644
--- a/emulators/virtualbox-ose-legacy/pkg-plist
+++ b/emulators/virtualbox-ose-legacy/pkg-plist
@@ -436,7 +436,7 @@ lib/virtualbox/components/VBoxXPCOMBase.xpt
lib/virtualbox/components/VBoxXPCOMIPCC.so
lib/virtualbox/components/VirtualBox_XPCOM.xpt
%%QT%%share/applications/virtualbox.desktop
-%%MANUAL%%%%DOCSDIR%%/UserManual.pdf
+%%DOCS%%%%DOCSDIR%%/UserManual.pdf
%%QT%%share/pixmaps/VBox.png
%%DATADIR%%/idl/VirtualBox_XPCOM.idl
%%DATADIR%%/idl/ipcIClientObserver.idl
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index f6e73b081d09..82c5fc047dd6 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -1,5 +1,6 @@
PORTNAME= virtualbox-ose
PORTVERSION= 6.1.44
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= https://download.virtualbox.org/virtualbox/${PORTVERSION}/
DISTFILES= VirtualBox-${PORTVERSION}${EXTRACT_SUFX} ${GUESTADDITIONS}
@@ -54,7 +55,7 @@ VBOX_UTILS= VBoxExtPackHelperApp VBoxNetAdpCtl VBoxNetDHCP VBoxNetNAT \
SUB_FILES= pkg-message
-OPTIONS_DEFINE= AIO ALSA DBUS DEBUG GUESTADDITIONS MANUAL NLS OPUS PULSEAUDIO \
+OPTIONS_DEFINE= AIO ALSA DBUS DEBUG DOCS GUESTADDITIONS NLS OPUS PULSEAUDIO \
PYTHON QT5 R0LOGGING UDPTUNNEL VDE VNC WEBSERVICE VPX X11
OPTIONS_DEFAULT= AIO DBUS QT5 UDPTUNNEL VNC WEBSERVICE X11
# Since version 6.1.24 pulseaudio is broken at runtime, preventing
@@ -65,7 +66,6 @@ OPTIONS_SUB= yes
AIO_DESC= Enable Asyncronous IO support (check pkg-message)
DEBUG_DESC= Debug symbols, additional logs and assertions
GUESTADDITIONS_DESC= Build with Guest Additions
-MANUAL_DESC= Build with user manual
NLS_DESC= Native language support (requires QT5)
OPUS_DESC= Use libvpx for audio recording (requires VPX)
QT5_DESC= Build with QT5 frontend (requires X11)
@@ -81,8 +81,8 @@ ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
DBUS_CONFIGURE_OFF= --disable-dbus
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DEBUG_CONFIGURE_ON= --build-debug
-MANUAL_BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd:textproc/docbook-xml
-MANUAL_CONFIGURE_OFF= --disable-docs
+DOCS_BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd:textproc/docbook-xml
+DOCS_CONFIGURE_OFF= --disable-docs
NLS_IMPLIES= QT5
OPUS_CONFIGURE_OFF= --disable-libopus
OPUS_LIB_DEPENDS= libopus.so:audio/opus
@@ -143,7 +143,7 @@ LICENSE_PERMS_Additions= auto-accept
LICENSE_DISTFILES_Additions= ${GUESTADDITIONS}
.endif
-.if ${PORT_OPTIONS:MMANUAL}
+.if ${PORT_OPTIONS:MDOCS}
DBKXMLDIR= ${LOCALBASE}/share/xml/docbook/4.4
DBKXSLDIR= ${LOCALBASE}/share/xsl/docbook
USES+= tex
@@ -385,7 +385,7 @@ do-install:
${STAGEDIR}${VBOX_DIR}/additions/VBoxGuestAdditions.iso
.endif
-.if ${PORT_OPTIONS:MMANUAL}
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${KMK_BUILDDIR}/bin/UserManual*.pdf \
${STAGEDIR}${DOCSDIR}
diff --git a/emulators/virtualbox-ose/pkg-plist b/emulators/virtualbox-ose/pkg-plist
index b3058f23ff9e..5a71bfe95aa0 100644
--- a/emulators/virtualbox-ose/pkg-plist
+++ b/emulators/virtualbox-ose/pkg-plist
@@ -438,7 +438,7 @@ lib/virtualbox/components/VBoxXPCOMBase.xpt
lib/virtualbox/components/VBoxXPCOMIPCC.so
lib/virtualbox/components/VirtualBox_XPCOM.xpt
%%QT%%share/applications/virtualbox.desktop
-%%MANUAL%%%%DOCSDIR%%/UserManual.pdf
+%%DOCS%%%%DOCSDIR%%/UserManual.pdf
%%QT%%share/pixmaps/VBox.png
%%DATADIR%%/idl/VirtualBox_XPCOM.idl
%%DATADIR%%/idl/ipcIClientObserver.idl