aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2024-01-06 18:22:13 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2024-01-06 18:22:13 +0000
commita157ce5f55c445c891b640e4179d609c8bb84ea2 (patch)
treed59548a6bea6bb21fcaa369b9997f3523865c8ec
parentbf1a1bec3c18eaae2c54ec86570b9fe62b7a0aa8 (diff)
downloadports-a157ce5f55c445c891b640e4179d609c8bb84ea2.tar.gz
ports-a157ce5f55c445c891b640e4179d609c8bb84ea2.zip
www/nginx-devel: third-party modules management (+)
o) update third-party lua module to 0.10.26; o) update third-party headers-more module to latest snapshot; o) remove third-party http_mp4_h264 module, legacy and undownloadable. Bump PORTREVISION.
-rw-r--r--www/nginx-devel/Makefile2
-rw-r--r--www/nginx-devel/Makefile.extmod13
-rw-r--r--www/nginx-devel/Makefile.options.desc1
-rw-r--r--www/nginx-devel/distinfo12
-rw-r--r--www/nginx-devel/files/extra-patch-nginx_mod_h264_streaming-config41
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_streaming_module.c13
-rw-r--r--www/nginx-devel/pkg-plist1
7 files changed, 9 insertions, 74 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 645d9f3af748..d207232c7e54 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME?= nginx
PORTVERSION= 1.25.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
diff --git a/www/nginx-devel/Makefile.extmod b/www/nginx-devel/Makefile.extmod
index 022f17b30262..9577581996c2 100644
--- a/www/nginx-devel/Makefile.extmod
+++ b/www/nginx-devel/Makefile.extmod
@@ -7,7 +7,7 @@ OPTIONS_GROUP_THIRDPARTYGRP= AJP AWS_AUTH BROTLI CACHE_PURGE CT \
FIPS_CHECK FORMINPUT GRIDFS HEADERS_MORE HTTP_ACCEPT_LANGUAGE HTTP_AUTH_DIGEST \
HTTP_AUTH_KRB5 HTTP_AUTH_LDAP HTTP_AUTH_PAM HTTP_DAV_EXT HTTP_EVAL \
HTTP_FANCYINDEX HTTP_FOOTER HTTP_GEOIP2 HTTP_IP2LOCATION HTTP_IP2PROXY \
- HTTP_JSON_STATUS HTTP_MOGILEFS HTTP_MP4_H264 HTTP_NOTICE HTTP_PUSH \
+ HTTP_JSON_STATUS HTTP_MOGILEFS HTTP_NOTICE HTTP_PUSH \
HTTP_PUSH_STREAM HTTP_REDIS HTTP_SLICE_AHEAD HTTP_SUBS_FILTER HTTP_TARANTOOL \
HTTP_UPLOAD HTTP_UPLOAD_PROGRESS HTTP_UPSTREAM_CHECK HTTP_UPSTREAM_FAIR \
HTTP_UPSTREAM_STICKY HTTP_VIDEO_THUMBEXTRACTOR HTTP_ZIP ICONV LET LINK LUA MEMC \
@@ -71,7 +71,7 @@ GRIDFS_LIB_DEPENDS= libbson-1.0.so:devel/libbson \
libmongoc-1.0.so:devel/mongo-c-driver
GRIDFS_VARS= DSO_EXTMODS+=gridfs GRIDFS_SUBDIR=/nginx-gridfs
-HEADERS_MORE_GH_TUPLE= openresty:headers-more-nginx-module:3fb97bc:headers_more
+HEADERS_MORE_GH_TUPLE= openresty:headers-more-nginx-module:06dc0be:headers_more
HEADERS_MORE_VARS= DSO_EXTMODS+=headers_more
HTTP_ACCEPT_LANGUAGE_GH_TUPLE= dvershinin:nginx_accept_language_module:5683967:accept_language
@@ -132,13 +132,6 @@ HTTP_MOGILEFS_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ngx_http_mogilefs_module.c
${PATCHDIR}/extra-patch-nginx_mogilefs_module-config
HTTP_MOGILEFS_VARS= DSO_EXTDIRS+=nginx_mogilefs_module-1.0.4
-HTTP_MP4_H264_MASTER_SITES= http://h264.code-shop.com/download/:mp4streaming
-HTTP_MP4_H264_CONFIGURE_ON= --with-cc-opt="-DLARGEFILE_SOURCE -DBUILDING_NGINX"
-HTTP_MP4_H264_DISTFILES= nginx_mod_h264_streaming-2.2.7.tar.gz:mp4streaming
-HTTP_MP4_H264_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ngx_http_streaming_module.c \
- ${PATCHDIR}/extra-patch-nginx_mod_h264_streaming-config
-HTTP_MP4_H264_VARS= DSO_EXTDIRS+=nginx_mod_h264_streaming-2.2.7
-
HTTP_NOTICE_GH_TUPLE= kr:nginx-notice:3c95966:notice
HTTP_NOTICE_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ngx_http_notice_module.c \
${PATCHDIR}/extra-patch-nginx-notice-config
@@ -213,7 +206,7 @@ LUA_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
LUA_RUN_DEPENDS= lua-resty-core>0:www/lua-resty-core
LUA_CONFIGURE_ENV= LUAJIT_INC=${LOCALBASE}/include/luajit-2.1 \
LUAJIT_LIB=${LOCALBASE}/lib
-LUA_GH_TUPLE= openresty:lua-nginx-module:v0.10.26rc2:lua
+LUA_GH_TUPLE= openresty:lua-nginx-module:v0.10.26:lua
LUA_VARS= DSO_EXTMODS+=lua
LINK_GH_TUPLE= Taymindis:nginx-link-function:3.2.4:link
diff --git a/www/nginx-devel/Makefile.options.desc b/www/nginx-devel/Makefile.options.desc
index d79433a2ebf7..dd7ef896ef34 100644
--- a/www/nginx-devel/Makefile.options.desc
+++ b/www/nginx-devel/Makefile.options.desc
@@ -49,7 +49,6 @@ HTTP_IP2PROXY_DESC= 3rd party ip2proxy-nginx module
HTTP_JSON_STATUS_DESC= 3rd party http_json_status module
HTTP_MOGILEFS_DESC= 3rd party mogilefs module
HTTP_MP4_DESC= Enable http_mp4 module
-HTTP_MP4_H264_DESC= 3rd party mp4/h264 module
HTTP_NOTICE_DESC= 3rd party notice module
HTTP_PERL_DESC= Enable http_perl module
HTTP_PUSH_DESC= 3rd party push module
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index a2093c2b81d7..f4eb236072de 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,10 +1,8 @@
-TIMESTAMP = 1704150548
+TIMESTAMP = 1704564967
SHA256 (nginx-1.25.3.tar.gz) = 64c5b975ca287939e828303fa857d22f142b251f17808dfe41733512d9cded86
SIZE (nginx-1.25.3.tar.gz) = 1216580
SHA256 (nginx_mogilefs_module-1.0.4.tar.gz) = 7ac230d30907f013dff8d435a118619ea6168aa3714dba62c6962d350c6295ae
SIZE (nginx_mogilefs_module-1.0.4.tar.gz) = 11208
-SHA256 (nginx_mod_h264_streaming-2.2.7.tar.gz) = 6d974ba630cef59de1f60996c66b401264a345d25988a76037c2856cec756c19
-SIZE (nginx_mod_h264_streaming-2.2.7.tar.gz) = 44012
SHA256 (ngx_http_redis-0.3.9.tar.gz) = 21f87540f0a44b23ffa5df16fb3d788bc90803b255ef14f9c26e3847a6f26f46
SIZE (ngx_http_redis-0.3.9.tar.gz) = 13051
SHA256 (passenger-6.0.19.tar.gz) = 70eee7fecb8a6197517db3b6d134a839768a5388d5d08343e9e020910769b392
@@ -37,8 +35,8 @@ SHA256 (ogarrett-nginx-fips-check-module-6cb4270_GH0.tar.gz) = d52fbb0f2819cd91b
SIZE (ogarrett-nginx-fips-check-module-6cb4270_GH0.tar.gz) = 6494
SHA256 (nieoding-nginx-gridfs-059bdc3_GH0.tar.gz) = 9b059b5ae7b602d12d32d5ebe2700827ea625f22c0fb3b9956242e11de63845b
SIZE (nieoding-nginx-gridfs-059bdc3_GH0.tar.gz) = 4674
-SHA256 (openresty-headers-more-nginx-module-3fb97bc_GH0.tar.gz) = 62a0b84c86908b56fd37af79b440e70ae5b2a460d1dae5d7fabc3996c656ea5b
-SIZE (openresty-headers-more-nginx-module-3fb97bc_GH0.tar.gz) = 29426
+SHA256 (openresty-headers-more-nginx-module-06dc0be_GH0.tar.gz) = 883b1e31d59f3eb1e76b34259711ad65a3443102973dcf22df329397f3d5eaa4
+SIZE (openresty-headers-more-nginx-module-06dc0be_GH0.tar.gz) = 29438
SHA256 (dvershinin-nginx_accept_language_module-5683967_GH0.tar.gz) = a58feb576f2231498b8a3863d3c6fba45c7d48bc48735fa714e07a7bfbedb6e3
SIZE (dvershinin-nginx_accept_language_module-5683967_GH0.tar.gz) = 3425
SHA256 (atomx-nginx-http-auth-digest-274490c_GH0.tar.gz) = 0839c33c2f8d519f92daae274f62cf87eb68415d562c6500ee3e3721ce80557c
@@ -95,8 +93,8 @@ SHA256 (baysao-nginx-let-module-c1f23aa_GH0.tar.gz) = 7393809d5d8877812da1bd5b5f
SIZE (baysao-nginx-let-module-c1f23aa_GH0.tar.gz) = 20617
SHA256 (Taymindis-nginx-link-function-3.2.4_GH0.tar.gz) = 20c3679199ba7efe1598f03b2fa0b13591226363c8dd7930d7f02702cd5abada
SIZE (Taymindis-nginx-link-function-3.2.4_GH0.tar.gz) = 139656
-SHA256 (openresty-lua-nginx-module-v0.10.26rc2_GH0.tar.gz) = 3798109d047c917d564831051e31c0baac94ac6be379809df7d609505f0c302e
-SIZE (openresty-lua-nginx-module-v0.10.26rc2_GH0.tar.gz) = 745839
+SHA256 (openresty-lua-nginx-module-v0.10.26_GH0.tar.gz) = a75983287a2bdc5e964ace56a51b215dc2ec996639d4916cd393d6ebba94b565
+SIZE (openresty-lua-nginx-module-v0.10.26_GH0.tar.gz) = 745785
SHA256 (openresty-memc-nginx-module-v0.19_GH0.tar.gz) = 8c2bdbe875e4f5225d0778bfb09a2668f9281d7de6218c7b462a7ba2cee06fe8
SIZE (openresty-memc-nginx-module-v0.19_GH0.tar.gz) = 34654
SHA256 (SpiderLabs-ModSecurity-nginx-v1.0.3_GH0.tar.gz) = 32a42256616cc674dca24c8654397390adff15b888b77eb74e0687f023c8751b
diff --git a/www/nginx-devel/files/extra-patch-nginx_mod_h264_streaming-config b/www/nginx-devel/files/extra-patch-nginx_mod_h264_streaming-config
deleted file mode 100644
index 1acd8cd12405..000000000000
--- a/www/nginx-devel/files/extra-patch-nginx_mod_h264_streaming-config
+++ /dev/null
@@ -1,41 +0,0 @@
---- ../nginx_mod_h264_streaming-2.2.7/config.orig 2020-04-27 12:01:37.153986000 -0400
-+++ ../nginx_mod_h264_streaming-2.2.7/config 2020-04-27 12:16:52.832788000 -0400
-@@ -1,26 +1,19 @@
- ngx_addon_name=ngx_http_h264_streaming_module
--HTTP_AUX_FILTER_MODULES="$HTTP_AUX_FILTER_MODULES ngx_http_h264_streaming_module"
--CFLAGS="$CFLAGS -D_LARGEFILE_SOURCE -DBUILDING_NGINX"
--
--H264_STREAMING_MODULE_SOURCES="$ngx_addon_dir/src/ngx_http_h264_streaming_module.c \
-+ngx_module_name="$ngx_addon_name"
-+ngx_module_type=HTTP_AUX_FILTER
-+ngx_module_srcs="$ngx_addon_dir/src/ngx_http_h264_streaming_module.c \
- $ngx_addon_dir/src/moov.c \
- $ngx_addon_dir/src/mp4_io.c \
- $ngx_addon_dir/src/mp4_reader.c \
- $ngx_addon_dir/src/mp4_writer.c \
- $ngx_addon_dir/src/output_bucket.c \
- $ngx_addon_dir/src/output_mp4.c"
--
--for streaming_module_source in $H264_STREAMING_MODULE_SOURCES
--do
-- already_included=NO
-- for ngx_addon_src in $NGX_ADDON_SRCS
-- do
-- if [ "`basename $ngx_addon_src`" = "`basename $streaming_module_source`" ]; then
-- already_included=YES
-- break
-- fi
-- done
-- if [ "$already_included" = "NO" ]; then
-- NGX_ADDON_SRCS="$NGX_ADDON_SRCS $streaming_module_source"
-- fi
--done
-+ngx_module_deps="$ngx_addon_dir/src/mod_streaming_export.h \
-+ $ngx_addon_dir/src/moov.h \
-+ $ngx_addon_dir/src/mp4_io.h \
-+ $ngx_addon_dir/src/mp4_process.h \
-+ $ngx_addon_dir/src/mp4_reader.h \
-+ $ngx_addon_dir/src/mp4_writer.h \
-+ $ngx_addon_dir/src/output_bucket.h \
-+ $ngx_addon_dir/src/output_mp4.h"
-+. auto/module
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_streaming_module.c b/www/nginx-devel/files/extra-patch-ngx_http_streaming_module.c
deleted file mode 100644
index 3641090a9b5d..000000000000
--- a/www/nginx-devel/files/extra-patch-ngx_http_streaming_module.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ../nginx_mod_h264_streaming-2.2.7/src/ngx_http_streaming_module.c.orig 2010-05-24 18:04:43.000000000 +0400
-+++ ../nginx_mod_h264_streaming-2.2.7/src/ngx_http_streaming_module.c 2010-05-24 18:05:02.000000000 +0400
-@@ -155,10 +155,6 @@
- }
-
- /* TODO: Win32 */
-- if (r->zero_in_uri)
-- {
-- return NGX_DECLINED;
-- }
-
- rc = ngx_http_discard_request_body(r);
-
diff --git a/www/nginx-devel/pkg-plist b/www/nginx-devel/pkg-plist
index c81e6d434f59..4eab2d359735 100644
--- a/www/nginx-devel/pkg-plist
+++ b/www/nginx-devel/pkg-plist
@@ -39,7 +39,6 @@
%%DSO%%%%HTTP_IP2PROXY%%libexec/nginx/ngx_http_ip2proxy_module.so
%%DSO%%%%HTTP_JSON_STATUS%%libexec/nginx/ngx_http_json_status_module.so
%%DSO%%%%HTTP_MOGILEFS%%libexec/nginx/ngx_http_mogilefs_module.so
-%%DSO%%%%HTTP_MP4_H264%%libexec/nginx/ngx_http_h264_streaming_module.so
%%DSO%%%%HTTP_NOTICE%%libexec/nginx/ngx_http_notice_module.so
%%DSO%%%%HTTP_PERL%%libexec/nginx/ngx_http_perl_module.so
%%DSO%%%%HTTP_PUSH_STREAM%%libexec/nginx/ngx_http_push_stream_module.so