aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJamie Landeg-Jones <jamie@catflap.org>2024-02-11 08:52:34 +0000
committerKurt Jaeger <pi@FreeBSD.org>2024-02-11 08:52:34 +0000
commita23e25b398606f60cb186c1c0b01c7eac2c6c85b (patch)
treeca6a6622552848e5c1b43c4734e62b7922a971a5
parenteb945d132884da60e7a1ceb75040404a3cda1bfd (diff)
downloadports-a23e25b398606f60cb186c1c0b01c7eac2c6c85b.tar.gz
ports-a23e25b398606f60cb186c1c0b01c7eac2c6c85b.zip
security/sslscan: update 2.0.16 -> 2.1.3
- Now uses openssl 3.2.1 PR: 275254 Approved by: gavin (maintainer timeout) Author: Jamie Landeg-Jones <jamie@catflap.org>
-rw-r--r--security/sslscan/Makefile4
-rw-r--r--security/sslscan/distinfo10
-rw-r--r--security/sslscan/files/patch-Makefile26
3 files changed, 21 insertions, 19 deletions
diff --git a/security/sslscan/Makefile b/security/sslscan/Makefile
index 18733a257fa6..c3a93286e713 100644
--- a/security/sslscan/Makefile
+++ b/security/sslscan/Makefile
@@ -1,5 +1,5 @@
PORTNAME= sslscan
-DISTVERSION= 2.0.16
+DISTVERSION= 2.1.3
CATEGORIES= security
MASTER_SITES= https://www.openssl.org/source/:openssl \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/:openssl
@@ -15,7 +15,7 @@ USES= gmake perl5
USE_PERL5= build
USE_GITHUB= yes
GH_ACCOUNT= rbsec
-OPENSSL_VERSION= 3.1.0
+OPENSSL_VERSION= 3.2.1
ALL_TARGET= static
diff --git a/security/sslscan/distinfo b/security/sslscan/distinfo
index 5cc7753c42a2..dbcfa5fa418a 100644
--- a/security/sslscan/distinfo
+++ b/security/sslscan/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1683839135
-SHA256 (openssl-3.1.0.tar.gz) = aaa925ad9828745c4cad9d9efeb273deca820f2cdcf2c3ac7d7c1212b7c497b4
-SIZE (openssl-3.1.0.tar.gz) = 15525381
-SHA256 (rbsec-sslscan-2.0.16_GH0.tar.gz) = eae49b9c2023f9c9adeb10c50a6ee3ddf5da7aae20f6a6c59251e7a84aa44131
-SIZE (rbsec-sslscan-2.0.16_GH0.tar.gz) = 113523
+TIMESTAMP = 1707630173
+SHA256 (openssl-3.2.1.tar.gz) = 83c7329fe52c850677d75e5d0b0ca245309b97e8ecbcfdc1dfdc4ab9fac35b39
+SIZE (openssl-3.2.1.tar.gz) = 17733249
+SHA256 (rbsec-sslscan-2.1.3_GH0.tar.gz) = 6beec9345635b41fa2c1bbc5f0854f10014e4b2b4179e9e9a3bda6bdb9e1aa41
+SIZE (rbsec-sslscan-2.1.3_GH0.tar.gz) = 113917
diff --git a/security/sslscan/files/patch-Makefile b/security/sslscan/files/patch-Makefile
index bba98af1b52f..8319713a5c77 100644
--- a/security/sslscan/files/patch-Makefile
+++ b/security/sslscan/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2023-04-08 21:36:58 UTC
-+++ Makefile
+--- Makefile.orig 2023-11-14 21:36:52.000000000 +0000
++++ Makefile 2023-11-20 13:57:16.349229000 +0000
@@ -1,12 +1,7 @@
# set gcc as default if CC is not set
@@ -14,7 +14,7 @@
# Detect OS
OS := $(shell uname)
ARCH := $(shell uname -m)
-@@ -26,11 +21,11 @@ endif
+@@ -26,11 +21,11 @@
SRCS = sslscan.c
BINDIR = $(PREFIX)/bin
@@ -28,7 +28,7 @@
# for dynamic linking
LIBS = -lssl -lcrypto
-@@ -58,36 +53,12 @@ endif
+@@ -58,38 +53,12 @@
CFLAGS += -std=gnu11
# for static linking
@@ -61,12 +61,14 @@
-ifneq (,$(wildcard /usr/bin/nproc))
- NUM_PROCS = `/usr/bin/nproc --all`
-endif
--
+-ifeq ($(OS), Darwin)
+- NUM_PROCS = `sysctl -n hw.ncpu`
+-endif
-
.PHONY: all sslscan clean install uninstall static opensslpull
all: sslscan
-@@ -114,6 +85,9 @@ ifeq ($(OS), Darwin)
+@@ -116,6 +85,9 @@
install sslscan $(DESTDIR)$(BINDIR)/sslscan;
install -d $(DESTDIR)$(MAN1DIR)/;
install sslscan.1 $(DESTDIR)$(MAN1DIR)/sslscan.1;
@@ -76,20 +78,20 @@
else
install -D sslscan $(DESTDIR)$(BINDIR)/sslscan;
install -D sslscan.1 $(DESTDIR)$(MAN1DIR)/sslscan.1;
-@@ -126,11 +100,7 @@ uninstall:
+@@ -128,11 +100,7 @@
.openssl.is.fresh: opensslpull
true
opensslpull:
- if [ -d openssl -a -d openssl/.git ]; then \
-- cd ./openssl && git checkout OpenSSL_1_1_1-stable && git pull | grep -q "Already up-to-date." && [ -e ../.openssl.is.fresh ] || touch ../.openssl.is.fresh ; \
+- cd ./openssl && git checkout `git ls-remote https://github.com/openssl/openssl | grep -Eo '(openssl-3\.0\.[0-9]+)' | sort --version-sort | tail -n 1` && git pull | grep -q "Already up-to-date." && [ -e ../.openssl.is.fresh ] || touch ../.openssl.is.fresh ; \
- else \
-- git clone --depth 1 -b OpenSSL_1_1_1-stable https://github.com/openssl/openssl ./openssl && cd ./openssl && touch ../.openssl.is.fresh ; \
+- git clone --depth 1 -b `git ls-remote https://github.com/openssl/openssl | grep -Eo '(openssl-3\.0\.[0-9]+)' | sort -V | tail -n 1` https://github.com/openssl/openssl ./openssl && cd ./openssl && touch ../.openssl.is.fresh ; \
- fi
+ true
# Need to build OpenSSL differently on OSX
ifeq ($(OS), Darwin)
-@@ -144,16 +114,15 @@ openssl/Makefile: .openssl.is.fresh
+@@ -146,16 +114,15 @@
# Any other *NIX platform
else
openssl/Makefile: .openssl.is.fresh
@@ -99,10 +101,10 @@
openssl/libcrypto.a: openssl/Makefile
- $(MAKE) -j $(NUM_PROCS) -C openssl depend
-- $(MAKE) -j $(NUM_PROCS) -C openssl all
+- $(MAKE) -j $(NUM_PROCS) -C openssl build_libs
-# $(MAKE) -j $(NUM_PROCS) -C openssl test # Disabled because this takes 45+ minutes for OpenSSL v1.1.1.
+ $(MAKE) -C openssl depend
-+ $(MAKE) -C openssl build_sw
++ $(MAKE) -C openssl build_libs
static: openssl/libcrypto.a
- $(MAKE) -j $(NUM_PROCS) sslscan STATIC_BUILD=TRUE