aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-30 21:34:17 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-30 21:36:00 +0000
commita2582ff0623ba75d40846c44b6d830bc1ca40391 (patch)
tree04ff522aaa985c6f9065c032f46a7e10f4fecdab
parent52306be2973467a9d46978ae902529e13e1f49f7 (diff)
downloadports-a2582ff0623ba75d40846c44b6d830bc1ca40391.tar.gz
ports-a2582ff0623ba75d40846c44b6d830bc1ca40391.zip
devel/libdatovka: New port
This is client library for accessing SOAP services of ISDS (Data Box Information System) as defined in Czech ISDS Act (300/2008 Coll.) https://gitlab.nic.cz/datovka/libdatovka PR: 267573 Reported by: freebsd@sysctl.cz
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libdatovka/Makefile39
-rw-r--r--devel/libdatovka/distinfo3
-rw-r--r--devel/libdatovka/pkg-descr2
-rw-r--r--devel/libdatovka/pkg-plist9
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 74e485858fc8..1069553aa63b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1180,6 +1180,7 @@
SUBDIR += libdaemon
SUBDIR += libdap
SUBDIR += libdatadog
+ SUBDIR += libdatovka
SUBDIR += libdatrie
SUBDIR += libdbusmenu
SUBDIR += libdbusmenu-qt
diff --git a/devel/libdatovka/Makefile b/devel/libdatovka/Makefile
new file mode 100644
index 000000000000..152884f96a6a
--- /dev/null
+++ b/devel/libdatovka/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= libdatovka
+DISTVERSION= 0.3.0
+CATEGORIES= devel
+MASTER_SITES= https://secure.nic.cz/files/datove_schranky/libdatovka/
+
+MAINTAINER= freebsd@sysctl.cz
+COMMENT= ISDS client library
+WWW= https://gitlab.nic.cz/datovka/libdatovka
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= docbook-xsl>0:textproc/docbook-xsl \
+ expat>0:textproc/expat2 \
+ gpgme>0:security/gpgme \
+ libgcrypt>0:security/libgcrypt \
+ libiconv>0:converters/libiconv \
+ pkgconf:devel/pkgconf \
+ xsltproc:textproc/libxslt
+LIB_DEPENDS+= libassuan.so:security/libassuan \
+ libcurl.so:ftp/curl \
+ libexpat.so:textproc/expat2 \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error \
+ libgpgme.so:security/gpgme \
+ libxml2.so:textproc/libxml2
+
+USES= autoreconf gettext gmake gnome libtool localbase ssl tar:xz
+USE_GNOME= libxml2 libxslt
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --disable-fatalwarnings \
+ --enable-openssl-backend \
+ --with-docbook-xsl-stylesheets=${LOCALBASE}/share/xsl/docbook
+
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/devel/libdatovka/distinfo b/devel/libdatovka/distinfo
new file mode 100644
index 000000000000..882f081e8363
--- /dev/null
+++ b/devel/libdatovka/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1676041947
+SHA256 (libdatovka-0.3.0.tar.xz) = c69905a1be69774a6956a8145c1631d453de162caaef1769c692501c2340261b
+SIZE (libdatovka-0.3.0.tar.xz) = 689000
diff --git a/devel/libdatovka/pkg-descr b/devel/libdatovka/pkg-descr
new file mode 100644
index 000000000000..84a262047074
--- /dev/null
+++ b/devel/libdatovka/pkg-descr
@@ -0,0 +1,2 @@
+This is client library for accessing SOAP services of ISDS (Data Box Information
+System) as defined in Czech ISDS Act (300/2008 Coll.)
diff --git a/devel/libdatovka/pkg-plist b/devel/libdatovka/pkg-plist
new file mode 100644
index 000000000000..9ea4d4208312
--- /dev/null
+++ b/devel/libdatovka/pkg-plist
@@ -0,0 +1,9 @@
+include/libdatovka/isds.h
+lib/libdatovka.a
+lib/libdatovka.so
+lib/libdatovka.so.4
+lib/libdatovka.so.4.0.0
+libdata/pkgconfig/libdatovka.pc
+man/man3/isds.h.libdatovka.3.gz
+man/man3/libdatovka.3.gz
+share/locale/cs/LC_MESSAGES/libdatovka.mo