aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:10:25 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:10:25 +0000
commita2740617001e81cfd4d231f1758ad7b8b860a76f (patch)
treeaff19d607a0c402a02a2dd2068fc9dbc254bd233
parent32515454502ca7fd7e09c3549228a0b624ab4e21 (diff)
downloadports-a2740617001e81cfd4d231f1758ad7b8b860a76f.tar.gz
ports-a2740617001e81cfd4d231f1758ad7b8b860a76f.zip
devel/py-py-serializable: Add py-py-serializable 0.11.1
This Pythonic library provides a framework for serializing/deserializing Python classes to and from JSON and XML. It relies upon the use of Python Properties in your Python classes.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-py-serializable/Makefile22
-rw-r--r--devel/py-py-serializable/distinfo3
-rw-r--r--devel/py-py-serializable/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ee36776a85ee..711b97f989e9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5204,6 +5204,7 @@
SUBDIR += py-purl
SUBDIR += py-py
SUBDIR += py-py-partiql-parser
+ SUBDIR += py-py-serializable
SUBDIR += py-py-ubjson
SUBDIR += py-py3nvml
SUBDIR += py-pyTooling
diff --git a/devel/py-py-serializable/Makefile b/devel/py-py-serializable/Makefile
new file mode 100644
index 000000000000..3c3675560daf
--- /dev/null
+++ b/devel/py-py-serializable/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= py-serializable
+PORTVERSION= 0.11.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Library for serializing and deserializing Python Objects to and from JSON and XML
+WWW= https://github.com/madpah/serializable
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}defusedxml>=0.7.1<0.8:devel/py-defusedxml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-py-serializable/distinfo b/devel/py-py-serializable/distinfo
new file mode 100644
index 000000000000..b4c7f266addf
--- /dev/null
+++ b/devel/py-py-serializable/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688166014
+SHA256 (py-serializable-0.11.1.tar.gz) = ba0e1287b9e4f645a5334f1913abd8e647e7250209f84f55dce3909498a6f586
+SIZE (py-serializable-0.11.1.tar.gz) = 18531
diff --git a/devel/py-py-serializable/pkg-descr b/devel/py-py-serializable/pkg-descr
new file mode 100644
index 000000000000..cae3b6ad2dfc
--- /dev/null
+++ b/devel/py-py-serializable/pkg-descr
@@ -0,0 +1,4 @@
+This Pythonic library provides a framework for serializing/deserializing Python
+classes to and from JSON and XML.
+
+It relies upon the use of Python Properties in your Python classes.