aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 14:04:01 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 14:46:35 +0000
commita2c48babbb8e61650609e6a63a0a09c89ba1b745 (patch)
treed1b6d501fe592fde05662eac2e6bf2a684905d18
parent070863350c0b75779f8664164596888f3ba5f951 (diff)
downloadports-a2c48babbb8e61650609e6a63a0a09c89ba1b745.tar.gz
ports-a2c48babbb8e61650609e6a63a0a09c89ba1b745.zip
net/trickle: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--net/trickle/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/trickle/Makefile b/net/trickle/Makefile
index 8f9dbfab2b39..a6747b5e8982 100644
--- a/net/trickle/Makefile
+++ b/net/trickle/Makefile
@@ -14,10 +14,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libevent.so:devel/libevent
USES= libtool localbase
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libevent=${LOCALBASE} \
--sysconfdir=${PREFIX}/etc
-USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
@@ -25,6 +26,11 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/trickle/trickle-overload.so
${INSTALL_DATA} ${FILESDIR}/trickled.conf ${STAGEDIR}${PREFIX}/etc/trickled.conf.sample