aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-18 04:02:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-18 04:06:08 +0000
commita2c5d69385fe0d8c5a666d570f5b464ca302d37d (patch)
tree7b4b6fa35dbe9f08c7f28e6e2aa0d58d6abf77f1
parent52c6d02708d05e3c2c917ff36e5678fa724372e7 (diff)
downloadports-a2c5d69385fe0d8c5a666d570f5b464ca302d37d.tar.gz
ports-a2c5d69385fe0d8c5a666d570f5b464ca302d37d.zip
audio/audacity: Update 2.4.2 -> 3.0.0
I also changed the default of LADSPA to OFF and LV2 to ON because LV2 is a new generation of LADSPA. PR: 254598 Submitted by: xxjack12xx@gmail.com (maintainer)
-rw-r--r--audio/audacity/Makefile26
-rw-r--r--audio/audacity/distinfo6
-rw-r--r--audio/audacity/files/patch-cmake-proxies_CMakeLists.txt4
-rw-r--r--audio/audacity/files/patch-cmake-proxies_wxWidgets_CMakeLists.txt20
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h2
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqstk_include_FileRead.h10
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlfio.c12
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h6
-rw-r--r--audio/audacity/files/patch-lib-src_portsmf_allegro.h10
-rw-r--r--audio/audacity/files/patch-src_AudioIO.cpp4
-rw-r--r--audio/audacity/files/patch-src_FFmpeg.h29
-rw-r--r--audio/audacity/files/patch-src_ProjectSerializer.cpp60
-rw-r--r--audio/audacity/files/patch-src_import_Import.cpp16
-rw-r--r--audio/audacity/files/patch-src_widgets_FileConfig.cpp11
-rw-r--r--audio/audacity/files/patch-src_widgets_Grid.cpp11
-rw-r--r--audio/audacity/pkg-plist5
16 files changed, 157 insertions, 75 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 75b96d11bef2..a860326b2886 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -1,10 +1,10 @@
# Created by: Marc van Woerkom <3d@FreeBSD.org>
PORTNAME= audacity
-PORTVERSION= 2.4.2
-PORTREVISION= 4
-DISTVERSIONPREFIX= Audacity-
+DISTVERSIONPREFIX= minsrc-
+DISTVERSION= 3.0.0
CATEGORIES= audio
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/Audacity-${PORTVERSION}/
MAINTAINER= xxjack12xx@gmail.com
COMMENT= GUI editor for digital audio waveforms
@@ -16,11 +16,11 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libexpat.so:textproc/expat2 \
libportaudio.so:audio/portaudio \
libsndfile.so:audio/libsndfile \
- libsoxr.so:audio/libsoxr
+ libsoxr.so:audio/libsoxr \
+ libsqlite3.so:databases/sqlite3
-USES= cmake compiler:c++11-lang cpe desktop-file-utils gettext \
- gnome libtool python:build pkgconfig shared-mime-info
-USE_GITHUB= yes
+USES= cmake compiler:c++14-lang cpe desktop-file-utils gettext \
+ gnome libtool python:build pkgconfig shared-mime-info tar:xz
USE_GNOME= cairo gtk30
USE_WX= 3.1+
WX_COMPS= wx
@@ -40,7 +40,7 @@ CMAKE_OFF= audacity_use_pch
OPTIONS_DEFINE= DEBUG DOCS FFMPEG FLAC ID3TAG LADSPA LAME LV2 MAD \
MIDI OGG SBSMS SOUNDTOUCH TWOLAME VAMP \
VORBIS VST
-OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD MIDI OGG SBSMS \
+OPTIONS_DEFAULT= FLAC ID3TAG LV2 MAD MIDI OGG SBSMS \
SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_EXCLUDE_i386= SBSMS
@@ -134,13 +134,13 @@ CMAKE_ARGS+= -DHAVE_MMX:BOOL=OFF \
-DHAVE_SSE2:BOOL=OFF
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's,Python2,Python${PYTHON_MAJOR_VER}, ; \
- /CMAKE_CXX_STANDARD/s,14,11,' ${WRKSRC}/CMakeLists.txt
-
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @cd ${STAGEDIR}${PREFIX} && ${STRIP_CMD} \
+ bin/${PORTNAME} \
+ share/audacity/modules/mod-script-pipe.so
@${RM} ${STAGEDIR}${DOCSDIR}/LICENSE.txt
+ # delete empty directories: https://github.com/audacity/audacity/issues/808
+ @${FIND} ${STAGEDIR} -type d -empty -delete
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index f0de0d092a4f..4b53733c5ba4 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1593304211
-SHA256 (audacity-audacity-Audacity-2.4.2_GH0.tar.gz) = cdb4800c8e9d1d4ca19964caf8d24000f80286ebd8a4db566c2622449744c099
-SIZE (audacity-audacity-Audacity-2.4.2_GH0.tar.gz) = 61248430
+TIMESTAMP = 1616886054
+SHA256 (audacity-minsrc-3.0.0.tar.xz) = d3bb1358b930ea4ef935ed83cc5a0f47006565762c5667c2fb376c6535876a6a
+SIZE (audacity-minsrc-3.0.0.tar.xz) = 13308836
diff --git a/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt b/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
index 4f1dbe0e6300..bec1681c2429 100644
--- a/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
+++ b/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
@@ -1,4 +1,4 @@
---- cmake-proxies/CMakeLists.txt.orig 2020-06-19 15:16:47 UTC
+--- cmake-proxies/CMakeLists.txt.orig 2021-02-04 18:52:51 UTC
+++ cmake-proxies/CMakeLists.txt
@@ -132,7 +132,7 @@ addlib( expat expat EXPAT YES
addlib( lame lame LAME YES YES "lame >= 3.100" )
@@ -6,6 +6,6 @@
addlib( libsoxr soxr SOXR YES YES "soxr >= 0.1.1" )
-addlib( portaudio-v19 portaudio PORTAUDIO YES YES "" )
+addlib( portaudio-v19 portaudio PORTAUDIO YES YES "portaudio-2.0 >= 19" )
+ addlib( sqlite sqlite SQLITE YES YES "sqlite3 >= 3.32.0" )
# Optional libraries
- #
diff --git a/audio/audacity/files/patch-cmake-proxies_wxWidgets_CMakeLists.txt b/audio/audacity/files/patch-cmake-proxies_wxWidgets_CMakeLists.txt
new file mode 100644
index 000000000000..9be6dbd70f27
--- /dev/null
+++ b/audio/audacity/files/patch-cmake-proxies_wxWidgets_CMakeLists.txt
@@ -0,0 +1,20 @@
+--- cmake-proxies/wxWidgets/CMakeLists.txt.orig 2020-08-05 16:32:53 UTC
++++ cmake-proxies/wxWidgets/CMakeLists.txt
+@@ -237,17 +237,6 @@ file(
+ "^#define +wxVERSION_STRING +"
+ )
+
+-string( REGEX MATCHALL "\".+(Audacity).+\"" ours "${output}")
+-if( NOT ours )
+- message( FATAL_ERROR
+- "\n########################################################################\n"
+- "Audacity version 3.0.0 or higher requires use of a customized version of "
+- "wxWidgets. For details:\n"
+- " https://wiki.audacityteam.org/wiki/Building_for_Distros\n"
+- "########################################################################\n"
+- )
+-endif()
+-
+ target_include_directories( ${TARGET} INTERFACE ${INCLUDES} )
+ target_compile_definitions( ${TARGET} INTERFACE ${DEFINES} )
+ target_compile_options( ${TARGET} INTERFACE ${COPTS} )
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
index 30388586d0be..2d0cca0557c2 100644
--- a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
+++ b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
@@ -1,4 +1,4 @@
---- lib-src/libnyquist/nyquist/cmt/cext.h.orig 2018-10-01 14:07:33 UTC
+--- lib-src/libnyquist/nyquist/cmt/cext.h.orig 2021-02-04 18:52:51 UTC
+++ lib-src/libnyquist/nyquist/cmt/cext.h
@@ -61,7 +61,7 @@ EXIT(n) -- calls exit(n) after shutting down/dealloca
#include <malloc.h>
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqstk_include_FileRead.h b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqstk_include_FileRead.h
deleted file mode 100644
index fb9932cd3c0c..000000000000
--- a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqstk_include_FileRead.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h.orig 2016-07-26 13:34:06 UTC
-+++ lib-src/libnyquist/nyquist/nyqstk/include/FileRead.h
-@@ -33,6 +33,7 @@
- #define STK_FILEREAD_H
-
- #include "Stk.h"
-+#include <stdio.h>
-
- namespace Nyq
- {
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlfio.c b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlfio.c
new file mode 100644
index 000000000000..4bb6881c486d
--- /dev/null
+++ b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlfio.c
@@ -0,0 +1,12 @@
+--- lib-src/libnyquist/nyquist/xlisp/xlfio.c.orig 2021-02-04 18:52:51 UTC
++++ lib-src/libnyquist/nyquist/xlisp/xlfio.c
+@@ -19,8 +19,7 @@
+ /* do some sanity checking: */
+ #ifndef XL_BIG_ENDIAN
+ #ifndef XL_LITTLE_ENDIAN
+-#error configuration error -- either XL_BIG_ or XL_LITTLE_ENDIAN must be defined
+-in xlisp.h
++#error configuration error -- either XL_BIG_ or XL_LITTLE_ENDIAN must be defined in xlisp.h
+ #endif
+ #endif
+ #ifdef XL_BIG_ENDIAN
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
index cbf7ec305e7c..64e0f0276d9e 100644
--- a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
+++ b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
@@ -1,6 +1,6 @@
---- lib-src/libnyquist/nyquist/xlisp/xlisp.h.orig 2016-07-26 13:34:06 UTC
+--- lib-src/libnyquist/nyquist/xlisp/xlisp.h.orig 2021-02-04 18:52:51 UTC
+++ lib-src/libnyquist/nyquist/xlisp/xlisp.h
-@@ -161,6 +161,15 @@ extern long ptrtoabs();
+@@ -172,6 +172,15 @@ extern long ptrtoabs();
#endif
#endif
@@ -13,6 +13,6 @@
+#endif
+#endif
+
- /* Apple CC */
+ /* Apple CC (xcode, macOS, macintosh) */
#ifdef __APPLE__
#define NNODES 2000
diff --git a/audio/audacity/files/patch-lib-src_portsmf_allegro.h b/audio/audacity/files/patch-lib-src_portsmf_allegro.h
deleted file mode 100644
index 747f85b03f78..000000000000
--- a/audio/audacity/files/patch-lib-src_portsmf_allegro.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib-src/portsmf/allegro.h.orig 2020-07-18 17:54:26 UTC
-+++ lib-src/portsmf/allegro.h
-@@ -51,6 +51,7 @@
- #include <assert.h>
- #include <istream>
- #include <ostream>
-+#include <cstring>
-
- #define ALG_EPS 0.000001 // epsilon
- #define ALG_DEFAULT_BPM 100.0 // default tempo
diff --git a/audio/audacity/files/patch-src_AudioIO.cpp b/audio/audacity/files/patch-src_AudioIO.cpp
index 6cc523faba46..7534cdee3a98 100644
--- a/audio/audacity/files/patch-src_AudioIO.cpp
+++ b/audio/audacity/files/patch-src_AudioIO.cpp
@@ -1,6 +1,6 @@
--- src/AudioIO.cpp.orig 2020-06-19 15:16:47 UTC
+++ src/AudioIO.cpp
-@@ -491,7 +491,6 @@ time warp info and AudioIOListener and whether the pla
+@@ -490,7 +490,6 @@ time warp info and AudioIOListener and whether the pla
#define ROUND(x) (int) ((x)+0.5)
//#include <string.h>
// #include "../lib-src/portmidi/pm_common/portmidi.h"
@@ -8,7 +8,7 @@
#include "NoteTrack.h"
#endif
-@@ -815,13 +814,22 @@ struct AudioIoCallback::ScrubState (private)
+@@ -814,13 +813,22 @@ struct AudioIoCallback::ScrubState (private)
// return the system time as a double
static double streamStartTime = 0; // bias system time to small number
diff --git a/audio/audacity/files/patch-src_FFmpeg.h b/audio/audacity/files/patch-src_FFmpeg.h
deleted file mode 100644
index de19b2a86437..000000000000
--- a/audio/audacity/files/patch-src_FFmpeg.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/FFmpeg.h.orig 2018-10-01 14:07:33 UTC
-+++ src/FFmpeg.h
-@@ -685,7 +685,7 @@ extern "C" {
- FFMPEG_FUNCTION_WITH_RETURN(
- AVOutputFormat*,
- av_oformat_next,
-- (AVOutputFormat *f),
-+ (const AVOutputFormat *f),
- (f)
- );
- #endif
-@@ -766,7 +766,7 @@ extern "C" {
- FFMPEG_FUNCTION_WITH_RETURN(
- int,
- av_fifo_size,
-- (AVFifoBuffer *f),
-+ (const AVFifoBuffer *f),
- (f)
- );
- #endif
-@@ -828,7 +828,7 @@ extern "C" {
- FFMPEG_FUNCTION_WITH_RETURN(
- AVDictionaryEntry *,
- av_dict_get,
-- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
-+ (const AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
- (m, key, prev, flags)
- );
- #endif
diff --git a/audio/audacity/files/patch-src_ProjectSerializer.cpp b/audio/audacity/files/patch-src_ProjectSerializer.cpp
new file mode 100644
index 000000000000..3e43594c4a59
--- /dev/null
+++ b/audio/audacity/files/patch-src_ProjectSerializer.cpp
@@ -0,0 +1,60 @@
+--- src/ProjectSerializer.cpp.orig 2021-02-04 18:52:51 UTC
++++ src/ProjectSerializer.cpp
+@@ -206,9 +206,9 @@ ProjectSerializer::ProjectSerializer(size_t allocSize)
+ std::call_once(flag, []{
+ // Just once per run, store header information in the unique static
+ // dictionary that will be written into each project that is saved.
+- // Store the size of "wxChar" so we can convert during recovery in
+- // case the file is used on a system with a different character size.
+- char size = sizeof(wxChar);
++ // Store the size of "wxStringCharType" so we can convert during recovery
++ // in case the file is used on a system with a different character size.
++ char size = sizeof(wxStringCharType);
+ mDict.AppendByte(FT_CharSize);
+ mDict.AppendData(&size, 1);
+ });
+@@ -242,7 +242,7 @@ void ProjectSerializer::WriteAttr(const wxString & nam
+ mBuffer.AppendByte(FT_String);
+ WriteName(name);
+
+- const Length len = value.length() * sizeof(wxChar);
++ const Length len = value.length() * sizeof(wxStringCharType);
+ WriteLength( mBuffer, len );
+ mBuffer.AppendData(value.wx_str(), len);
+ }
+@@ -309,7 +309,7 @@ void ProjectSerializer::WriteData(const wxString & val
+ {
+ mBuffer.AppendByte(FT_Data);
+
+- Length len = value.length() * sizeof(wxChar);
++ Length len = value.length() * sizeof(wxStringCharType);
+ WriteLength( mBuffer, len );
+ mBuffer.AppendData(value.wx_str(), len);
+ }
+@@ -317,7 +317,7 @@ void ProjectSerializer::WriteData(const wxString & val
+ void ProjectSerializer::Write(const wxString & value)
+ {
+ mBuffer.AppendByte(FT_Raw);
+- Length len = value.length() * sizeof(wxChar);
++ Length len = value.length() * sizeof(wxStringCharType);
+ WriteLength( mBuffer, len );
+ mBuffer.AppendData(value.wx_str(), len);
+ }
+@@ -334,7 +334,7 @@ void ProjectSerializer::WriteSubTree(const ProjectSeri
+
+ void ProjectSerializer::WriteName(const wxString & name)
+ {
+- wxASSERT(name.length() * sizeof(wxChar) <= SHRT_MAX);
++ wxASSERT(name.length() * sizeof(wxStringCharType) <= SHRT_MAX);
+ UShort id;
+
+ auto nameiter = mNames.find(name);
+@@ -346,7 +346,7 @@ void ProjectSerializer::WriteName(const wxString & nam
+ {
+ // mNames is static. This appends each name to static mDict only once
+ // in each run.
+- UShort len = name.length() * sizeof(wxChar);
++ UShort len = name.length() * sizeof(wxStringCharType);
+
+ id = mNames.size();
+ mNames[name] = id;
diff --git a/audio/audacity/files/patch-src_import_Import.cpp b/audio/audacity/files/patch-src_import_Import.cpp
new file mode 100644
index 000000000000..5e43033c33ee
--- /dev/null
+++ b/audio/audacity/files/patch-src_import_Import.cpp
@@ -0,0 +1,16 @@
+--- src/import/Import.cpp.orig 2021-02-04 18:52:51 UTC
++++ src/import/Import.cpp
+@@ -803,9 +803,11 @@ bool Importer::Import( AudacityProject &project,
+ /* i18n-hint: %s will be the filename */
+ "Audacity did not recognize the type of the file '%s'.\n\n%sFor uncompressed files, also try File > Import > Raw Data.")
+ .Format( fName,
++#if defined(USE_FFMPEG)
+ !FFmpegLibsInst()
+- ? XO("Try installing FFmpeg.\n\n")
+- : XO("") );
++ ? XO("Try installing FFmpeg.\n\n") :
++#endif
++ Verbatim("") );
+ }
+ else
+ {
diff --git a/audio/audacity/files/patch-src_widgets_FileConfig.cpp b/audio/audacity/files/patch-src_widgets_FileConfig.cpp
new file mode 100644
index 000000000000..dbad602eaca0
--- /dev/null
+++ b/audio/audacity/files/patch-src_widgets_FileConfig.cpp
@@ -0,0 +1,11 @@
+--- src/widgets/FileConfig.cpp.orig 2021-02-04 18:52:51 UTC
++++ src/widgets/FileConfig.cpp
+@@ -10,6 +10,8 @@
+
+ #include "../Audacity.h"
+
++#include <errno.h>
++
+ #include <wx/defs.h>
+ #include <wx/app.h>
+ #include <wx/bmpbuttn.h>
diff --git a/audio/audacity/files/patch-src_widgets_Grid.cpp b/audio/audacity/files/patch-src_widgets_Grid.cpp
new file mode 100644
index 000000000000..4945a5bc8067
--- /dev/null
+++ b/audio/audacity/files/patch-src_widgets_Grid.cpp
@@ -0,0 +1,11 @@
+--- src/widgets/Grid.cpp.orig 2021-02-04 18:52:51 UTC
++++ src/widgets/Grid.cpp
+@@ -572,7 +572,7 @@ void Grid::OnKeyDown(wxKeyEvent &event)
+ {
+ wxTextDataObject *data = safenew wxTextDataObject(GetCellValue(crow, ccol));
+ wxClipboard::Get()->SetData(data);
+- SetCellValue(crow, ccol, {});
++ SetCellValue(crow, ccol, "");
+ return;
+ }
+ break;
diff --git a/audio/audacity/pkg-plist b/audio/audacity/pkg-plist
index 22a98a03a8e4..5457883d5bd6 100644
--- a/audio/audacity/pkg-plist
+++ b/audio/audacity/pkg-plist
@@ -49,8 +49,6 @@ share/applications/audacity.desktop
%%DATADIR%%/nyquist/velocity.lsp
%%DATADIR%%/nyquist/xlinit.lsp
%%DATADIR%%/nyquist/xm.lsp
-%%DATADIR%%/plug-ins/SilenceMarker.ny
-%%DATADIR%%/plug-ins/SoundFinder.ny
%%DATADIR%%/plug-ins/SpectralEditMulti.ny
%%DATADIR%%/plug-ins/SpectralEditParametricEQ.ny
%%DATADIR%%/plug-ins/SpectralEditShelves.ny
@@ -64,6 +62,7 @@ share/applications/audacity.desktop
%%DATADIR%%/plug-ins/eq-xml-to-txt-converter.ny
%%DATADIR%%/plug-ins/equalabel.ny
%%DATADIR%%/plug-ins/highpass.ny
+%%DATADIR%%/plug-ins/label-sounds.ny
%%DATADIR%%/plug-ins/limiter.ny
%%DATADIR%%/plug-ins/lowpass.ny
%%DATADIR%%/plug-ins/noisegate.ny
@@ -93,6 +92,7 @@ share/icons/hicolor/scalable/apps/audacity.svg
%%NLS%%share/locale/bs/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/ca/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/ca_ES@valencia/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/co/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/cs/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/cy/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/da/LC_MESSAGES/audacity.mo
@@ -119,6 +119,7 @@ share/icons/hicolor/scalable/apps/audacity.svg
%%NLS%%share/locale/ko/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/lt/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/mk/LC_MESSAGES/audacity.mo
+%%NLS%%share/locale/mr/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/my/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/nb/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/nl/LC_MESSAGES/audacity.mo