aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-09-30 09:36:11 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-09-30 09:36:11 +0000
commita2c85be5dfbd98a87ce64ecb8ed942f559b7fc46 (patch)
treefbb5823e93cfb6d99c76710f12d59c6f32cd9e3e
parentba131b23805c5255b7fbea4ce29544347557da09 (diff)
downloadports-a2c85be5dfbd98a87ce64ecb8ed942f559b7fc46.tar.gz
ports-a2c85be5dfbd98a87ce64ecb8ed942f559b7fc46.zip
[NEW PORT]: databases/py-redis2
Repocopy databases/py-redis to databases/py-redis2 to have the latest version of the 2.x release branch for a while. Use it also as a fallback if some consumers have issues with the upcoming update of databases/py-redis to the 3.x release. PR: 237237 Approved by: koobs (maintainer)
Notes
Notes: svn path=/head/; revision=513337
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-redis/Makefile1
-rw-r--r--databases/py-redis2/Makefile39
-rw-r--r--databases/py-redis2/distinfo3
-rw-r--r--databases/py-redis2/pkg-descr3
5 files changed, 47 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index cfe7634dc105..691981f2ff2a 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -843,6 +843,7 @@
SUBDIR += py-queries
SUBDIR += py-rb
SUBDIR += py-redis
+ SUBDIR += py-redis2
SUBDIR += py-riak
SUBDIR += py-rrdtool_lgpl
SUBDIR += py-sispy
diff --git a/databases/py-redis/Makefile b/databases/py-redis/Makefile
index f76a610b6890..07a4a0b17005 100644
--- a/databases/py-redis/Makefile
+++ b/databases/py-redis/Makefile
@@ -28,6 +28,7 @@ GH_ACCOUNT= andymccurdy
GH_PROJECT= ${PORTNAME}-py
NO_ARCH= yes
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}redis2
# Needs redis-server to be running
do-test:
diff --git a/databases/py-redis2/Makefile b/databases/py-redis2/Makefile
new file mode 100644
index 000000000000..30ed2a7aed06
--- /dev/null
+++ b/databases/py-redis2/Makefile
@@ -0,0 +1,39 @@
+# Created by: Cheng-Lung Sung <clsung@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= redis
+PORTVERSION= 2.10.6
+CATEGORIES= databases python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 2
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Python client for Redis key-value store
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= redis-server:databases/redis
+
+OPTIONS_DEFINE= HIREDIS
+
+HIREDIS_DESC= High performance response parser (via hiredis)
+
+HIREDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hiredis>0:databases/py-hiredis@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist concurrent
+
+USE_GITHUB= yes
+GH_ACCOUNT= andymccurdy
+GH_PROJECT= ${PORTNAME}-py
+
+NO_ARCH= yes
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}redis
+PORTSCOUT= limit:^2\.
+
+# Needs redis-server to be running
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/databases/py-redis2/distinfo b/databases/py-redis2/distinfo
new file mode 100644
index 000000000000..4a453d1f3ff6
--- /dev/null
+++ b/databases/py-redis2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1508148992
+SHA256 (andymccurdy-redis-py-2.10.6_GH0.tar.gz) = e28e24539d6590a8b88498f2d30f7fe3e2be1171d7a91fe1fa6c5b6982519015
+SIZE (andymccurdy-redis-py-2.10.6_GH0.tar.gz) = 94869
diff --git a/databases/py-redis2/pkg-descr b/databases/py-redis2/pkg-descr
new file mode 100644
index 000000000000..332817e4e430
--- /dev/null
+++ b/databases/py-redis2/pkg-descr
@@ -0,0 +1,3 @@
+This is the Python interface to the Redis key-value store.
+
+WWW: https://github.com/andymccurdy/redis-py