aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-04 14:11:32 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-04 14:11:32 +0000
commita3244e67b7a90eaa3fc842d05fb40b6d40f0eee0 (patch)
tree870a61a2f7d1eaa6588e52d1772bfd52ab25c6e1
parentf4b9e5c40aad945de193291277e62a73dbfe0243 (diff)
downloadports-a3244e67b7a90eaa3fc842d05fb40b6d40f0eee0.tar.gz
ports-a3244e67b7a90eaa3fc842d05fb40b6d40f0eee0.zip
security/wazuh-manager: Fix issue on aarch64
- Bump PORTREVISION Reported by: pkg-fallout
-rw-r--r--security/wazuh-manager/Makefile1
-rw-r--r--security/wazuh-manager/files/patch-src-rootcheck_os_string.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/security/wazuh-manager/Makefile b/security/wazuh-manager/Makefile
index a2fd2cf92c06..77128d95271a 100644
--- a/security/wazuh-manager/Makefile
+++ b/security/wazuh-manager/Makefile
@@ -1,6 +1,7 @@
PORTNAME= wazuh
DISTVERSION= 4.4.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://packages.wazuh.com/deps/18/libraries/sources/:wazuh_sources \
LOCAL/acm/${PORTNAME}/:wazuh_cache
diff --git a/security/wazuh-manager/files/patch-src-rootcheck_os_string.c b/security/wazuh-manager/files/patch-src-rootcheck_os_string.c
index 7655cc71532e..fdbe184aace3 100644
--- a/security/wazuh-manager/files/patch-src-rootcheck_os_string.c
+++ b/security/wazuh-manager/files/patch-src-rootcheck_os_string.c
@@ -5,7 +5,7 @@
#include <unistd.h>
#include <netinet/in.h>
+#ifdef __FreeBSD__
-+#include <machine/exec.h>
++#define __LDPGSZ 4096
+#endif
#ifdef SOLARIS