aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:53:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 14:53:20 +0000
commita327ff430ab824a5e8342f6a95e1d749c043e5de (patch)
tree29243a947e6109dbf0500a80dd52284f80f4b0aa
parenta2275161bdf38678974bb793dfe3195fe1950aab (diff)
downloadports-a327ff430ab824a5e8342f6a95e1d749c043e5de.tar.gz
ports-a327ff430ab824a5e8342f6a95e1d749c043e5de.zip
In preparation for making libtool generate libraries with a sane name, fix all
LIB_DEPENDS in cad With hat: portmgr
Notes
Notes: svn path=/head/; revision=336172
-rw-r--r--cad/brlcad/Makefile14
-rw-r--r--cad/calculix/Makefile16
-rw-r--r--cad/electric/Makefile2
-rw-r--r--cad/geda-gattrib/Makefile2
-rw-r--r--cad/geda-gschem/Makefile2
-rw-r--r--cad/geda-netlist/Makefile2
-rw-r--r--cad/geda-symcheck/Makefile2
-rw-r--r--cad/geda-utils/Makefile2
-rw-r--r--cad/gmsh/Makefile16
-rw-r--r--cad/kicad-devel/Makefile2
-rw-r--r--cad/kicad/Makefile2
-rw-r--r--cad/libgeda/Makefile2
-rw-r--r--cad/netgen/Makefile10
-rw-r--r--cad/opencascade/Makefile14
-rw-r--r--cad/pcb/Makefile4
-rw-r--r--cad/pdnmesh/Makefile24
-rw-r--r--cad/qcad/Makefile2
-rw-r--r--cad/scotch/Makefile2
-rw-r--r--cad/tochnog/Makefile4
-rw-r--r--cad/varkon/Makefile2
-rw-r--r--cad/z88/Makefile2
21 files changed, 64 insertions, 64 deletions
diff --git a/cad/brlcad/Makefile b/cad/brlcad/Makefile
index d261fff8915d..7eeddf946135 100644
--- a/cad/brlcad/Makefile
+++ b/cad/brlcad/Makefile
@@ -11,13 +11,13 @@ COMMENT= CSG modelling system from the US Ballistic Research Laboratory
BUILD_DEPENDS= ${LOCALBASE}/include/tnt/jama_lu.h:${PORTSDIR}/math/jama \
xsltproc:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- drm:${PORTSDIR}/graphics/libdrm \
- png15:${PORTSDIR}/graphics/png \
- rle:${PORTSDIR}/graphics/urt \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libdrm.so:${PORTSDIR}/graphics/libdrm \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ librle.so:${PORTSDIR}/graphics/urt \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
USE_BZIP2= yes
USE_GL= gl glu
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index 948b94ad0b68..1af77d935ae9 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -27,9 +27,9 @@ COMMENT= A Three-Dimensional Structural Finite Element Program
LICENSE= GPLv2
-LIB_DEPENDS= arpack.1:${PORTSDIR}/math/arpack \
- spooles.1:${PORTSDIR}/math/spooles \
- taucs.1:${PORTSDIR}/math/taucs
+LIB_DEPENDS= libarpack.so:${PORTSDIR}/math/arpack \
+ libspooles.so:${PORTSDIR}/math/spooles \
+ libtaucs.so:${PORTSDIR}/math/taucs
USE_BZIP2= yes
@@ -61,22 +61,22 @@ OPTIONS_DEFINE= METIS METIS_EDF
OPTIONS_DEFAULT=METIS
.if ${PORT_OPTIONS:MMETIS}
-LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis4
+LIB_DEPENDS+= libmetis.so:${PORTSDIR}/math/metis4
.endif
.if ${PORT_OPTIONS:MMETIS_EDF}
-LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis-edf
+LIB_DEPENDS+= libmetis.so:${PORTSDIR}/math/metis-edf
.endif
.if exists(${LOCALBASE}/lib/libatlas.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS_LIBS= -lf77blas
LAPACK_LIBS= -lalapack -lcblas
.else
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS_LIBS= -lblas
LAPACK_LIBS= -llapack
.endif
diff --git a/cad/electric/Makefile b/cad/electric/Makefile
index 9e0c37ff1476..22c9c35dc0a3 100644
--- a/cad/electric/Makefile
+++ b/cad/electric/Makefile
@@ -26,7 +26,7 @@ NO_STAGE= yes
FEATURES+= MOTIF
.if ${PORT_OPTIONS:MT1LIB}
-LIB_DEPENDS+= t1.5:${PORTSDIR}/devel/t1lib
+LIB_DEPENDS+= libt1.so:${PORTSDIR}/devel/t1lib
FEATURES+= T1LIB
.endif
diff --git a/cad/geda-gattrib/Makefile b/cad/geda-gattrib/Makefile
index 78cd68a4a7d6..f475b511bb03 100644
--- a/cad/geda-gattrib/Makefile
+++ b/cad/geda-gattrib/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The gEDA's attribute editor
RUN_DEPENDS= ${LOCALBASE}/share/geda/sym:${PORTSDIR}/cad/geda-symbols
-LIB_DEPENDS= geda.33:${PORTSDIR}/cad/libgeda
+LIB_DEPENDS= libgeda.so:${PORTSDIR}/cad/libgeda
DATADIR= ${PREFIX}/share/geda
DOCSDIR= ${PREFIX}/share/doc/geda
diff --git a/cad/geda-gschem/Makefile b/cad/geda-gschem/Makefile
index a6e2315c24ad..bfc13927619d 100644
--- a/cad/geda-gschem/Makefile
+++ b/cad/geda-gschem/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The gEDA's electronic schematic capture tool
RUN_DEPENDS= ${LOCALBASE}/share/geda/sym:${PORTSDIR}/cad/geda-symbols
-LIB_DEPENDS= geda.33:${PORTSDIR}/cad/libgeda
+LIB_DEPENDS= libgeda.so:${PORTSDIR}/cad/libgeda
DOCSDIR= ${PREFIX}/share/doc/geda
DATADIR= ${PREFIX}/share/geda
diff --git a/cad/geda-netlist/Makefile b/cad/geda-netlist/Makefile
index 69d622e45b3a..f8dda2716fe1 100644
--- a/cad/geda-netlist/Makefile
+++ b/cad/geda-netlist/Makefile
@@ -14,7 +14,7 @@ DISTNAME= ${PKGNAMEPREFIX}g${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The gEDA's netlister
-LIB_DEPENDS= geda.33:${PORTSDIR}/cad/libgeda
+LIB_DEPENDS= libgeda.so:${PORTSDIR}/cad/libgeda
RUN_DEPENDS= ${LOCALBASE}/share/geda/sym:${PORTSDIR}/cad/geda-symbols
DATADIR= ${PREFIX}/share/geda
diff --git a/cad/geda-symcheck/Makefile b/cad/geda-symcheck/Makefile
index 38b6f5db6160..f33e35476412 100644
--- a/cad/geda-symcheck/Makefile
+++ b/cad/geda-symcheck/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The gEDA's symbol checking utility
RUN_DEPENDS= ${LOCALBASE}/share/geda/sym:${PORTSDIR}/cad/geda-symbols
-LIB_DEPENDS= geda.33:${PORTSDIR}/cad/libgeda
+LIB_DEPENDS= libgeda.so:${PORTSDIR}/cad/libgeda
DOCSDIR= ${PREFIX}/share/doc/geda
DATADIR= ${PREFIX}/share/geda
diff --git a/cad/geda-utils/Makefile b/cad/geda-utils/Makefile
index 730b9f279aa2..a2c4a061bbd3 100644
--- a/cad/geda-utils/Makefile
+++ b/cad/geda-utils/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The gEDA's utilities
RUN_DEPENDS= ${LOCALBASE}/share/geda/sym:${PORTSDIR}/cad/geda-symbols
-LIB_DEPENDS= geda.33:${PORTSDIR}/cad/libgeda
+LIB_DEPENDS= libgeda.so:${PORTSDIR}/cad/libgeda
DOCSDIR= ${PREFIX}/share/doc/geda
DATADIR= ${PREFIX}/share/geda
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index 3c2608e5674a..e0814df5620e 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -18,10 +18,10 @@ COMMENT= An automatic 3D finite element mesh generator
LICENSE= GPLv2
-LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk \
- jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ liblapack.so:${PORTSDIR}/math/lapack
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
@@ -86,21 +86,21 @@ PLIST_SUB+= METIS="@comment "
.endif
.if defined(WITH_TAUCS)
-LIB_DEPENDS+= taucs:${PORTSDIR}/math/taucs
+LIB_DEPENDS+= libtaucs.so:${PORTSDIR}/math/taucs
CMAKE_ARGS+= -DENABLE_TAUCS=ON
.else
CMAKE_ARGS+= -DENABLE_TAUCS=OFF
.endif
.if !defined(WITHOUT_MED)
-LIB_DEPENDS+= med:${PORTSDIR}/french/med
+LIB_DEPENDS+= libmed.so:${PORTSDIR}/french/med
CMAKE_ARGS+= -DENABLE_MED=ON
.else
CMAKE_ARGS+= -DENABLE_MED=OFF
.endif
.if !defined(WITHOUT_CGNS)
-LIB_DEPENDS+= cgns:${PORTSDIR}/science/cgnslib
+LIB_DEPENDS+= libcgns.so:${PORTSDIR}/science/cgnslib
CMAKE_ARGS+= -DENABLE_CGNS=ON
.else
CMAKE_ARGS+= -DENABLE_CGNS=OFF
@@ -111,7 +111,7 @@ CMAKE_ARGS+= -DENABLE_GMM=OFF
.endif
.if defined(WITH_OCC)
-LIB_DEPENDS+= TKernel:${PORTSDIR}/cad/opencascade
+LIB_DEPENDS+= libTKernel.so:${PORTSDIR}/cad/opencascade
CMAKE_ARGS+= -DENABLE_OCC=ON -DOCC_INC=${LOCALBASE}/include/OpenCASCADE
CONFLICTS= gmsh-2.*
.else
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index 28cb2327411f..c1ac1df5b171 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= wxgtk2-2.8-config:${PORTSDIR}/x11-toolkits/wxgtk28 \
bzr:${PORTSDIR}/devel/bzr \
${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/bzrlib/plugins/bzrtools/bzrtools.py:${PORTSDIR}/devel/bzrtools
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
CONFLICTS= kicad-2008*
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index e8c4b1b09d51..23da4f4caa68 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -15,7 +15,7 @@ EXTRACT_ONLY= ${SFNAME}-stable${EXTRACT_SUFX}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Schematic and PCB editing software
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/share/kicad/library/74xx.dcm:${PORTSDIR}/cad/kicad-library
CONFLICTS= kicad-devel*
diff --git a/cad/libgeda/Makefile b/cad/libgeda/Makefile
index 90f0cde15677..fcda30ad558e 100644
--- a/cad/libgeda/Makefile
+++ b/cad/libgeda/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/release/v1.4/${PORTVERSION}/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= The gEDA's tools base utility library
-LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
+LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/cad/netgen/Makefile b/cad/netgen/Makefile
index 833b7d703462..fb4d5d3c1a27 100644
--- a/cad/netgen/Makefile
+++ b/cad/netgen/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF/netgen-mesher/netgen-mesher/${PORTVERSION:S|.0$||}/
MAINTAINER= stephen@FreeBSD.org
COMMENT= An automatic 3D tetrahedral mesh generator
-LIB_DEPENDS= Tix8.4.3:${PORTSDIR}/x11-toolkits/tix \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- togl.1:${PORTSDIR}/graphics/togl
+LIB_DEPENDS= liobTix8.4.so:${PORTSDIR}/x11-toolkits/tix \
+ liobjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liobtogl.so:${PORTSDIR}/graphics/togl
USE_LDCONFIG= yes
USES= gmake
@@ -36,13 +36,13 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOCC}
-LIB_DEPENDS+= TKernel.0:${PORTSDIR}/cad/opencascade
+LIB_DEPENDS+= libTKernel.so:${PORTSDIR}/cad/opencascade
CXXFLAGS+= -DOCCGEOMETRY -DHAVE_CONFIG_H -D${ARCH} -I${LOCALBASE}/include/OpenCASCADE
CONFIGURE_ARGS+= --enable-occ
.endif
.if ${PORT_OPTIONS:MFFMPEG}
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-ffmpeg
.endif
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index fc7462c4a331..f5f97fa30f83 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -53,7 +53,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTBB}
-LIB_DEPENDS+= tbb:${PORTSDIR}/devel/tbb
+LIB_DEPENDS+= libtbb.so:${PORTSDIR}/devel/tbb
CONFIGURE_ARGS+=--with-tbb-include=${LOCALBASE}/include \
--with-tbb-library=${LOCALBASE}/lib
.endif
@@ -64,9 +64,9 @@ CONFIGURE_ARGS+=--enable-vis \
--with-freetype=${LOCALBASE} \
--with-gl2ps=${LOCALBASE}
USE_GL= glu
-LIB_DEPENDS+= ftgl:${PORTSDIR}/graphics/ftgl \
- freetype:${PORTSDIR}/print/freetype2 \
- gl2ps:${PORTSDIR}/print/gl2ps
+LIB_DEPENDS+= libftgl.so:${PORTSDIR}/graphics/ftgl \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libgl2ps:${PORTSDIR}/print/gl2ps
PLIST_SUB+= VIS=""
. if ${PORT_OPTIONS:MOCAF}
CONFIGURE_ARGS+=--enable-caf
@@ -79,8 +79,8 @@ CONFIGURE_ARGS+=--enable-draw \
--with-tcl=${TCL_LIBDIR} \
--with-tk=${TK_LIBDIR}
USE_TK= 84+
-LIB_DEPENDS+= itcl.${ITCL_VER}:${PORTSDIR}/lang/itcl \
- Tix${TIX_VER}:${PORTSDIR}/x11-toolkits/tix
+LIB_DEPENDS+= libitcl.so.${ITCL_VER}:${PORTSDIR}/lang/itcl \
+ libTix${TIX_VER}.so:${PORTSDIR}/x11-toolkits/tix
ITCL_VER= 3
TIX_VER= 8.4.3
TIX_MM= 8.4.3
@@ -103,7 +103,7 @@ PLIST_SUB+= VIS="@comment " DRAW="@comment " DE="@comment " OCAF="@comment "
.endif
.if ${PORT_OPTIONS:MFI}
-LIB_DEPENDS+= freeimageplus:${PORTSDIR}/graphics/freeimage
+LIB_DEPENDS+= libfreeimageplus.so:${PORTSDIR}/graphics/freeimage
CONFIGURE_ARGS+=--with-freeimage=${LOCALBASE}
.else
PLIST_SUB+= FI="@comment "
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index c820e851058a..04c7b907acdd 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -12,8 +12,8 @@ COMMENT= X11 interactive printed circuit board layout system
LICENSE= GPLv2
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
- gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
+ libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
RUN_DEPENDS= m4>=1.4.11:${PORTSDIR}/devel/m4 \
${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus
BUILD_DEPENDS:= ${RUN_DEPENDS}
diff --git a/cad/pdnmesh/Makefile b/cad/pdnmesh/Makefile
index 1da7cbd283af..e7a4f8adb7bf 100644
--- a/cad/pdnmesh/Makefile
+++ b/cad/pdnmesh/Makefile
@@ -12,15 +12,15 @@ COMMENT= Mesh generator and solver for Finite Element problems
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- cairo:${PORTSDIR}/graphics/cairo \
- drm:${PORTSDIR}/graphics/libdrm \
- png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- gtkglext:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libcairo.so:${PORTSDIR}/graphics/cairo \
+ libdrm.so:${PORTSDIR}/graphics/libdrm \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libgtkglext.so:${PORTSDIR}/x11-toolkits/gtkglext
OPTIONS_DEFINE= ATLAS DOCS EXAMPLES
ATLAS_DESC= Enable ATLAS support
@@ -45,11 +45,11 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MATLAS}
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
CONFIGURE_ARGS+=--with-blas=cblas --with-lapack=alapack
.else
-LIB_DEPENDS+= blas:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
CONFIGURE_ARGS+=--with-blas=blas --with-lapack=lapack
.endif
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 30c2796a8e15..5cdab85ed22b 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/lib/libopenNURBS.a:${PORTSDIR}/graphics/opennurbs
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
CONFLICTS= texlive-base-*
diff --git a/cad/scotch/Makefile b/cad/scotch/Makefile
index ee0445befb0c..53263032c79b 100644
--- a/cad/scotch/Makefile
+++ b/cad/scotch/Makefile
@@ -51,7 +51,7 @@ MAN1= acpl.1 amk_ccc.1 amk_fft2.1 amk_grf.1 amk_hy.1 amk_m2.1 amk_p2.1 \
PKGMESSAGE= ${WRKSRC}/LICENSE_en.txt
.if !defined(WITHOUT_MPI)
-LIB_DEPENDS+= mpich.2:${PORTSDIR}/net/mpich2
+LIB_DEPENDS+= libmpich.so:${PORTSDIR}/net/mpich2
ALL_TARGET+= ptscotch
MAKE_ENV+= PATH=${PATH}:${LOCALBASE}/mpich2/bin
diff --git a/cad/tochnog/Makefile b/cad/tochnog/Makefile
index c5f8985734c4..5df89c64a942 100644
--- a/cad/tochnog/Makefile
+++ b/cad/tochnog/Makefile
@@ -12,9 +12,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A free explicit/implicit Finite Element Program
.ifdef WITH_ATLAS
-LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS= libatlas.so:${PORTSDIR}/math/atlas
.else
-LIB_DEPENDS= blas:${PORTSDIR}/math/blas
+LIB_DEPENDS= libblas.so:${PORTSDIR}/math/blas
.endif
BUILD_DEPENDS= ${LOCALBASE}/lib/libf2c.a:${PORTSDIR}/lang/f2c
.ifdef WITH_THREADS
diff --git a/cad/varkon/Makefile b/cad/varkon/Makefile
index 1543371b43fd..7d24a189aa13 100644
--- a/cad/varkon/Makefile
+++ b/cad/varkon/Makefile
@@ -11,7 +11,7 @@ DIST_SUBDIR= varkon
MAINTAINER= ports@FreeBSD.org
COMMENT= Free CAD system and applications development tool
-LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
WRKSRC= ${WRKDIR}/Varkon_${PORTVERSION}
diff --git a/cad/z88/Makefile b/cad/z88/Makefile
index c0a2a2325477..cfce3f1906c5 100644
--- a/cad/z88/Makefile
+++ b/cad/z88/Makefile
@@ -13,7 +13,7 @@ EXTRACT_ONLY= ${PORTNAME}130${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A compact Finite Element Analysis System
-LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
NO_WRKSUBDIR= yes
USES= pkgconfig