aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2022-10-09 13:44:11 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2022-10-09 13:50:07 +0000
commita32b593e20a3db4ebfc6e6d9df83fd7b8fb2c980 (patch)
tree6af099b4204922d8e9393fec80f77b16a8b66c92
parent5f4279cb21d4773d0370f392adf1e32bd309e1cd (diff)
downloadports-a32b593e20a3db4ebfc6e6d9df83fd7b8fb2c980.tar.gz
ports-a32b593e20a3db4ebfc6e6d9df83fd7b8fb2c980.zip
editors/cooledit: Adopt/Port improvements
Prepare to new release: - Add WWW project url - Build with clang - Use make instead of gmake - Remove unneeded patch (HAVE_MBRTOWC) - Clean compiler flags - Bump PORTREVISION
-rw-r--r--editors/cooledit/Makefile19
-rw-r--r--editors/cooledit/files/patch-widget__widechar.c18
2 files changed, 9 insertions, 28 deletions
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index 0e98097f0dce..dfa40970ed1e 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -1,28 +1,27 @@
PORTNAME= cooledit
DISTVERSION= 3.17.28
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors
MASTER_SITES= SUNSITE/apps/editors/X/cooledit
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Suite of utilities, including a GUI editor
+MAINTAINER= eduardo@FreeBSD.org
+COMMENT= CoolEdit Programmers Code Editor
+WWW= https://github.com/paulsheer/cooledit
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gettext gmake libtool python xorg # gettext is linked to despite .mo files having been deleted
-USE_GCC= yes
+USES= gettext-runtime libtool:build python xorg # gettext is linked to despite .mo files having been deleted
USE_LDCONFIG= yes
USE_XORG= x11 xt
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-CFLAGS+= -DHAVE_MBRTOWC
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+LDFLAGS+= -lpthread
-OPTIONS_DEFINE= NEXT_LOOK
-NEXT_LOOK_DESC= Enable NeXT look
+OPTIONS_DEFINE= NEXT_LOOK
+NEXT_LOOK_DESC= Enable NeXT look
NEXT_LOOK_CONFIGURE_ENABLE= NeXT-look
post-patch:
diff --git a/editors/cooledit/files/patch-widget__widechar.c b/editors/cooledit/files/patch-widget__widechar.c
deleted file mode 100644
index 2d4aa642e314..000000000000
--- a/editors/cooledit/files/patch-widget__widechar.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- widget/widechar.c.orig 2017-08-04 19:12:31 UTC
-+++ widget/widechar.c
-@@ -227,6 +227,7 @@ static inline struct mb_rule apply_mb_ru
- static inline struct mb_rule apply_mb_rules_going_right (WEdit * edit, long byte_index, struct mb_rule mb_rule)
- {
- #ifdef HAVE_WCHAR_H
-+#ifdef HAVE_MBRTOWC
- wchar_t wc;
- unsigned char p[16];
- int n;
-@@ -253,6 +254,7 @@ static inline struct mb_rule apply_mb_ru
- mb_rule.end = 0;
- mb_rule.ch = -1;
- #endif
-+#endif
- return mb_rule;
- }
-