aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 16:23:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 17:03:08 +0000
commita36512fd88e04f2561c984f6bffc96845f28cb8b (patch)
treec9b8012cb1255e711e1b83762130a09566892563
parent16567d7044fd151e4aac9e8adc6edde0ee7540d9 (diff)
downloadports-a36512fd88e04f2561c984f6bffc96845f28cb8b.tar.gz
ports-a36512fd88e04f2561c984f6bffc96845f28cb8b.zip
net/gamenetworkingsockets: Fix build with protobuf 22+
-rw-r--r--net/gamenetworkingsockets/Makefile3
-rw-r--r--net/gamenetworkingsockets/files/patch-CMakeLists.txt11
2 files changed, 13 insertions, 1 deletions
diff --git a/net/gamenetworkingsockets/Makefile b/net/gamenetworkingsockets/Makefile
index 7fa739a62955..de076eb9c1bb 100644
--- a/net/gamenetworkingsockets/Makefile
+++ b/net/gamenetworkingsockets/Makefile
@@ -13,7 +13,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libprotobuf.so:devel/protobuf
-USES= cmake
+USES= cmake compiler:c++17-lang
+
USE_GITHUB= yes
GH_ACCOUNT= ValveSoftware
GH_PROJECT= GameNetworkingSockets
diff --git a/net/gamenetworkingsockets/files/patch-CMakeLists.txt b/net/gamenetworkingsockets/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..ddcae531e29d
--- /dev/null
+++ b/net/gamenetworkingsockets/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2021-05-29 00:43:16 UTC
++++ CMakeLists.txt
+@@ -210,7 +210,7 @@ function(set_target_common_gns_properties TGT)
+ endif()
+
+ set_target_properties(${TGT} PROPERTIES
+- CXX_STANDARD 11
++ CXX_STANDARD 17
+ )
+ endfunction()
+