aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-08 12:04:39 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-08 12:04:39 +0000
commita385a94464cb0b62e7f17e5decfa5087ac9c43c1 (patch)
tree0557a3941c56c311e3ec60223c2eab6939d06033
parentedc9f2983a86f8fa2d4d5de95a7432326667b985 (diff)
downloadports-a385a94464cb0b62e7f17e5decfa5087ac9c43c1.tar.gz
ports-a385a94464cb0b62e7f17e5decfa5087ac9c43c1.zip
emulators/frodo: fix build on powerpc64le
While base GCC can build this port on 12.2, clang can't: VIC.cpp:1407:8: error: expected unqualified-id static asm void fastcopy(register uchar *dst, register uchar *src); ^ VIC.cpp:1408:8: error: expected unqualified-id static asm void fastcopy(register uchar *dst, register uchar *src) ^ VIC.cpp:1838:3: error: use of undeclared identifier 'fastcopy' fastcopy(chunky_line_start, (uint8 *)chunky_tmp); It also can't build with USES=compiler:gcc-c++11-lib. Since this port doesn't have reverse dependencies, use USE_GCC=yes.
-rw-r--r--emulators/frodo/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/emulators/frodo/Makefile b/emulators/frodo/Makefile
index b5b1f9e4535e..e9abd75d9c8e 100644
--- a/emulators/frodo/Makefile
+++ b/emulators/frodo/Makefile
@@ -32,6 +32,10 @@ USES+= sdl
USE_SDL= sdl
.endif
+.if ${ARCH} == powerpc64le
+USE_GCC= yes
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|wish|wish${TK_VER}|' \
${WRKSRC}/C64_x.i