aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-23 15:53:54 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-24 13:08:27 +0000
commita394e0cd6d0821125751118282fb454b161d34a6 (patch)
treeeb88391572935186f52f59da063c624874f53680
parent05056ba2d46a5be1386735c5c589f2950f82b6fd (diff)
print/hp2xx: Optionize INFO
- Utilize USES=localbase - Pet portclippy
-rw-r--r--print/hp2xx/Makefile26
-rw-r--r--print/hp2xx/files/patch-Makefile29
-rw-r--r--print/hp2xx/files/patch-png.c6
3 files changed, 36 insertions, 25 deletions
diff --git a/print/hp2xx/Makefile b/print/hp2xx/Makefile
index 289a6628305b..fee0e58dd32b 100644
--- a/print/hp2xx/Makefile
+++ b/print/hp2xx/Makefile
@@ -13,26 +13,32 @@ LICENSE= GPLv2+
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
-WRKSRC_SUBDIR= sources
+USES= jpeg localbase:ldflags
-USES= makeinfo
-MAKE_ARGS= infodir=${PREFIX}/${INFO_PATH}
MAKE_ENV= DEFINES="${CPPFLAGS}" ALL_LIBS="${LDFLAGS}"
-CPPFLAGS+= -DUNIX -I${LOCALBASE}/include
-LDFLAGS+= -lm -L${LOCALBASE}/lib -ltiff -lpng -lz
+CPPFLAGS+= -DUNIX
+LDFLAGS+= -lm -ltiff -lpng -lz
+
+WRKSRC_SUBDIR= sources
-INFO= hp2xx
PLIST_FILES= bin/hp2xx man/man1/hp2xx.1.gz
-OPTIONS_DEFINE= X11
-OPTIONS_DEFAULT= X11
+OPTIONS_DEFINE= INFO X11
+OPTIONS_DEFAULT= INFO X11
+INFO_USES= makeinfo
+INFO_MAKE_ARGS= infodir=${PREFIX}/${INFO_PATH}
+INFO_INFO= hp2xx
X11_USES= xorg
X11_USE= XORG=x11
X11_MAKE_ENV= PREVIEWER=to_x11
X11_MAKE_ENV_OFF= PREVIEWER=no_prev
-X11_CPPFLAGS= -DHAS_UNIX_X11 -I${LOCALBASE}/include
-X11_LDFLAGS= -L${LOCALBASE}/lib -lX11
+X11_CPPFLAGS= -DHAS_UNIX_X11
+X11_LDFLAGS= -lX11
+
+post-patch-INFO-off:
+ @${REINPLACE_CMD} -e '/^all:/s|hp2xx.info||g; \
+ /^install:/s|install-info||g' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/print/hp2xx/files/patch-Makefile b/print/hp2xx/files/patch-Makefile
index 247d98273af5..4104a0d2f9f7 100644
--- a/print/hp2xx/files/patch-Makefile
+++ b/print/hp2xx/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Sun Jun 22 00:16:34 2003
-+++ Makefile Tue Jun 24 07:53:46 2003
-@@ -35,7 +35,7 @@
+--- Makefile.orig 2003-06-21 15:16:34 UTC
++++ Makefile
+@@ -35,7 +35,7 @@ STRIP = strip
# Installation sites (GNU conventions):
#
@@ -9,7 +9,7 @@
bindir = $(prefix)/bin
includedir = $(prefix)/include
mandir = $(prefix)/man
-@@ -45,14 +45,14 @@
+@@ -45,14 +45,14 @@ infodir = $(prefix)/info
# CC and CFLAGS set for gcc, but any ANSI-C compiler should work.
# For non-gcc compilers, simply set CFLAGS = -O (to start with)
#
@@ -27,7 +27,7 @@
CPPFLAGS = -I. # only sometimes needed; see below for examples
BINDCMD = # only needed for EMX and DJGPP DOS extenders
-@@ -65,9 +65,9 @@
+@@ -65,9 +65,9 @@ BINDCMD = # only needed for EMX and DJ
#
# Generic UNIX + X11 previewer (default)
#
@@ -40,7 +40,7 @@
#
# for experimental truetype font support
#
-@@ -230,13 +230,13 @@
+@@ -230,13 +230,13 @@ ALL_CFLAGS = -c $(CFLAGS)
# $(SRCS) NOT USED YET:
SRCS = clip.c fillpoly.c\
@@ -56,17 +56,18 @@
to_vec.o to_pcx.o to_pcl.o to_eps.o to_img.o to_pbm.o \
to_rgip.o to_fig.o std_main.o $(PREVIEWER).o pendef.o lindef.o $(EX_OBJ)
-@@ -244,7 +244,8 @@
+@@ -244,8 +244,9 @@ PROGRAM = hp2xx
$(PROGRAM): $(OBJS)
$(CC) $(LFLAGS) $(OBJS) $(ALL_LIBS) $(EX_LIBS) -o $(PROGRAM)
- $(BINDCMD)
-+
-+all: $(PROGRAM) hp2xx.info
++all: $(PROGRAM)
++
default:
@echo "This makefile needs manual configuration! Edit it now!
-@@ -268,9 +269,9 @@
+ @echo "After configuration, you may use the following commands:
+@@ -268,9 +269,9 @@ default:
# #
#########################################################################
@@ -79,8 +80,12 @@
#########################################################################
-@@ -330,15 +331,11 @@
- install: install-bin install-info install-man
+@@ -327,18 +328,14 @@ realclean:
+ TAGS:
+ @echo make TAGS -- not supported nor needed.
+
+-install: install-bin install-info install-man
++install: install-bin install-man
install-bin: $(PROGRAM)
- -$(STRIP) $(PROGRAM)
diff --git a/print/hp2xx/files/patch-png.c b/print/hp2xx/files/patch-png.c
index 48162b3d7dae..a3973fd0202a 100644
--- a/print/hp2xx/files/patch-png.c
+++ b/print/hp2xx/files/patch-png.c
@@ -1,5 +1,5 @@
---- png.c.orig 2003-06-21 17:31:51.000000000 +0200
-+++ png.c 2012-05-06 06:59:14.000000000 +0200
+--- png.c.orig 2003-06-21 15:31:51 UTC
++++ png.c
@@ -6,6 +6,7 @@
#include <stdlib.h>
#include "to_png.h"
@@ -8,7 +8,7 @@
#define PDNCOL 256
-@@ -36,7 +37,7 @@
+@@ -36,7 +37,7 @@ FILE *fd;
}
/* set up error handlimg for libpng */