aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-04-23 12:29:42 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-04-23 19:06:07 +0000
commita39d3cd20cde6d947125e8db641c73dd0a554f49 (patch)
treeb6f9ec085f098dd5b6f81a955c69afc361c49f66
parent0ff939e3cfe766c0a4c9ca94636ab49a7d170717 (diff)
downloadports-a39d3cd20cde6d947125e8db641c73dd0a554f49.tar.gz
ports-a39d3cd20cde6d947125e8db641c73dd0a554f49.zip
devel/gitaly: Update to 13.11.1.
This update is required for gitlab-ce 13.11 upgrade.
-rw-r--r--devel/gitaly/Makefile24
-rw-r--r--devel/gitaly/distinfo22
-rw-r--r--devel/gitaly/files/patch-Makefile26
-rw-r--r--devel/gitaly/files/patch-config.toml.example17
-rw-r--r--devel/gitaly/files/patch-ruby_Gemfile16
5 files changed, 52 insertions, 53 deletions
diff --git a/devel/gitaly/Makefile b/devel/gitaly/Makefile
index 89d4e80bb4d0..a8b8c3bc72b5 100644
--- a/devel/gitaly/Makefile
+++ b/devel/gitaly/Makefile
@@ -1,5 +1,5 @@
PORTNAME= gitaly
-DISTVERSION= 13.10.3
+DISTVERSION= 13.11.1
PORTREVISION= 0
CATEGORIES= devel
@@ -10,22 +10,22 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
# define dependencies that are required for build and run under MY_DEPENDS
-MY_DEPENDS= git>=2.29:devel/git \
+MY_DEPENDS= git>=2.31.1:devel/git \
rubygem-bundler>=2.1.4:sysutils/rubygem-bundler \
rubygem-rugged>=1.1<2:devel/rubygem-rugged \
rubygem-github-linguist>=7.12.1<8:textproc/rubygem-github-linguist \
rubygem-gitlab-markup>=1.7.1<1.8.0:textproc/rubygem-gitlab-markup \
- rubygem-activesupport60>=6.0.3.4<6.0.4:devel/rubygem-activesupport60 \
+ rubygem-activesupport60>=6.0.3.6<6.0.4:devel/rubygem-activesupport60 \
rubygem-rdoc>=6.1<7.0:devel/rubygem-rdoc \
rubygem-gitlab-gollum-lib>=4.2.7.10.gitlab.1<4.2.8:www/rubygem-gitlab-gollum-lib \
- rubygem-gitlab-gollum-rugged_adapter>=0.4.4.3.gitlab.1<0.4.5.0:www/rubygem-gitlab-gollum-rugged_adapter \
+ rubygem-gitlab-gollum-rugged_adapter>=0.4.4.4.gitlab.1<0.4.5.0:www/rubygem-gitlab-gollum-rugged_adapter \
rubygem-grpc130>=1.30.2<1.31:net/rubygem-grpc130 \
rubygem-sentry-raven>=3.0<4:devel/rubygem-sentry-raven \
rubygem-faraday>=1.0.1<2:www/rubygem-faraday \
rubygem-rbtrace>=0.4.14:devel/rubygem-rbtrace \
- rubygem-gitlab-labkit>=0.16.1<0.17:devel/rubygem-gitlab-labkit \
+ rubygem-gitlab-labkit>=0.16.2<0.17:devel/rubygem-gitlab-labkit \
rubygem-licensee>=9.14.1<9.15:devel/rubygem-licensee \
- rubygem-google-protobuf314>=3.12.0<3.15:devel/rubygem-google-protobuf314
+ rubygem-google-protobuf314>=3.14.0<3.15:devel/rubygem-google-protobuf314
BUILD_DEPENDS= gem:devel/ruby-gems \
bash>0:shells/bash \
${MY_DEPENDS}
@@ -43,12 +43,12 @@ MAKE_ENV+= ${GO_ENV}
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find this here: https://gitlab.com/gitlab-org/gitaly/-/tags
-GL_COMMIT= 80796c538e2c8f45d311914c3d7a6b22866a0758
+GL_COMMIT= 538266fbaefe35385130e0f3c7b1865cec2a57b0
# for go dependencies
USE_GITHUB= nodefault
# generated with: make gomod-vendor
-# 85dd
+# 89dd
GH_TUPLE= \
DataDog:dd-trace-go:v1.7.0:datadog_dd_trace_go/vendor/gopkg.in/DataDog/dd-trace-go.v1 \
alexbrainman:sspi:909beea2cc74:alexbrainman_sspi/vendor/github.com/alexbrainman/sspi \
@@ -56,7 +56,7 @@ GH_TUPLE= \
beorn7:perks:v1.0.1:beorn7_perks/vendor/github.com/beorn7/perks \
census-instrumentation:opencensus-go:v0.22.2:census_instrumentation_opencensus_go/vendor/go.opencensus.io \
client9:reopen:v1.0.0:client9_reopen/vendor/github.com/client9/reopen \
- cloudflare:tableflip:4baec9811f2b:cloudflare_tableflip/vendor/github.com/cloudflare/tableflip \
+ cloudflare:tableflip:v1.2.2:cloudflare_tableflip/vendor/github.com/cloudflare/tableflip \
HdrHistogram:hdrhistogram-go:3a0bb77429bd:codahale_hdrhistogram_go/vendor/github.com/codahale/hdrhistogram \
containerd:cgroups:2819c83ced99:containerd_cgroups/vendor/github.com/containerd/cgroups \
coreos:go-systemd:v22.0.0:coreos_go_systemd_v22/vendor/github.com/coreos/go-systemd/v22 \
@@ -77,12 +77,14 @@ GH_TUPLE= \
golang:crypto:be400aefbc4c:golang_crypto/vendor/golang.org/x/crypto \
golang:exp:e8c3332aa8e5:golang_exp/vendor/golang.org/x/exp \
golang:groupcache:215e87163ea7:golang_groupcache/vendor/github.com/golang/groupcache \
+ golang:lint:fdd1cda4f05f:golang_lint/vendor/golang.org/x/lint \
golang:net:5f4716e94777:golang_net/vendor/golang.org/x/net \
golang:oauth2:bf48bf16ab8d:golang_oauth2/vendor/golang.org/x/oauth2 \
golang:protobuf:v1.3.3:golang_protobuf/vendor/github.com/golang/protobuf \
golang:sync:6e8e738ad208:golang_sync/vendor/golang.org/x/sync \
- golang:sys:ed752295db88:golang_sys/vendor/golang.org/x/sys \
+ golang:sys:b64e53b001e4:golang_sys/vendor/golang.org/x/sys \
golang:text:v0.3.3:golang_text/vendor/golang.org/x/text \
+ golang:tools:b753a1ba74fa:golang_tools/vendor/golang.org/x/tools \
google:go-cmp:v0.4.0:google_go_cmp/vendor/github.com/google/go-cmp \
google:go-genproto:7949de9c1215:google_go_genproto/vendor/google.golang.org/genproto \
google:pprof:d4f498aebedc:google_pprof/vendor/github.com/google/pprof \
@@ -95,6 +97,7 @@ GH_TUPLE= \
grpc:grpc-go:v1.29.1:grpc_grpc_go/vendor/google.golang.org/grpc \
hashicorp:go-uuid:v1.0.2:hashicorp_go_uuid/vendor/github.com/hashicorp/go-uuid \
hashicorp:golang-lru:v0.5.4:hashicorp_golang_lru/vendor/github.com/hashicorp/golang-lru \
+ hashicorp:yamux:a95892c5f864:hashicorp_yamux/vendor/github.com/hashicorp/yamux \
jcmturner:aescts:v1.0.1:jcmturner_aescts/vendor/gopkg.in/jcmturner/aescts.v1 \
jcmturner:dnsutils:v1.0.1:jcmturner_dnsutils/vendor/gopkg.in/jcmturner/dnsutils.v1 \
jcmturner:gofork:v1.0.0:jcmturner_gofork/vendor/github.com/jcmturner/gofork \
@@ -129,6 +132,7 @@ GH_TUPLE= \
stretchr:objx:v0.1.1:stretchr_objx/vendor/github.com/stretchr/objx \
stretchr:testify:v1.6.1:stretchr_testify/vendor/github.com/stretchr/testify \
tinylib:msgp:v1.1.0:tinylib_msgp/vendor/github.com/tinylib/msgp \
+ uber-go:goleak:v1.1.10:uber_go_goleak/vendor/go.uber.org/goleak \
uber:jaeger-client-go:v2.15.0:uber_jaeger_client_go/vendor/github.com/uber/jaeger-client-go \
uber:jaeger-lib:v1.5.0:uber_jaeger_lib/vendor/github.com/uber/jaeger-lib
diff --git a/devel/gitaly/distinfo b/devel/gitaly/distinfo
index df0ae8e3774c..b4783b5ba674 100644
--- a/devel/gitaly/distinfo
+++ b/devel/gitaly/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1618497419
+TIMESTAMP = 1619179548
SHA256 (DataDog-dd-trace-go-v1.7.0_GH0.tar.gz) = d81bd47683ef9cbd228691b077373d3e15ca5fa5b9e7919099c4e87779040e84
SIZE (DataDog-dd-trace-go-v1.7.0_GH0.tar.gz) = 3321111
SHA256 (alexbrainman-sspi-909beea2cc74_GH0.tar.gz) = 50b452d12987d884f45c85bd2de8ea7076cd54f6f2c8b612a1d4c1704e52b5df
@@ -11,8 +11,8 @@ SHA256 (census-instrumentation-opencensus-go-v0.22.2_GH0.tar.gz) = 0aa930142b669
SIZE (census-instrumentation-opencensus-go-v0.22.2_GH0.tar.gz) = 165321
SHA256 (client9-reopen-v1.0.0_GH0.tar.gz) = 64829db9b9fd0dd94b2444c45a2cb6e926b79c3a2e589a75a5edc2ba488a7875
SIZE (client9-reopen-v1.0.0_GH0.tar.gz) = 6283
-SHA256 (cloudflare-tableflip-4baec9811f2b_GH0.tar.gz) = d9437a27968b8d30e3923c1da75f3fd5b4fca4ea537073a22a089ab35c2106cd
-SIZE (cloudflare-tableflip-4baec9811f2b_GH0.tar.gz) = 16376
+SHA256 (cloudflare-tableflip-v1.2.2_GH0.tar.gz) = c4773f3a8de95bf654d3002d52880940c0d7278ad583f04a850e2759e92cb431
+SIZE (cloudflare-tableflip-v1.2.2_GH0.tar.gz) = 17812
SHA256 (HdrHistogram-hdrhistogram-go-3a0bb77429bd_GH0.tar.gz) = bf9c0b3bc04b0d4ed31e2019240a2854f650b87a383f47824f8af222e58a4001
SIZE (HdrHistogram-hdrhistogram-go-3a0bb77429bd_GH0.tar.gz) = 7738
SHA256 (containerd-cgroups-2819c83ced99_GH0.tar.gz) = 716242603cc675f072031528fab440588dfc1350e4dc037a546234fee52ef7d9
@@ -53,6 +53,8 @@ SHA256 (golang-exp-e8c3332aa8e5_GH0.tar.gz) = 02d36b798456326f37ca4bebc8824c0eaf
SIZE (golang-exp-e8c3332aa8e5_GH0.tar.gz) = 1513507
SHA256 (golang-groupcache-215e87163ea7_GH0.tar.gz) = 500b097a42fb5c0cd516f1bb56e9c745ba6c1c910b4dc7296aea2b9120ee5e70
SIZE (golang-groupcache-215e87163ea7_GH0.tar.gz) = 26040
+SHA256 (golang-lint-fdd1cda4f05f_GH0.tar.gz) = d02215cdf7a8c9e1874406b0414f3799e13e235ed4de142f837f68aa69d6fd55
+SIZE (golang-lint-fdd1cda4f05f_GH0.tar.gz) = 31573
SHA256 (golang-net-5f4716e94777_GH0.tar.gz) = 987ec0774e8480615daf0664cd9c9ec9eb25cf6e553e32ae38697515629714b6
SIZE (golang-net-5f4716e94777_GH0.tar.gz) = 1251426
SHA256 (golang-oauth2-bf48bf16ab8d_GH0.tar.gz) = 28b3a51a8bd90beb5952d1080218ea238127edfe9455ad48921989619ff918a8
@@ -61,10 +63,12 @@ SHA256 (golang-protobuf-v1.3.3_GH0.tar.gz) = b3a1440808d6ed4dc0d194c482de029f6c1
SIZE (golang-protobuf-v1.3.3_GH0.tar.gz) = 315377
SHA256 (golang-sync-6e8e738ad208_GH0.tar.gz) = 011eb5dc95a0ede8be5d68edde93be5af1b88d7fc098d0f74c6f7560beb378f0
SIZE (golang-sync-6e8e738ad208_GH0.tar.gz) = 17288
-SHA256 (golang-sys-ed752295db88_GH0.tar.gz) = 0d6424cced930a084d419bdba3b05f08a2dbc1d534f81b4bebcb7ae73d9de427
-SIZE (golang-sys-ed752295db88_GH0.tar.gz) = 1085924
+SHA256 (golang-sys-b64e53b001e4_GH0.tar.gz) = 4c32d52373df17d9c40604d76e189f274c6fd1386d4d23b9114dbb9805079796
+SIZE (golang-sys-b64e53b001e4_GH0.tar.gz) = 1103798
SHA256 (golang-text-v0.3.3_GH0.tar.gz) = 1604233637e3593749fbbb13b5069b08e6feba6d2b55a02fd3148793d5871185
SIZE (golang-text-v0.3.3_GH0.tar.gz) = 7747332
+SHA256 (golang-tools-b753a1ba74fa_GH0.tar.gz) = f2113b46975e020ac89dcb60e74a5760408c2173cdfbe353ca30a80339a2dc33
+SIZE (golang-tools-b753a1ba74fa_GH0.tar.gz) = 2341520
SHA256 (google-go-cmp-v0.4.0_GH0.tar.gz) = 97964b47aa6dc61007f9e1b1ad67812f0a8a2380072a59daebac7bc0cdcf740a
SIZE (google-go-cmp-v0.4.0_GH0.tar.gz) = 81600
SHA256 (google-go-genproto-7949de9c1215_GH0.tar.gz) = a89e3dc49016b3bc24360b543070e17a429aabdf38a7baa0415846a12319dabb
@@ -89,6 +93,8 @@ SHA256 (hashicorp-go-uuid-v1.0.2_GH0.tar.gz) = 2dee0f810c3e3a2cd3d49a075d0a64a88
SIZE (hashicorp-go-uuid-v1.0.2_GH0.tar.gz) = 7058
SHA256 (hashicorp-golang-lru-v0.5.4_GH0.tar.gz) = d50c188af0cc8b22e7e4b79e9071694fa06428a9964b22d68dc997fa787a177a
SIZE (hashicorp-golang-lru-v0.5.4_GH0.tar.gz) = 13428
+SHA256 (hashicorp-yamux-a95892c5f864_GH0.tar.gz) = 9468ab6cee06cee3e1883a99f5d763bd8d9111e13ce499c5f5f5a705a9979789
+SIZE (hashicorp-yamux-a95892c5f864_GH0.tar.gz) = 24397
SHA256 (jcmturner-aescts-v1.0.1_GH0.tar.gz) = 89d8aa45b05c9cd5e66c40a5c4f3a5224dbf9632d1fd1e27d05f2ad26effae32
SIZE (jcmturner-aescts-v1.0.1_GH0.tar.gz) = 7311
SHA256 (jcmturner-dnsutils-v1.0.1_GH0.tar.gz) = 9781a79a5b46e6ad245d238d1be1b37d8eab9ca9e57edb575ef0af158adeeefb
@@ -157,12 +163,14 @@ SHA256 (stretchr-testify-v1.6.1_GH0.tar.gz) = 40fd7204ab72ca9d8759f1cc3604dd17f5
SIZE (stretchr-testify-v1.6.1_GH0.tar.gz) = 84215
SHA256 (tinylib-msgp-v1.1.0_GH0.tar.gz) = 30ac583b725d84aee147c26d1bc31e8770a3911e8437461cda0e53fb69c54570
SIZE (tinylib-msgp-v1.1.0_GH0.tar.gz) = 77923
+SHA256 (uber-go-goleak-v1.1.10_GH0.tar.gz) = 99ccfd2270aebb09e5c1693094d1da5f47be09689fd515b623657f75e6dc2c40
+SIZE (uber-go-goleak-v1.1.10_GH0.tar.gz) = 12098
SHA256 (uber-jaeger-client-go-v2.15.0_GH0.tar.gz) = 6b89d1a6684475fcbaed3f9d2137df072e2c1f7b15feb69a8ef8963804c44c94
SIZE (uber-jaeger-client-go-v2.15.0_GH0.tar.gz) = 164460
SHA256 (uber-jaeger-lib-v1.5.0_GH0.tar.gz) = 98901cc41df77858a2f601ad48b45bdf72af40c56f15bc5182416b15db0daac3
SIZE (uber-jaeger-lib-v1.5.0_GH0.tar.gz) = 31655
-SHA256 (gitlab-org-gitaly-80796c538e2c8f45d311914c3d7a6b22866a0758_GL0.tar.gz) = 6caa7d7f8ee04b9b455ba84fdd2a04ff16f6b79cd780ae02ac3b4c09c2a3541d
-SIZE (gitlab-org-gitaly-80796c538e2c8f45d311914c3d7a6b22866a0758_GL0.tar.gz) = 3396835
+SHA256 (gitlab-org-gitaly-538266fbaefe35385130e0f3c7b1865cec2a57b0_GL0.tar.gz) = 733010a94f91466721334683969d253abfa67dbc3d19b09475e99754b99a627a
+SIZE (gitlab-org-gitaly-538266fbaefe35385130e0f3c7b1865cec2a57b0_GL0.tar.gz) = 3459810
SHA256 (gitlab-org-gitlab-shell-3f9890ef73dced430d86801a1efc0e93ec50890e_GL0.tar.gz) = 7f5b214e4bd2b72231462c3a153d9b416caab331a1a25a3ca5cd44b02ab9eb15
SIZE (gitlab-org-gitlab-shell-3f9890ef73dced430d86801a1efc0e93ec50890e_GL0.tar.gz) = 89693
SHA256 (gitlab-org-labkit-f2d7fb209ecad2eaddb5fb9c4ab03eb8eaa82811_GL0.tar.gz) = 0ac619ab0bfcbda29f80f0955e86c7ffa1adaa20c96ed546f53fb837633f5d90
diff --git a/devel/gitaly/files/patch-Makefile b/devel/gitaly/files/patch-Makefile
index a4245bea4471..ab17a26152bc 100644
--- a/devel/gitaly/files/patch-Makefile
+++ b/devel/gitaly/files/patch-Makefile
@@ -1,15 +1,6 @@
---- Makefile.orig 2021-03-17 18:58:25 UTC
+--- Makefile.orig 2021-04-22 21:08:06 UTC
+++ Makefile
-@@ -51,7 +51,7 @@ GOLANGCI_LINT_OPTIONS ?=
- GOLANGCI_LINT_CONFIG ?= ${SOURCE_DIR}/.golangci.yml
-
- # Build information
--BUNDLE_FLAGS ?= $(shell test -f ${SOURCE_DIR}/../.gdk-install-root && echo --no-deployment || echo --deployment)
-+BUNDLE_FLAGS ?= $(shell test -f ${SOURCE_DIR}/../.gdk-install-root && echo --no-deployment || echo --local)
- GITALY_PACKAGE := gitlab.com/gitlab-org/gitaly
- BUILD_TIME := $(shell date +"%Y%m%d.%H%M%S")
- GITALY_VERSION := $(shell git describe --match v* 2>/dev/null | sed 's/^v//' || cat ${SOURCE_DIR}/VERSION 2>/dev/null || echo unknown)
-@@ -190,7 +190,7 @@ all: INSTALL_DEST_DIR = ${SOURCE_DIR}
+@@ -197,7 +197,7 @@ all: INSTALL_DEST_DIR = ${SOURCE_DIR}
all: install
.PHONY: build
@@ -18,7 +9,7 @@
go install ${GO_LDFLAGS} -tags "${GO_BUILD_TAGS}" $(addprefix ${GITALY_PACKAGE}/cmd/, $(call find_commands))
.PHONY: install
-@@ -228,7 +228,7 @@ assemble-ruby:
+@@ -235,7 +235,7 @@ assemble-ruby:
.PHONY: binaries
binaries: assemble
${Q}if [ ${ARCH} != 'x86_64' ]; then echo Incorrect architecture for build: ${ARCH}; exit 1; fi
@@ -27,17 +18,18 @@
.PHONY: prepare-tests
prepare-tests: git libgit2 prepare-test-repos ${SOURCE_DIR}/.ruby-bundle
-@@ -381,8 +381,7 @@ libgit2: ${LIBGIT2_INSTALL_DIR}/lib/libgit2.a
+@@ -388,9 +388,7 @@ libgit2: ${LIBGIT2_INSTALL_DIR}/lib/libgit2.a
# step. Both Omnibus and CNG assume it is in the Gitaly root, not in
# _build. Hence the '../' in front.
${SOURCE_DIR}/.ruby-bundle: ${GITALY_RUBY_DIR}/Gemfile.lock ${GITALY_RUBY_DIR}/Gemfile
+- ${Q}cd ${GITALY_RUBY_DIR} && bundle config set --local deployment "${BUNDLE_DEPLOYMENT}"
- ${Q}cd ${GITALY_RUBY_DIR} && bundle config # for debugging
-- ${Q}cd ${GITALY_RUBY_DIR} && bundle install ${BUNDLE_FLAGS}
-+ ${Q}cd ${GITALY_RUBY_DIR} && rm -f Gemfile.lock && bundle install ${BUNDLE_FLAGS}
+- ${Q}cd ${GITALY_RUBY_DIR} && bundle install
++ ${Q}cd ${GITALY_RUBY_DIR} && rm -f Gemfile.lock && bundle install --local
${Q}touch $@
${SOURCE_DIR}/NOTICE: ${BUILD_DIR}/NOTICE
-@@ -445,7 +444,7 @@ ${GIT_INSTALL_DIR}/bin/git: ${DEPENDENCY_DIR}/git.vers
+@@ -457,7 +455,7 @@ endif
else
${DEPENDENCY_DIR}/git_full_bins.tgz: ${DEPENDENCY_DIR}/git.version
curl -o $@.tmp --silent --show-error -L ${GIT_BINARIES_URL}
@@ -46,7 +38,7 @@
${Q}mv $@.tmp $@
${GIT_INSTALL_DIR}/bin/git: ${DEPENDENCY_DIR}/git_full_bins.tgz
-@@ -458,7 +457,7 @@ ${TOOLS_DIR}/protoc.zip: TOOL_VERSION = ${PROTOC_VERSI
+@@ -470,7 +468,7 @@ ${TOOLS_DIR}/protoc.zip: TOOL_VERSION = ${PROTOC_VERSI
${TOOLS_DIR}/protoc.zip: ${TOOLS_DIR}/protoc.version
${Q}if [ -z "${PROTOC_URL}" ]; then echo "Cannot generate protos on unsupported platform ${OS}" && exit 1; fi
curl -o $@.tmp --silent --show-error -L ${PROTOC_URL}
diff --git a/devel/gitaly/files/patch-config.toml.example b/devel/gitaly/files/patch-config.toml.example
index 33a08e4486c2..758d0dcb28ce 100644
--- a/devel/gitaly/files/patch-config.toml.example
+++ b/devel/gitaly/files/patch-config.toml.example
@@ -1,4 +1,4 @@
---- config.toml.example.orig 2020-09-21 16:21:08 UTC
+--- config.toml.example.orig 2021-04-22 21:08:06 UTC
+++ config.toml.example
@@ -2,10 +2,10 @@
# Documentation lives at https://docs.gitlab.com/ee/administration/gitaly/ and
@@ -13,15 +13,20 @@
# # Optional: listen on a TCP socket. This is insecure (no authentication)
# listen_addr = "localhost:9999"
-@@ -29,13 +29,13 @@ bin_dir = "/home/git/gitaly"
+@@ -28,9 +28,9 @@ bin_dir = "/home/git/gitaly"
+ # certificate_path = '/home/git/cert.cert'
# key_path = '/home/git/key.pem'
- # # Git settings
+-# # Git settings
-# [git]
-# bin_path = "/usr/bin/git"
++# Git settings
+[git]
+bin_path = "%%PREFIX%%/bin/git"
# catfile_cache_size = 100
+ # [[git.config]]
+ # key = fetch.fsckObjects
+@@ -38,7 +38,7 @@ bin_dir = "/home/git/gitaly"
[[storage]]
name = "default"
@@ -30,7 +35,7 @@
# # You can optionally configure more storages for this Gitaly instance to serve up
#
-@@ -47,7 +47,7 @@ path = "/home/git/repositories"
+@@ -50,7 +50,7 @@ path = "/home/git/repositories"
# # You can optionally configure Gitaly to output JSON-formatted log messages to stdout
# [logging]
# # The directory where Gitaly stores extra log files
@@ -39,7 +44,7 @@
# format = "json"
# # Optional: Set log level to only log entries with that severity or above
# # One of, in order: debug, info, warn, errror, fatal, panic
-@@ -65,7 +65,7 @@ dir = "/home/git/gitlab/log"
+@@ -68,7 +68,7 @@ dir = "/home/git/gitlab/log"
[gitaly-ruby]
# The directory where gitaly-ruby is installed
@@ -48,7 +53,7 @@
# # Gitaly-ruby resident set size (RSS) that triggers a memory restart (bytes)
# max_rss = 200000000
-@@ -85,14 +85,14 @@ dir = "/home/git/gitaly/ruby"
+@@ -88,14 +88,14 @@ dir = "/home/git/gitaly/ruby"
[gitlab-shell]
# The directory where gitlab-shell is installed
diff --git a/devel/gitaly/files/patch-ruby_Gemfile b/devel/gitaly/files/patch-ruby_Gemfile
index 1edec7ee3614..86bfa219997c 100644
--- a/devel/gitaly/files/patch-ruby_Gemfile
+++ b/devel/gitaly/files/patch-ruby_Gemfile
@@ -1,18 +1,8 @@
---- ruby/Gemfile.orig 2021-03-17 18:58:25 UTC
+--- ruby/Gemfile.orig 2021-04-22 21:08:06 UTC
+++ ruby/Gemfile
-@@ -13,21 +13,11 @@ gem 'faraday', '~> 1.0'
- gem 'rbtrace', require: false
+@@ -21,13 +21,3 @@ gem 'licensee', '~> 9.14.1'
- # Labkit provides observability functionality
--gem 'gitlab-labkit', '~> 0.15.0'
-+gem 'gitlab-labkit', '~> 0.16.1'
-
- # Detects the open source license the repository includes
- # This version needs to be in sync with GitLab CE/EE
- gem 'licensee', '~> 9.14.1'
-
--gem 'google-protobuf', '~> 3.12'
-+gem 'google-protobuf', '~> 3.14.0'
+ gem 'google-protobuf', '~> 3.14.0'
-group :development, :test do
- gem 'rubocop', '~> 0.69', require: false