aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 15:47:28 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 16:22:19 +0000
commita4135938b1019a9defb46b5edf128b019073ac5b (patch)
tree664fd1bab1c8a475efb0167bc566186d2b809210
parented919666b65788a22619ae4f956a482a3380de94 (diff)
downloadports-a4135938b1019a9defb46b5edf128b019073ac5b.tar.gz
ports-a4135938b1019a9defb46b5edf128b019073ac5b.zip
editors/e93: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--editors/e93/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/editors/e93/Makefile b/editors/e93/Makefile
index a30514741c22..43a60b90a1ea 100644
--- a/editors/e93/Makefile
+++ b/editors/e93/Makefile
@@ -20,6 +20,16 @@ PORTDOCS= README* TODO
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CFLAGS=|CFLAGS\+=|g' \
+ ${WRKSRC}/xgui/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/e93 ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/e93lib
@@ -29,4 +39,4 @@ do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>